aboutsummaryrefslogtreecommitdiff
path: root/math/chryzodus/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-11 19:25:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-11 19:25:17 +0000
commit5d7dcdec462a1e66891ba4ef178ccfc2c88016d3 (patch)
tree34d2fa2d280a591e71fb76d52f28f1b48eb6621a /math/chryzodus/Makefile
parent3808749df3ed9b6980a6b6003903720f9424e2d1 (diff)
downloadports-5d7dcdec462a1e66891ba4ef178ccfc2c88016d3.tar.gz
ports-5d7dcdec462a1e66891ba4ef178ccfc2c88016d3.zip
Chryzodus is a cross-platform graphical program drawing
beautiful and colorful chryzodes. If you do not know what chryzodes are, take a look at http://www.chryzode.org/. Then you will be able to explore the world of chryzodes by yourself using Chryzodus. But one does not even need to know much about chryzodes to use Chryzodus and see beautiful images appear on the screen! PR: ports/83234 Submitted by: Nicola Vitale <nivit@email.it>
Notes
Notes: svn path=/head/; revision=138937
Diffstat (limited to 'math/chryzodus/Makefile')
-rw-r--r--math/chryzodus/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/math/chryzodus/Makefile b/math/chryzodus/Makefile
new file mode 100644
index 000000000000..a280d709e161
--- /dev/null
+++ b/math/chryzodus/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: chryzodus
+# Date created: 2005-07-09
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= chryzodus
+PORTVERSION= 0.32
+DISTVERSIONSUFFIX= -src
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= nivit@email.it
+COMMENT= A chryzode (http//www.chryzode.org) explorer
+
+LIB_DEPENDS= alleg.41:${PORTSDIR}/devel/allegro
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKEFILE= makefile.unx
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}; \
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>