aboutsummaryrefslogtreecommitdiff
path: root/math/dcdflib/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-12-24 07:04:38 +0000
committerSteve Price <steve@FreeBSD.org>1998-12-24 07:04:38 +0000
commite4b2e8c27f0255b31a0e5501eeea78ce02c5e400 (patch)
tree84daf8bd08f75c0e71593a20485b63c420530821 /math/dcdflib/Makefile
parent5e84dd40c1c055c6e963b9247346a0ca409b9b81 (diff)
downloadports-e4b2e8c27f0255b31a0e5501eeea78ce02c5e400.tar.gz
ports-e4b2e8c27f0255b31a0e5501eeea78ce02c5e400.zip
Initial import of dcdflib version 1.1.
A library of C routines for cumulative distribution functions. PR: 7865 Submitted by: Anton Berezin <tobez@plab.ku.dk>
Notes
Notes: svn path=/head/; revision=15563
Diffstat (limited to 'math/dcdflib/Makefile')
-rw-r--r--math/dcdflib/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/math/dcdflib/Makefile b/math/dcdflib/Makefile
new file mode 100644
index 000000000000..1ea8a650b76e
--- /dev/null
+++ b/math/dcdflib/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: dcdflib
+# Version required: 1.1
+# Date created: 08 September 1998
+# Whom: Anton Berezin <tobez@plab.ku.dk>
+#
+# $Id$
+#
+
+DISTNAME= dcdflib.c-1.1
+CATEGORIES= math
+MASTER_SITES= ftp://odin.mda.uth.tmc.edu/pub/source/
+
+MAINTAINER= tobez@plab.ku.dk
+
+WRKSRC= ${WRKDIR}/dcdflib.c/src
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ @${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/dcdflib
+ @${INSTALL_DATA} ${WRKSRC}/../doc/dcdflib.chs ${PREFIX}/share/doc/dcdflib
+ @${INSTALL_DATA} ${WRKSRC}/../doc/dcdflib.fdoc ${PREFIX}/share/doc/dcdflib
+ @${INSTALL_DATA} ${WRKSRC}/../README ${PREFIX}/share/doc/dcdflib
+.endif
+.if ${PORTOBJFORMAT} == "aout"
+ @${LN} -sf libdcdflib.so.1.1 ${PREFIX}/lib/libdcdflib.so
+.endif
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+
+.include <bsd.port.post.mk>