aboutsummaryrefslogtreecommitdiff
path: root/math/emacs-calc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-13 15:31:02 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-13 15:31:02 +0000
commit767a3e989dc8f6046771ddb3b960e76655649611 (patch)
tree52b51799c5be41a0145b8eb306f3c84f12717809 /math/emacs-calc
parent36ffedf9c8ce247acc61818face5cfd98651667c (diff)
downloadports-767a3e989dc8f6046771ddb3b960e76655649611.tar.gz
ports-767a3e989dc8f6046771ddb3b960e76655649611.zip
Emacs Calc can do arbitrary precision arithmetic, operations on matrices,
complex numbers, calendar dates and various other types, plus symbolic algebra and calculus, graphics, and lots more. Calc also comes with an extensive manual which you can print or read on-line. PR: ports/83238 Submitted by: Andrew Bernard <andrewb@cs.cmu.edu>
Notes
Notes: svn path=/head/; revision=139096
Diffstat (limited to 'math/emacs-calc')
-rw-r--r--math/emacs-calc/Makefile23
-rw-r--r--math/emacs-calc/distinfo2
-rw-r--r--math/emacs-calc/files/patch-AA-emacs-21.3-PROBLEMS256
-rw-r--r--math/emacs-calc/files/patch-Makefile55
-rw-r--r--math/emacs-calc/files/patch-calc-autoload.el19
-rw-r--r--math/emacs-calc/files/patch-calc.texinfo14
-rw-r--r--math/emacs-calc/pkg-descr14
-rw-r--r--math/emacs-calc/pkg-plist47
8 files changed, 430 insertions, 0 deletions
diff --git a/math/emacs-calc/Makefile b/math/emacs-calc/Makefile
new file mode 100644
index 000000000000..586de8804e13
--- /dev/null
+++ b/math/emacs-calc/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: emacs-calc
+# Date created: 7/10/5
+# Whom: andrewb@cs.cmu.edu
+#
+# $FreeBSD$
+#
+
+PORTNAME= calc
+PORTVERSION= 2.02f
+CATEGORIES= math editors
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= emacs-
+
+MAINTAINER= andrewb@cs.cmu.edu
+COMMENT= Arbitrary-precision calculator for Emacs
+
+RUN_DEPENDS= emacs:${PORTSDIR}/editors/emacs
+BUILD_DEPENDS= emacs:${PORTSDIR}/editors/emacs
+
+INFO= calc
+
+.include <bsd.port.mk>
diff --git a/math/emacs-calc/distinfo b/math/emacs-calc/distinfo
new file mode 100644
index 000000000000..a4afd70370e8
--- /dev/null
+++ b/math/emacs-calc/distinfo
@@ -0,0 +1,2 @@
+MD5 (calc-2.02f.tar.gz) = fbeb5535bdc35a8dbca3a8482ea2984a
+SIZE (calc-2.02f.tar.gz) = 831865
diff --git a/math/emacs-calc/files/patch-AA-emacs-21.3-PROBLEMS b/math/emacs-calc/files/patch-AA-emacs-21.3-PROBLEMS
new file mode 100644
index 000000000000..c393d6acc325
--- /dev/null
+++ b/math/emacs-calc/files/patch-AA-emacs-21.3-PROBLEMS
@@ -0,0 +1,256 @@
+# from /usr/local/share/emacs/21.3/etc/PROBLEMS
+--- calc-ext.el.~1~ Sun Apr 3 02:26:34 1994
++++ calc-ext.el Wed Sep 18 17:35:01 1996
+@@ -1354,6 +1354,25 @@
+ (calc-fancy-prefix 'calc-inverse-flag "Inverse..." n)
+ )
+
++(defconst calc-fancy-prefix-map
++ (let ((map (make-sparse-keymap)))
++ (define-key map [t] 'calc-fancy-prefix-other-key)
++ (define-key map (vector meta-prefix-char t) 'calc-fancy-prefix-other-key)
++ (define-key map [switch-frame] nil)
++ (define-key map [?\C-u] 'universal-argument)
++ (define-key map [?0] 'digit-argument)
++ (define-key map [?1] 'digit-argument)
++ (define-key map [?2] 'digit-argument)
++ (define-key map [?3] 'digit-argument)
++ (define-key map [?4] 'digit-argument)
++ (define-key map [?5] 'digit-argument)
++ (define-key map [?6] 'digit-argument)
++ (define-key map [?7] 'digit-argument)
++ (define-key map [?8] 'digit-argument)
++ (define-key map [?9] 'digit-argument)
++ map)
++ "Keymap used while processing calc-fancy-prefix.")
++
+ (defun calc-fancy-prefix (flag msg n)
+ (let (prefix)
+ (calc-wrapper
+@@ -1364,6 +1383,8 @@
+ (message (if prefix msg "")))
+ (and prefix
+ (not calc-is-keypad-press)
++ (if (boundp 'overriding-terminal-local-map)
++ (setq overriding-terminal-local-map calc-fancy-prefix-map)
+ (let ((event (calc-read-key t)))
+ (if (eq (setq last-command-char (car event)) ?\C-u)
+ (universal-argument)
+@@ -1376,9 +1397,18 @@
+ (if (or (not (integerp last-command-char))
+ (eq last-command-char ?-))
+ (calc-unread-command)
+- (digit-argument n))))))
++ (digit-argument n)))))))
+ )
+ (setq calc-is-keypad-press nil)
++
++(defun calc-fancy-prefix-other-key (arg)
++ (interactive "P")
++ (if (or (not (integerp last-command-char))
++ (and (>= last-command-char 0) (< last-command-char ? )
++ (not (eq last-command-char meta-prefix-char))))
++ (calc-wrapper)) ; clear flags if not a Calc command.
++ (calc-unread-command)
++ (setq overriding-terminal-local-map nil))
+
+ (defun calc-invert-func ()
+ (save-excursion
+
+Index: Makefile
+--- Makefile.~1~ Sun Dec 15 23:50:45 1996
++++ Makefile Thu Nov 30 15:09:45 2000
+@@ -41,7 +41,7 @@
+
+ # Other macros.
+ EFLAGS = -batch
+-MAINT = -l calc-maint.elc
++MAINT = -l calc-maint.el
+
+ # Control whether intermediate files are kept.
+ PURGE = -rm -f
+@@ -154,10 +154,7 @@
+
+
+ # All this because "-l calc-maint" doesn't work.
+-maint: calc-maint.elc
+-calc-maint.elc: calc-maint.el
+- cp calc-maint.el calc-maint.elc
+-
++maint: calc-maint.el
+
+ # Create an Emacs TAGS file
+ tags: TAGS
+
+Index: calc-aent.el
+--- calc-aent.el.~1~ Sun Dec 15 23:50:36 1996
++++ calc-aent.el Tue Nov 21 18:34:33 2000
+@@ -385,7 +385,7 @@
+ (calc-minibuffer-contains
+ "\\`\\([^\"]*\"[^\"]*\"\\)*[^\"]*\"[^\"]*\\'"))
+ (insert "`")
+- (setq alg-exp (buffer-string))
++ (setq alg-exp (field-string))
+ (and (> (length alg-exp) 0) (setq calc-previous-alg-entry alg-exp))
+ (exit-minibuffer))
+ )
+@@ -393,14 +393,14 @@
+
+ (defun calcAlg-enter ()
+ (interactive)
+- (let* ((str (buffer-string))
++ (let* ((str (field-string))
+ (exp (and (> (length str) 0)
+ (save-excursion
+ (set-buffer calc-buffer)
+ (math-read-exprs str)))))
+ (if (eq (car-safe exp) 'error)
+ (progn
+- (goto-char (point-min))
++ (goto-char (field-beginning))
+ (forward-char (nth 1 exp))
+ (beep)
+ (calc-temp-minibuffer-message
+@@ -455,14 +455,14 @@
+ (interactive)
+ (if (calc-minibuffer-contains ".*[@oh] *[^'m ]+[^'m]*\\'")
+ (calcDigit-key)
+- (setq calc-digit-value (buffer-string))
++ (setq calc-digit-value (field-string))
+ (exit-minibuffer))
+ )
+
+ (defun calcDigit-edit ()
+ (interactive)
+ (calc-unread-command)
+- (setq calc-digit-value (buffer-string))
++ (setq calc-digit-value (field-string))
+ (exit-minibuffer)
+ )
+
+Index: calc.el
+--- calc.el.~1~ Sun Dec 15 23:50:47 1996
++++ calc.el Wed Nov 22 13:08:49 2000
+@@ -2051,11 +2051,11 @@
+ ;; Exercise for the reader: Figure out why this is a good precaution!
+ (or (boundp 'calc-buffer)
+ (use-local-map minibuffer-local-map))
+- (let ((str (buffer-string)))
++ (let ((str (field-string)))
+ (setq calc-digit-value (save-excursion
+ (set-buffer calc-buffer)
+ (math-read-number str))))
+- (if (and (null calc-digit-value) (> (buffer-size) 0))
++ (if (and (null calc-digit-value) (> (field-end) (field-beginning)))
+ (progn
+ (beep)
+ (calc-temp-minibuffer-message " [Bad format]"))
+@@ -2071,7 +2071,7 @@
+
+ (defun calc-minibuffer-contains (rex)
+ (save-excursion
+- (goto-char (point-min))
++ (goto-char (field-end (point-min)))
+ (looking-at rex))
+ )
+
+@@ -2158,10 +2158,8 @@
+ (upcase last-command-char))))
+ (and dig
+ (< dig radix)))))))
+- (save-excursion
+- (goto-char (point-min))
+- (looking-at
+- "[-+]?\\(.*\\+/- *\\|.*mod *\\)?\\([0-9]+\\.?0*[@oh] *\\)?\\([0-9]+\\.?0*['m] *\\)?[0-9]*\\(\\.?[0-9]*\\(e[-+]?[0-3]?[0-9]?[0-9]?[0-9]?[0-9]?[0-9]?[0-9]?\\)?\\|[0-9]:\\([0-9]+:\\)?[0-9]*\\)?[\"s]?\\'")))
++ (calc-minibuffer-contains
++ "[-+]?\\(.*\\+/- *\\|.*mod *\\)?\\([0-9]+\\.?0*[@oh] *\\)?\\([0-9]+\\.?0*['m] *\\)?[0-9]*\\(\\.?[0-9]*\\(e[-+]?[0-3]?[0-9]?[0-9]?[0-9]?[0-9]?[0-9]?[0-9]?\\)?\\|[0-9]:\\([0-9]+:\\)?[0-9]*\\)?[\"s]?\\'"))
+ (if (and (memq last-command-char '(?@ ?o ?h ?\' ?m))
+ (string-match " " calc-hms-format))
+ (insert " "))
+@@ -2190,7 +2188,7 @@
+ ((eq last-command 'calcDigit-start)
+ (erase-buffer))
+ (t (backward-delete-char 1)))
+- (if (= (buffer-size) 0)
++ (if (= (field-beginning) (field-end))
+ (progn
+ (setq last-command-char 13)
+ (calcDigit-nondigit)))
+
+* TeX'ing the Calc manual fails.
+
+The following patches allow to build the Calc manual using texinfo.tex
+from Emacs 19.34 distribution:
+
+*** calc-maint.e~0 Mon Dec 16 07:11:26 1996
+--- calc-maint.el Sun Dec 10 14:32:38 2000
+***************
+*** 308,314 ****
+ (insert "@tex\n"
+ "\\global\\advance\\appendixno2\n"
+ "\\gdef\\xref#1.{See ``#1.''}\n")
+! (setq midpos (point))
+ (insert "@end tex\n")
+ (insert-buffer-substring srcbuf sumpos endpos)
+ (insert "@bye\n")
+--- 308,314 ----
+ (insert "@tex\n"
+ "\\global\\advance\\appendixno2\n"
+ "\\gdef\\xref#1.{See ``#1.''}\n")
+! (setq midpos (point-marker))
+ (insert "@end tex\n")
+ (insert-buffer-substring srcbuf sumpos endpos)
+ (insert "@bye\n")
+*** Makefile.~0 Mon Dec 16 07:11:24 1996
+--- Makefile Sun Dec 10 14:44:00 2000
+***************
+*** 98,106 ****
+ # Format the Calc manual as one printable volume using TeX.
+ tex:
+ $(REMOVE) calc.aux
+! $(TEX) calc.texinfo
+ $(TEXINDEX) calc.[cfkptv]?
+! $(TEX) calc.texinfo
+ $(PURGE) calc.cp calc.fn calc.pg calc.tp calc.vr
+ $(PURGE) calc.cps calc.fns calc.kys calc.pgs calc.tps calc.vrs
+ $(PURGE) calc.toc
+--- 98,106 ----
+ # Format the Calc manual as one printable volume using TeX.
+ tex:
+ $(REMOVE) calc.aux
+! -$(TEX) calc.texinfo
+ $(TEXINDEX) calc.[cfkptv]?
+! -$(TEX) calc.texinfo
+ $(PURGE) calc.cp calc.fn calc.pg calc.tp calc.vr
+ $(PURGE) calc.cps calc.fns calc.kys calc.pgs calc.tps calc.vrs
+ $(PURGE) calc.toc
+*** calc.texinfo.~1~ Thu Oct 10 18:18:56 1996
+--- calc.texinfo Mon Dec 11 08:25:00 2000
+***************
+*** 12,17 ****
+--- 12,19 ----
+ % Because makeinfo.c exists, we can't just define new commands.
+ % So instead, we take over little-used existing commands.
+ %
++ % Suggested by Karl Berry <karl@@freefriends.org>
++ \gdef\!{\mskip-\thinmuskip}
+ % Redefine @cite{text} to act like $text$ in regular TeX.
+ % Info will typeset this same as @samp{text}.
+ \gdef\goodtex{\tex \let\rm\goodrm \let\t\ttfont \turnoffactive}
+***************
+*** 23686,23692 ****
+ a vector of the actual parameter values, written as equations:
+ @cite{[a = 3, b = 2]}, in case you'd rather read them in a list
+ than pick them out of the formula. (You can type @kbd{t y}
+! to move this vector to the stack; @pxref{Trail Commands}.)
+
+ Specifying a different independent variable name will affect the
+ resulting formula: @kbd{a F 1 k RET} produces @kbd{3 + 2 k}.
+--- 23689,23695 ----
+ a vector of the actual parameter values, written as equations:
+ @cite{[a = 3, b = 2]}, in case you'd rather read them in a list
+ than pick them out of the formula. (You can type @kbd{t y}
+! to move this vector to the stack; see @ref{Trail Commands}.)
+
+ Specifying a different independent variable name will affect the
+ resulting formula: @kbd{a F 1 k RET} produces @kbd{3 + 2 k}.
diff --git a/math/emacs-calc/files/patch-Makefile b/math/emacs-calc/files/patch-Makefile
new file mode 100644
index 000000000000..1a20da7024c9
--- /dev/null
+++ b/math/emacs-calc/files/patch-Makefile
@@ -0,0 +1,55 @@
+--- Makefile.orig Sun Jul 10 10:59:15 2005
++++ Makefile Sun Jul 10 11:24:42 2005
+@@ -52,13 +52,13 @@
+ # Do full Calc installation. (Note that `make' == `make all'.)
+ # These are written this way instead of `all: compile private info'
+ # to make the steps more explicit while the `make' is in progress.
+-all:
++all.orig:
+ $(MAKE) compile
+ $(MAKE) private
+ $(MAKE) info
+ $(ECHO) "Calc is now installed."
+
+-install:
++install.orig:
+ $(MAKE) compile
+ $(MAKE) public
+ $(MAKE) info
+@@ -180,4 +180,36 @@
+ $(REMOVE) calctut.*
+ $(REMOVE) calcsum.*
+
++# FreeBSD installation
++
++prefix = /usr/local
++infodir = ${prefix}/info
++sharedir = ${prefix}/share
++emacssharedir = ${sharedir}/emacs
++emacssitedir = ${emacssharedir}/site-lisp
++calcsitedir = ${emacssitedir}/calc
++
++elcfiles != find . -name '*.elc' -type f
++infofiles != find . -name 'calc.info*' -type f
++sitefiles = INSTALL README README.prev ${elcfiles}
++
++installfiles := ${infofiles:%=$(infodir)/%} ${sitefiles:%=$(calcsitedir)/%}
++
++all:
++ $(MAKE) compile
++ $(MAKE) info
++
++install: ${installfiles}
++ install-info ${infodir}/calc.info ${infodir}/dir
++
++.for file in ${infofiles}
++${infodir}/${file}: ${file}
++ install -o root -g wheel -m 0444 $? $@
++.endfor
++
++.for file in ${sitefiles}
++${calcsitedir}/${file}: ${file}
++ @install -d -o root -g wheel -m 0755 ${@D}
++ install -o root -g wheel -m 0444 $? $@
++.endfor
+
diff --git a/math/emacs-calc/files/patch-calc-autoload.el b/math/emacs-calc/files/patch-calc-autoload.el
new file mode 100644
index 000000000000..b0da974607b8
--- /dev/null
+++ b/math/emacs-calc/files/patch-calc-autoload.el
@@ -0,0 +1,19 @@
+--- calc-autoload.el.orig Wed Dec 31 19:00:00 1969
++++ calc-autoload.el Sun Jul 10 12:05:24 2005
+@@ -0,0 +1,16 @@
++
++(global-set-key '[?\M-# ?c] 'calc)
++
++(autoload 'defmath "calc" nil t t)
++(autoload 'calc-eval "calc" "Use Calculator from Lisp" )
++(autoload 'calc-dispatch "calc" "Calculator Options" t)
++(autoload 'full-calc "calc" "Full-screen Calculator" t)
++(autoload 'full-calc-keypad "calc" "Full-screen X Calculator" t)
++(autoload 'calc "calc" "Calculator Mode" t)
++(autoload 'quick-calc "calc" "Quick Calculator" t)
++(autoload 'calc-keypad "calc" "X windows Calculator" t)
++(autoload 'calc-embedded "calc" "Use Calc inside any buffer" t)
++(autoload 'calc-embedded-activate "calc" "Activate =>'s in buffer" t)
++(autoload 'calc-grab-region "calc" "Grab region of Calc data" t)
++(autoload 'calc-grab-rectangle "calc" "Grab rectangle of data" t)
++
diff --git a/math/emacs-calc/files/patch-calc.texinfo b/math/emacs-calc/files/patch-calc.texinfo
new file mode 100644
index 000000000000..9d4295edcec9
--- /dev/null
+++ b/math/emacs-calc/files/patch-calc.texinfo
@@ -0,0 +1,14 @@
+--- calc.texinfo.orig Sun Jul 10 11:30:45 2005
++++ calc.texinfo Sun Jul 10 11:33:21 2005
+@@ -172,6 +172,11 @@
+ \catcode`\@=0 @catcode`@\=@active
+ @end iftex
+
++@dircategory The Emacs editor and associated tools
++@direntry
++* Calc: (calc). The Emacs calculator
++@end direntry
++
+ @ifinfo
+ This file documents Calc, the GNU Emacs calculator.
+
diff --git a/math/emacs-calc/pkg-descr b/math/emacs-calc/pkg-descr
new file mode 100644
index 000000000000..3cbbc26c228b
--- /dev/null
+++ b/math/emacs-calc/pkg-descr
@@ -0,0 +1,14 @@
+Emacs Calc can do arbitrary precision arithmetic, operations on matrices,
+complex numbers, calendar dates and various other types, plus symbolic
+algebra and calculus, graphics, and lots more. Calc also comes with an
+extensive manual which you can print or read on-line.
+
+-- the Emacs Calc home page
+
+WWW: http://www.synaptics.com/people/daveg
+
+Add
+ (load "calc-autoload")
+to your .emacs file to define autoloads.
+
+Maintainer: Andrew Bernard (andrewb@cs.cmu.edu)
diff --git a/math/emacs-calc/pkg-plist b/math/emacs-calc/pkg-plist
new file mode 100644
index 000000000000..1a813c14e578
--- /dev/null
+++ b/math/emacs-calc/pkg-plist
@@ -0,0 +1,47 @@
+share/emacs/site-lisp/calc/INSTALL
+share/emacs/site-lisp/calc/README
+share/emacs/site-lisp/calc/README.prev
+share/emacs/site-lisp/calc/calc.elc
+share/emacs/site-lisp/calc/calc-alg-2.elc
+share/emacs/site-lisp/calc/calc-autoload.elc
+share/emacs/site-lisp/calc/calc-ext.elc
+share/emacs/site-lisp/calc/calc-aent.elc
+share/emacs/site-lisp/calc/calc-embed.elc
+share/emacs/site-lisp/calc/calc-comb.elc
+share/emacs/site-lisp/calc/calc-alg-3.elc
+share/emacs/site-lisp/calc/calc-alg.elc
+share/emacs/site-lisp/calc/calc-arith.elc
+share/emacs/site-lisp/calc/calc-bin.elc
+share/emacs/site-lisp/calc/calc-comp.elc
+share/emacs/site-lisp/calc/calc-cplx.elc
+share/emacs/site-lisp/calc/calc-forms.elc
+share/emacs/site-lisp/calc/calc-fin.elc
+share/emacs/site-lisp/calc/calc-funcs.elc
+share/emacs/site-lisp/calc/calc-frac.elc
+share/emacs/site-lisp/calc/calc-graph.elc
+share/emacs/site-lisp/calc/calc-help.elc
+share/emacs/site-lisp/calc/calc-incom.elc
+share/emacs/site-lisp/calc/calc-keypd.elc
+share/emacs/site-lisp/calc/calc-lang.elc
+share/emacs/site-lisp/calc/calc-macs.elc
+share/emacs/site-lisp/calc/calc-maint.elc
+share/emacs/site-lisp/calc/calc-map.elc
+share/emacs/site-lisp/calc/calc-mat.elc
+share/emacs/site-lisp/calc/calc-math.elc
+share/emacs/site-lisp/calc/calc-misc.elc
+share/emacs/site-lisp/calc/calc-mode.elc
+share/emacs/site-lisp/calc/calc-poly.elc
+share/emacs/site-lisp/calc/calc-prog.elc
+share/emacs/site-lisp/calc/calc-rewr.elc
+share/emacs/site-lisp/calc/calc-rules.elc
+share/emacs/site-lisp/calc/calc-sel-2.elc
+share/emacs/site-lisp/calc/calc-sel.elc
+share/emacs/site-lisp/calc/calc-stat.elc
+share/emacs/site-lisp/calc/calc-store.elc
+share/emacs/site-lisp/calc/calc-stuff.elc
+share/emacs/site-lisp/calc/calc-trail.elc
+share/emacs/site-lisp/calc/calc-undo.elc
+share/emacs/site-lisp/calc/calc-units.elc
+share/emacs/site-lisp/calc/calc-vec.elc
+share/emacs/site-lisp/calc/calc-yank.elc
+@dirrm share/emacs/site-lisp/calc