aboutsummaryrefslogtreecommitdiff
path: root/math/fftw3
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-09-30 23:22:01 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-09-30 23:22:01 +0000
commit9586f9f15f8ebffd84d95a3c0171ddfcedfb5485 (patch)
tree93b5cca9c2de323026677e3ff81116cb2c95ebfd /math/fftw3
parenta1425656f3d8684d10a431b4dfc41499adbe247a (diff)
downloadports-9586f9f15f8ebffd84d95a3c0171ddfcedfb5485.tar.gz
ports-9586f9f15f8ebffd84d95a3c0171ddfcedfb5485.zip
- Fix build of fftw3-long on 5.x, 6.x, 7.x when CPUTYPE is not defined
by using math/ldouble. Also, CPUTYPE=[i386|i486|i586|i686] and proabably some others won't work. Reported by: PointyHat
Notes
Notes: svn path=/head/; revision=143887
Diffstat (limited to 'math/fftw3')
-rw-r--r--math/fftw3/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index 2b70bea455d5..56b92d29f47d 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -61,6 +61,9 @@ USE_GCC= 3.4
.endif
.endif
.endif
+.if ${FFTW3_FLAVOR}=="long" && !defined(CPUTYPE)
+USE_LDOUBLE= yes
+.endif
.if ${MACHINE_CPU:M3dnow}
CONFIGURE_ARGS+=--enable-k7
CFLAGS_3DNOW= ${CFLAGS:N-O:N-O*} -O3 -fomit-frame-pointer -fno-schedule-insns \
@@ -86,7 +89,7 @@ FFTW3_PKGNAMESUFFIX= -float
CONFIGURE_ARGS+=--enable-float
.else
.if ${FFTW3_FLAVOR}=="long"
-.if ${OSVERSION} < 504000
+.if ${OSVERSION} < 504000 || defined(USE_LDOUBLE)
LIB_DEPENDS+= ml.0:${PORTSDIR}/math/ldouble
.endif
FFTW3_SUFX= l
@@ -121,7 +124,7 @@ post-patch:
${WRKSRC}/tools/Makefile.in
.if ${FFTW3_FLAVOR}=="long"
@${REINPLACE_CMD} -e 's|cosl sinl tanl||' ${WRKSRC}/configure
-.if ${OSVERSION} < 504000
+.if ${OSVERSION} < 504000 || defined(USE_LDOUBLE)
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -E -e \
's|@LIBS@|-lml @LIBS@|'
.endif