aboutsummaryrefslogtreecommitdiff
path: root/math/fftw3
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-03-18 08:38:33 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-03-18 08:38:33 +0000
commit8d087a6cf09331f49618430b0d609cc79134b723 (patch)
treec8937a66b1fd7a8fbec5282c96ed0d89d9e51325 /math/fftw3
parent42d57a80e550d99534e6046defa1a5ec5a99df78 (diff)
downloadports-8d087a6cf09331f49618430b0d609cc79134b723.tar.gz
ports-8d087a6cf09331f49618430b0d609cc79134b723.zip
Fast C routines library to compute the Discrete Fourier Transform
PR: ports/9222 Submitted by: Lars Koeller lkoeller@cc.fh-lippe.de
Notes
Notes: svn path=/head/; revision=17276
Diffstat (limited to 'math/fftw3')
-rw-r--r--math/fftw3/Makefile32
-rw-r--r--math/fftw3/distinfo1
-rw-r--r--math/fftw3/pkg-comment1
-rw-r--r--math/fftw3/pkg-descr12
-rw-r--r--math/fftw3/pkg-plist17
5 files changed, 63 insertions, 0 deletions
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
new file mode 100644
index 000000000000..b6a4bbe64081
--- /dev/null
+++ b/math/fftw3/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: fftw
+# Version required: 2.0.1
+# Date created: Dec 28 1998
+# Whom: Lars Koeller <lkoeller@cc.fh-lippe.de>
+#
+# $Id$
+#
+
+DISTNAME= fftw-2.0.1
+CATEGORIES= math
+MASTER_SITES= ftp://theory.lcs.mit.edu/pub/fftw/ \
+ ftp://ftp.uni-bielefeld.de/pub/systems/FreeBSD/lkoeller/
+
+MAINTAINER= Lars.Koeller@Uni-Bielefeled.DE
+
+HAS_CONFIGURE= YES
+
+.include <bsd.port.mk>
+
+.if ${ARCH} == "i386"
+ CONFIGURE_ARGS= --enable-i386-hacks
+.endif
+
+CONFIGURE_ARGS+= --enable-shared
+
+post-install:
+ if [ ! -f ${PREFIX}/info/dir ]; then \
+ ${SED} -ne '1,/Menu:/p' /usr/share/info/dir > ${PREFIX}/info/dir; \
+ fi
+ .for info in fftw.info
+ install-info ${PREFIX}/info/${info} ${PREFIX}/info/dir
+ .endfor
diff --git a/math/fftw3/distinfo b/math/fftw3/distinfo
new file mode 100644
index 000000000000..c1d06eec80d0
--- /dev/null
+++ b/math/fftw3/distinfo
@@ -0,0 +1 @@
+MD5 (fftw-2.0.1.tar.gz) = ebd79d36f85e995bab49bb675ec6847e
diff --git a/math/fftw3/pkg-comment b/math/fftw3/pkg-comment
new file mode 100644
index 000000000000..eed982c6bde1
--- /dev/null
+++ b/math/fftw3/pkg-comment
@@ -0,0 +1 @@
+Fast C routines library to compute the Discrete Fourier Transform
diff --git a/math/fftw3/pkg-descr b/math/fftw3/pkg-descr
new file mode 100644
index 000000000000..46dcef355057
--- /dev/null
+++ b/math/fftw3/pkg-descr
@@ -0,0 +1,12 @@
+
+ FFTW, the Fastest Fourier Transform in the West. FFTW is a comprehensive
+ collection of fast C routines for computing the discrete Fourier transform
+ (DFT) in one or more dimensions, of both real and complex data, and of
+ arbitrary input size. FFTW also includes parallel transforms, documented
+ elsewhere. We assume herein that the reader is already familiar with the
+ properties and uses of the DFT that are relevant to her application.
+ Otherwise, see e.g. `The Fast Fourier Transform' by E. O. Brigham
+ (Prentice-Hall, Englewood Cliffs, NJ, 1974). Our web page also has links to
+ FFT-related information online, see
+
+ http://theory.lcs.mit.edu/~fftw
diff --git a/math/fftw3/pkg-plist b/math/fftw3/pkg-plist
new file mode 100644
index 000000000000..a2c144a4e185
--- /dev/null
+++ b/math/fftw3/pkg-plist
@@ -0,0 +1,17 @@
+lib/libfftw.la
+lib/libfftw.so.2.1
+lib/libfftw.so
+lib/libfftw.a
+lib/librfftw.la
+lib/librfftw.so.2.1
+lib/librfftw.so
+lib/librfftw.a
+include/fftw.h
+include/rfftw.h
+@unexec install-info --delete %D/info/fftw.info %D/info/dir
+info/fftw.info
+info/fftw.info-1
+info/fftw.info-2
+info/fftw.info-3
+@exec [ -f %D/info/dir ] || sed -ne '1,/Menu:/p' /usr/share/info/dir > %D/info/dir
+@exec install-info %D/info/fftw.info %D/info/dir