aboutsummaryrefslogtreecommitdiff
path: root/math/fftw
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2013-12-22 17:06:45 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2013-12-22 17:06:45 +0000
commitdb9a9e2c7c7bd1c147b4c7f2401cae4236cced10 (patch)
treeef5a35e9313fc8117af73c84ee3406668690f581 /math/fftw
parent8b5efc4a6dea33996cd5235dc2e5f3dcb857f424 (diff)
downloadports-db9a9e2c7c7bd1c147b4c7f2401cae4236cced10.tar.gz
ports-db9a9e2c7c7bd1c147b4c7f2401cae4236cced10.zip
- Add DOCS option.
- USES=fortran gmake. - Staging.
Notes
Notes: svn path=/head/; revision=337201
Diffstat (limited to 'math/fftw')
-rw-r--r--math/fftw/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/math/fftw/Makefile b/math/fftw/Makefile
index bbd6b4922f02..289bbd94be10 100644
--- a/math/fftw/Makefile
+++ b/math/fftw/Makefile
@@ -16,12 +16,13 @@ COMMENT?= Fast C routines to compute the Discrete Fourier Transform
LICENSE= GPLv2
+OPTIONS_DEFINE= DOCS
+
# current flavors: default, float
FFTW_FLAVOR?= default
FFTW_SUFIX=
-USE_FORTRAN= yes
-USE_GMAKE= yes
+USES= fortran gmake
USE_AUTOTOOLS= aclocal automake autoconf libtool
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing
@@ -33,9 +34,6 @@ PLIST_SUB= FFTW_SUFX="${FFTW_SUFX}"
PORTSCOUT= limit:^2\.
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
.if ${FFTW_FLAVOR}=="float"
CONFIGURE_ARGS+= --enable-float --enable-type-prefix
FFTW_SUFX= s
@@ -46,6 +44,8 @@ INFO= fftw
PLIST_SUB+= DEF=""
.endif
+.include <bsd.port.options.mk>
+
.if ${ARCH} == "i386"
CONFIGURE_ARGS+= --enable-i386-hacks
.endif
@@ -64,14 +64,14 @@ post-build:
post-install:
.if ${FFTW_FLAVOR}=="default"
- ${INSTALL_DATA} ${WRKSRC}/doc/fftw.info ${PREFIX}/${INFO_PATH}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/fftw.ps ${DOCSDIR}/fftw.ps
+ ${INSTALL_DATA} ${WRKSRC}/doc/fftw.info ${STAGEDIR}${PREFIX}/${INFO_PATH}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/fftw.ps ${STAGEDIR}${DOCSDIR}/fftw.ps
.endif
.endif
regression-test: build
- @cd ${WRKSRC}/tests && ${SETENV} ${MAKE_ENV} ${MAKE} check
+ @(cd ${WRKSRC}/tests && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} check)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>