aboutsummaryrefslogtreecommitdiff
path: root/math/fxt
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-10-12 12:59:39 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-10-12 12:59:39 +0000
commit3e9ac88a241d375bc091cb4c433814244d5d4d1f (patch)
tree83f1692062796d30ace45f500fade54ef27c9c70 /math/fxt
parent6cc631883a260588d850147a5b631638906e4aa1 (diff)
downloadports-3e9ac88a241d375bc091cb4c433814244d5d4d1f.tar.gz
ports-3e9ac88a241d375bc091cb4c433814244d5d4d1f.zip
Update to version 2004.10.04
PR: ports/72531 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=119002
Diffstat (limited to 'math/fxt')
-rw-r--r--math/fxt/Makefile37
-rw-r--r--math/fxt/distinfo4
-rw-r--r--math/fxt/files/patch-aux0::aux0print.cc11
-rw-r--r--math/fxt/files/patch-bmat::bitmatprint.cc10
-rw-r--r--math/fxt/files/patch-bpol::bitpolprint.cc10
-rw-r--r--math/fxt/files/patch-include::jjassert.h11
-rw-r--r--math/fxt/files/patch-makefile56
-rw-r--r--math/fxt/pkg-plist565
8 files changed, 417 insertions, 287 deletions
diff --git a/math/fxt/Makefile b/math/fxt/Makefile
index c6bea66f6a98..5ccccd2f1f02 100644
--- a/math/fxt/Makefile
+++ b/math/fxt/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= fxt
-PORTVERSION= 2003.02.18
-PORTREVISION= 1
+PORTVERSION= 2004.10.04
CATEGORIES= math
MASTER_SITES= http://www.jjj.de/fxt/
EXTRACT_SUFX= .tgz
@@ -18,14 +17,34 @@ COMMENT= FFT code and related stuff
WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GCC= 3.4
+USE_REINPLACE= yes
USE_GMAKE= yes
MAKEFILE= makefile
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile with gcc 3.4.2"
+MAKE_ENV= CXX="${CXX}" OFLAGS="${CXXFLAGS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^OFLAGS|#OFLAGS|g ; \
+ s|^ARCHFLAG|#ARCHFLAG|g ; \
+ s|^WFLAGS|#WFLAGS|g ; \
+ s|^GFLAGS|#GFLAGS|g ; \
+ s|^PFLAGS|#PFLAGS|g ; \
+ s|^FXT_CXXFLAGS|#FXT_CXXFLAGS|g' ${WRKSRC}/makefile
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libfxt.a ${PREFIX}/lib
+ @${MKDIR} ${PREFIX}/include/fxt
+ ${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include/fxt
+.for dir in aux0 aux1 aux2 bits bmat bpol chirpzt correlation comb \
+ comb/bucket convolution dctdst demo ds fft fht graph graph/bucket \
+ haar matrix matrixfft mod mult ntt perm perm/bucket realfft simplfft \
+ sort sort/bucket test walsh wavelet
+ @${MKDIR} ${PREFIX}/include/fxt/${dir}
+ ${INSTALL_DATA} ${WRKSRC}/${dir}/*.h ${PREFIX}/include/fxt/${dir}
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/00*.txt ${DOCSDIR}
.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/fxt/distinfo b/math/fxt/distinfo
index f52967e77fce..1a8f753686fc 100644
--- a/math/fxt/distinfo
+++ b/math/fxt/distinfo
@@ -1,2 +1,2 @@
-MD5 (fxt-2003.02.18.tgz) = e9941264cf6f6755f88ebc92063608ed
-SIZE (fxt-2003.02.18.tgz) = 477583
+MD5 (fxt-2004.10.04.tgz) = 706f72662fa5723813f8b491ac021875
+SIZE (fxt-2004.10.04.tgz) = 682896
diff --git a/math/fxt/files/patch-aux0::aux0print.cc b/math/fxt/files/patch-aux0::aux0print.cc
new file mode 100644
index 000000000000..34ff9871f64c
--- /dev/null
+++ b/math/fxt/files/patch-aux0::aux0print.cc
@@ -0,0 +1,11 @@
+--- aux0/aux0print.cc.orig Sun Jul 11 23:08:11 2004
++++ aux0/aux0print.cc Wed Oct 6 22:31:25 2004
+@@ -1,6 +1,8 @@
+
+ #include "fxtio.h"
+
++#include <cmath>
++
+
+ void
+ print_fixed(const char *bla, double v, long nd, bool sq)
diff --git a/math/fxt/files/patch-bmat::bitmatprint.cc b/math/fxt/files/patch-bmat::bitmatprint.cc
new file mode 100644
index 000000000000..f60c37557f35
--- /dev/null
+++ b/math/fxt/files/patch-bmat::bitmatprint.cc
@@ -0,0 +1,10 @@
+--- bmat/bitmatprint.cc.orig Mon Dec 22 01:05:42 2003
++++ bmat/bitmatprint.cc Wed Oct 6 22:28:38 2004
+@@ -2,6 +2,7 @@
+
+ //#include "bits/printbin.h"
+ #include "fxtiomanip.h"
++#include "fxttypes.h"
+
+
+ void
diff --git a/math/fxt/files/patch-bpol::bitpolprint.cc b/math/fxt/files/patch-bpol::bitpolprint.cc
new file mode 100644
index 000000000000..e9650dd7eaba
--- /dev/null
+++ b/math/fxt/files/patch-bpol::bitpolprint.cc
@@ -0,0 +1,10 @@
+--- bpol/bitpolprint.cc.orig Wed Apr 14 01:51:29 2004
++++ bpol/bitpolprint.cc Wed Oct 6 23:18:23 2004
+@@ -2,6 +2,7 @@
+ #include "bits/bitsperlong.h"
+
+ #include "fxtio.h"
++#include "fxttypes.h"
+
+
+ void
diff --git a/math/fxt/files/patch-include::jjassert.h b/math/fxt/files/patch-include::jjassert.h
deleted file mode 100644
index 47b53e6ea6a3..000000000000
--- a/math/fxt/files/patch-include::jjassert.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/jjassert.h.orig Sun Feb 23 14:08:38 2003
-+++ include/jjassert.h Sun Feb 23 14:08:56 2003
-@@ -2,7 +2,7 @@
- #define HAVE_JJASSERT_H__
-
- // if you don't have sys/cdefs.h just uncomment the next line:
--//#include <sys/cdefs.h> // __STRING()
-+#include <sys/cdefs.h> // __STRING()
-
- // aux0/jjassert.cc:
- // options for last action of jjassert_fail():
diff --git a/math/fxt/files/patch-makefile b/math/fxt/files/patch-makefile
deleted file mode 100644
index 90c3a13b6e9a..000000000000
--- a/math/fxt/files/patch-makefile
+++ /dev/null
@@ -1,56 +0,0 @@
---- makefile.orig Sat Jan 11 18:08:57 2003
-+++ makefile Mon Jan 27 16:08:56 2003
-@@ -3,7 +3,7 @@
-
- PROJ=fxt
-
--CXX = c++
-+#CXX = c++
- PPLIBS = -lm -lstdc++
-
-
-@@ -15,7 +15,6 @@
- # -mcpu= Schedule code for given CPU
- # Note that specifying `-march=CPU-TYPE' implies `-mcpu=CPU-TYPE'
-
--OFLAGS = -O2
- OFLAGS += -fomit-frame-pointer
- OFLAGS += -fno-exceptions
- OFLAGS += -ffast-math
-@@ -53,12 +52,12 @@
- -Imod -Iwavelet -Isort -Islow
-
- #### choose the FLAG combo here:
--CXXFLAGS = -pipe -fno-exceptions
--CXXFLAGS += $(OFLAGS) # uncomment for OPTIMIZATION
-+#CXXFLAGS = -pipe -fno-exceptions
-+#CXXFLAGS += $(OFLAGS) # uncomment for OPTIMIZATION
- #CXXFLAGS += $(PFLAGS) # uncomment for PROFILING
- #CXXFLAGS += $(GFLAGS) # uncomment for DEBUGGING
- #CXXFLAGS += -D__NO_MATH_INLINES
--CXXFLAGS += $(WFLAGS) # uncomment for WARNINGS
-+#CXXFLAGS += $(WFLAGS) # uncomment for WARNINGS
-
- #-------------------------------------
-
-@@ -354,16 +353,16 @@
- # @echo ' ===== make FXT lib DONE. ====='
-
-
--PREFIX=/usr/
--LIBDIR=$(PREFIX)/lib/fxt
-+#PREFIX=/usr/
-+LIBDIR=$(PREFIX)/lib
- INCDIR=$(PREFIX)/include/fxt
- .PHONY: install ## install to $(PREFIX)/{lib,include}/fxt/
- install: lib
- @echo 'PREFIX=$(PREFIX) LIBDIR=$(LIBDIR) INCDIR=$(INCDIR)'
- @test -d $(LIBDIR) || mkdir $(LIBDIR)
-- cp -auv $(FXTLIB) $(LIBDIR)/
-+ ${BSD_INSTALL_DATA} $(FXTLIB) $(LIBDIR)/
- @test -d $(INCDIR) || mkdir $(INCDIR)
-- @cp -auv $(FXTHDRS) $(INCDIR)/
-+ ${BSD_INSTALL_DATA} $(FXTHDRS) $(INCDIR)/
-
- .PHONY: uninstall ## opposite of install ;-)
- uninstall:
diff --git a/math/fxt/pkg-plist b/math/fxt/pkg-plist
index 57d1a1eb6fcf..16ab0fd4311d 100644
--- a/math/fxt/pkg-plist
+++ b/math/fxt/pkg-plist
@@ -1,217 +1,364 @@
-include/fxt/applyfunc.h
-include/fxt/arith1.h
-include/fxt/arith2d.h
-include/fxt/array.h
-include/fxt/array2d.h
-include/fxt/aux0lazy.h
-include/fxt/aux1lazy.h
-include/fxt/aux2lazy.h
-include/fxt/auxbitlazy.h
-include/fxt/auxdouble.h
-include/fxt/auxprint.h
-include/fxt/binarydebruijn.h
-include/fxt/binaryprimestring.h
-include/fxt/bit2adic.h
-include/fxt/bit2composition.h
-include/fxt/bit2pow.h
-include/fxt/bitarray.h
-include/fxt/bitasm.h
-include/fxt/bitcombcolex.h
-include/fxt/bitcomblex.h
-include/fxt/bitcombminchange.h
-include/fxt/bitcopy.h
-include/fxt/bitcount.h
-include/fxt/bitcyclic.h
-include/fxt/bitcyclic2.h
-include/fxt/bitgather.h
-include/fxt/bithigh.h
-include/fxt/bitinvolutions.h
-include/fxt/bitlex.h
-include/fxt/bitlow.h
-include/fxt/bitmat.h
-include/fxt/bitmisc.h
-include/fxt/bitmrotate.h
-include/fxt/bitpol.h
-include/fxt/bitpolirred.h
-include/fxt/bitpolmodmult.h
-include/fxt/bitpolmodmultrev.h
-include/fxt/bitpoltrace.h
-include/fxt/bitrotate.h
-include/fxt/bitsequency.h
-include/fxt/bitsperlong.h
-include/fxt/bitsubset.h
-include/fxt/bitswap.h
-include/fxt/bitzip.h
-include/fxt/branchless.h
-include/fxt/bytescan.h
-include/fxt/cholesky.h
-include/fxt/cmult.h
-include/fxt/combaltminchange.h
-include/fxt/combcolex.h
-include/fxt/comblazy.h
-include/fxt/comblex.h
-include/fxt/combminchange.h
+include/fxt/aux0-all.h
+include/fxt/aux0/aux0double.h
+include/fxt/aux0/cmult.h
+include/fxt/aux0/constants.h
+include/fxt/aux0/csincos.h
+include/fxt/aux0/fhtmulsqr.h
+include/fxt/aux0/funcemu.h
+include/fxt/aux0/inline.h
+include/fxt/aux0/rand.h
+include/fxt/aux0/range.h
+include/fxt/aux0/sincos.h
+include/fxt/aux0/sumdiff.h
+include/fxt/aux0/swap.h
+include/fxt/aux0/timer.h
+include/fxt/aux0/version.h
+include/fxt/aux1-all.h
+include/fxt/aux1/applyfunc.h
+include/fxt/aux1/arith1.h
+include/fxt/aux1/array.h
+include/fxt/aux1/aux1double.h
+include/fxt/aux1/auxprint.h
+include/fxt/aux1/bytescan.h
+include/fxt/aux1/copy.h
+include/fxt/aux1/diff.h
+include/fxt/aux1/grsnegate.h
+include/fxt/aux1/misc.h
+include/fxt/aux1/resample.h
+include/fxt/aux1/scale.h
+include/fxt/aux1/scanbox.h
+include/fxt/aux1/shift.h
+include/fxt/aux1/symmetry.h
+include/fxt/aux1/wordgray.h
+include/fxt/aux2-all.h
+include/fxt/aux2/applyfunc2d.h
+include/fxt/aux2/arith2d.h
+include/fxt/aux2/array2d.h
+include/fxt/aux2/copy2d.h
+include/fxt/aux2/minmax2d.h
+include/fxt/aux2/reverse2d.h
+include/fxt/aux2/rotate2d.h
+include/fxt/aux2/scale2d.h
+include/fxt/aux2/shift2d.h
+include/fxt/aux2/transpose.h
+include/fxt/aux2/transpose2.h
+include/fxt/aux2/transpose2_ba.h
+include/fxt/aux2/transpose_ba.h
+include/fxt/bits-all.h
+include/fxt/bits/bit2adic.h
+include/fxt/bits/bit2composition.h
+include/fxt/bits/bit2pow.h
+include/fxt/bits/bitasm.h
+include/fxt/bits/bitcombcolex.h
+include/fxt/bits/bitcomblex.h
+include/fxt/bits/bitcombminchange.h
+include/fxt/bits/bitcopy.h
+include/fxt/bits/bitcount.h
+include/fxt/bits/bitcyclic.h
+include/fxt/bits/bitcyclic2.h
+include/fxt/bits/bitcyclic3.h
+include/fxt/bits/bitcyclicgray.h
+include/fxt/bits/bitgather.h
+include/fxt/bits/bitgraypermute.h
+include/fxt/bits/bithigh.h
+include/fxt/bits/bitlex.h
+include/fxt/bits/bitlow.h
+include/fxt/bits/bitmisc.h
+include/fxt/bits/bitmrotate.h
+include/fxt/bits/bitnecklace.h
+include/fxt/bits/bitrotate.h
+include/fxt/bits/bitseparate.h
+include/fxt/bits/bitsequency.h
+include/fxt/bits/bitsperlong.h
+include/fxt/bits/bitsubset.h
+include/fxt/bits/bitsubsetgray.h
+include/fxt/bits/bitswap.h
+include/fxt/bits/bittransforms.h
+include/fxt/bits/bitxtransforms.h
+include/fxt/bits/bitzip.h
+include/fxt/bits/branchless.h
+include/fxt/bits/colormix.h
+include/fxt/bits/colormixp.h
+include/fxt/bits/fl_colormix.h
+include/fxt/bits/graycode.h
+include/fxt/bits/graypower.h
+include/fxt/bits/greencode.h
+include/fxt/bits/grsnegative.h
+include/fxt/bits/hilbert.h
+include/fxt/bits/negbin.h
+include/fxt/bits/nextgray.h
+include/fxt/bits/parity.h
+include/fxt/bits/printbin.h
+include/fxt/bits/revbin.h
+include/fxt/bits/tinyfactors.h
+include/fxt/bits/zerobyte.h
+include/fxt/bmat-all.h
+include/fxt/bmat/bitmat.h
+include/fxt/bmat/bitmatinline.h
+include/fxt/bpol-all.h
+include/fxt/bpol/allirredpol.h
+include/fxt/bpol/bitpol.h
+include/fxt/bpol/bitpoldegree.h
+include/fxt/bpol/bitpolfactor.h
+include/fxt/bpol/bitpolirred.h
+include/fxt/bpol/bitpolmodmult.h
+include/fxt/bpol/bitpolmodmultrev.h
+include/fxt/bpol/bitpolprimitive.h
+include/fxt/bpol/bitpolprint.h
+include/fxt/bpol/bitpolsquarefree.h
+include/fxt/bpol/fcsr.h
+include/fxt/bpol/gf2n.h
+include/fxt/bpol/gf2nfuncs.h
+include/fxt/bpol/lfsr.h
+include/fxt/bpol/lfsr64.h
+include/fxt/bpol/lhca.h
+include/fxt/bpol/necklace2bitpol.h
+include/fxt/bpol/normalbasis.h
+include/fxt/bpol/numofbitpol.h
+include/fxt/bpol/primpoly.h
+include/fxt/chirpzt-all.h
+include/fxt/chirpzt/chirpzt.h
+include/fxt/comb-all.h
+include/fxt/comb/binarydebruijn.h
+include/fxt/comb/binaryprimestring.h
+include/fxt/comb/bucket/binarydebruijn.h
+include/fxt/comb/bucket/combcolex.h
+include/fxt/comb/bucket/comblex.h
+include/fxt/comb/bucket/combminchange.h
+include/fxt/comb/bucket/compositionalt.h
+include/fxt/comb/bucket/subsetdebruijn.h
+include/fxt/comb/combaltminchange.h
+include/fxt/comb/combcolex.h
+include/fxt/comb/comblex.h
+include/fxt/comb/combminchange.h
+include/fxt/comb/compositionlex.h
+include/fxt/comb/debruijn.h
+include/fxt/comb/gray.h
+include/fxt/comb/lyndongray.h
+include/fxt/comb/mixedradix.h
+include/fxt/comb/mixedradixgray.h
+include/fxt/comb/mixedradixlex.h
+include/fxt/comb/modularmixedradixgray.h
+include/fxt/comb/numofnecklaces.h
+include/fxt/comb/paren.h
+include/fxt/comb/paren2.h
+include/fxt/comb/partition.h
+include/fxt/comb/primestring.h
+include/fxt/comb/stringsubst.h
+include/fxt/comb/subsetdebruijn.h
+include/fxt/comb/subsetlex.h
+include/fxt/comb/subsetminchange.h
+include/fxt/comb/subsetmonotone.h
include/fxt/complextype.h
-include/fxt/compositionalt.h
-include/fxt/compositionlex.h
-include/fxt/constants.h
-include/fxt/convex.h
-include/fxt/copy.h
-include/fxt/copy2d.h
-include/fxt/csincos.h
-include/fxt/cycles.h
-include/fxt/daubechies.h
-include/fxt/debruijn.h
-include/fxt/deque.h
-include/fxt/diff.h
-include/fxt/diskaux.h
-include/fxt/dslazy.h
-include/fxt/dyadiccnvl.h
-include/fxt/factor.h
-include/fxt/fcsr.h
-include/fxt/fhtmulsqr.h
-include/fxt/funcemu.h
-include/fxt/fxt.h
-include/fxt/fxtauxlazy.h
+include/fxt/convolution-all.h
+include/fxt/convolution/convolution.h
+include/fxt/convolution/slowcnvl.h
+include/fxt/convolution/slowtwodimcnvl.h
+include/fxt/correlation-all.h
+include/fxt/correlation/correlation.h
+include/fxt/correlation/slowcorr.h
+include/fxt/dctdst-all.h
+include/fxt/dctdst/dctdst.h
+include/fxt/demo/bitdemos.h
+include/fxt/demo/nextarg.h
+include/fxt/ds-all.h
+include/fxt/ds/bitarray.h
+include/fxt/ds/deque.h
+include/fxt/ds/heap.h
+include/fxt/ds/orderedrarray.h
+include/fxt/ds/priorityqueue.h
+include/fxt/ds/queue.h
+include/fxt/ds/rarray.h
+include/fxt/ds/ringbuffer.h
+include/fxt/ds/rset.h
+include/fxt/ds/stack.h
+include/fxt/fft-all.h
+include/fxt/fft/fft.h
+include/fxt/fht-all.h
+include/fxt/fht/fht.h
+include/fxt/fht/shortfhtdifcore.h
+include/fxt/fht/shortfhtditcore.h
+include/fxt/fxtalloca.h
include/fxt/fxtio.h
include/fxt/fxtiomanip.h
-include/fxt/fxtmult.h
include/fxt/fxttypes.h
-include/fxt/graycode.h
-include/fxt/graypermute.h
-include/fxt/grayrevpermute.h
-include/fxt/greencode.h
-include/fxt/haarnn.h
-include/fxt/haarnninplace.h
-include/fxt/haarpermute.h
-include/fxt/heap.h
-include/fxt/heapsort.h
-include/fxt/hilbert.h
-include/fxt/inline.h
-include/fxt/intarith.h
+include/fxt/graph-all.h
+include/fxt/graph/bucket/debruijngraph.h
+include/fxt/graph/digraph.h
+include/fxt/graph/digraphpaths.h
+include/fxt/graph/digraphspecial.h
+include/fxt/graph/printpath.h
+include/fxt/haar-all.h
+include/fxt/haar/haar.h
+include/fxt/haar/haari2i.h
+include/fxt/haar/haarnn.h
+include/fxt/haar/haarrevnn.h
+include/fxt/haar/transposedhaarnn.h
+include/fxt/haar/transposedhaarrevnn.h
include/fxt/jjassert.h
-include/fxt/ldn2rc.h
-include/fxt/lfsr.h
-include/fxt/lfsr64.h
-include/fxt/lhca.h
-include/fxt/lowbitprimpoly.h
-include/fxt/matrix.h
-include/fxt/matrixsymmetryq.h
-include/fxt/minmax.h
-include/fxt/minmax2d.h
-include/fxt/minweightlhcarule.h
-include/fxt/minweightprimpoly.h
-include/fxt/misc.h
-include/fxt/misc2d.h
-include/fxt/mixedradix.h
-include/fxt/mixedradixgray.h
-include/fxt/mixedradixlex.h
-include/fxt/mmult.h
-include/fxt/mod.h
-include/fxt/modarith.h
-include/fxt/modlazy.h
-include/fxt/modm.h
-include/fxt/modularmixedradixgray.h
-include/fxt/moduli.h
-include/fxt/monotone.h
-include/fxt/monotonegray.h
-include/fxt/mrotate.h
-include/fxt/mtypes.h
-include/fxt/ntt.h
-include/fxt/orderedrarray.h
-include/fxt/paren.h
-include/fxt/paren2.h
-include/fxt/partition.h
-include/fxt/permapply.h
-include/fxt/permcyclic.h
-include/fxt/permderange.h
-include/fxt/permlazy.h
-include/fxt/permlex.h
-include/fxt/permminchange.h
-include/fxt/permstar.h
-include/fxt/permtrotter.h
-include/fxt/permutation.h
-include/fxt/permvisit.h
-include/fxt/primes.h
-include/fxt/primestring.h
-include/fxt/printbin.h
-include/fxt/priorityqueue.h
-include/fxt/quantise.h
-include/fxt/queue.h
-include/fxt/radixpermute.h
-include/fxt/rand.h
-include/fxt/randprimpoly.h
-include/fxt/range.h
-include/fxt/rarray.h
-include/fxt/reorth.h
-include/fxt/resample.h
+include/fxt/matrix-all.h
+include/fxt/matrix/cholesky.h
+include/fxt/matrix/matrix.h
+include/fxt/matrix/matrixsymmetryq.h
+include/fxt/matrix/mmult.h
+include/fxt/matrix/reorth.h
+include/fxt/matrix/symmetricpart.h
+include/fxt/matrix/testmatrix.h
+include/fxt/matrix/toeplitz.h
+include/fxt/matrix/vector.h
+include/fxt/matrixfft-all.h
+include/fxt/matrixfft/ldn2rc.h
+include/fxt/matrixfft/matrixfft.h
+include/fxt/mod-all.h
+include/fxt/mod/binarygcd.h
+include/fxt/mod/chebyshev.h
+include/fxt/mod/factor.h
+include/fxt/mod/gcd.h
+include/fxt/mod/ipow.h
+include/fxt/mod/isqrt.h
+include/fxt/mod/mersenne.h
+include/fxt/mod/mod.h
+include/fxt/mod/modarith.h
+include/fxt/mod/mtypes.h
+include/fxt/mod/numtheory.h
+include/fxt/mod/primes.h
+include/fxt/mod/testnum.h
+include/fxt/mult-all.h
+include/fxt/mult/diskaux.h
+include/fxt/mult/fxtmult.h
+include/fxt/mult/workspace.h
+include/fxt/ntt-all.h
+include/fxt/ntt/ntt.h
+include/fxt/perm-all.h
+include/fxt/perm/bucket/graypermute.h
+include/fxt/perm/bucket/partition.h
+include/fxt/perm/bucket/revbinpermute.h
+include/fxt/perm/cycles.h
+include/fxt/perm/graypermute.h
+include/fxt/perm/grayrevpermute.h
+include/fxt/perm/greenpermute.h
+include/fxt/perm/greenrevpermute.h
+include/fxt/perm/haarpermute.h
+include/fxt/perm/mrotate.h
+include/fxt/perm/permapply.h
+include/fxt/perm/permapplyfunc.h
+include/fxt/perm/permcyclic.h
+include/fxt/perm/permderange.h
+include/fxt/perm/permlex.h
+include/fxt/perm/permminchange.h
+include/fxt/perm/permstar.h
+include/fxt/perm/permtrotter.h
+include/fxt/perm/permutation.h
+include/fxt/perm/permvisit.h
+include/fxt/perm/radixpermute.h
+include/fxt/perm/randperm.h
+include/fxt/perm/revbinpermute.h
+include/fxt/perm/revbinpermute0.h
+include/fxt/perm/reverse.h
+include/fxt/perm/rotate.h
+include/fxt/perm/shortgraypermute.h
+include/fxt/perm/shortrevbinpermute.h
+include/fxt/perm/shortrevbinpermute0.h
+include/fxt/perm/swapblocks.h
+include/fxt/perm/xorpermute.h
+include/fxt/perm/zip.h
+include/fxt/perm/ziprev.h
+include/fxt/realfft-all.h
+include/fxt/realfft/realfft.h
include/fxt/restrict.h
-include/fxt/revbin.h
-include/fxt/revbinpermute.h
-include/fxt/revbinpermute0.h
-include/fxt/reverse.h
-include/fxt/reverse2d.h
-include/fxt/ringbuffer.h
-include/fxt/rotate.h
-include/fxt/rotate2d.h
-include/fxt/rset.h
-include/fxt/scale.h
-include/fxt/scale2d.h
-include/fxt/scan.h
-include/fxt/scanbox.h
-include/fxt/scanfunc.h
-include/fxt/search.h
-include/fxt/searchidx.h
-include/fxt/searchptr.h
-include/fxt/shift.h
-include/fxt/shift2d.h
-include/fxt/shortfhtdifcore.h
-include/fxt/shortfhtditcore.h
-include/fxt/shortgraypermute.h
-include/fxt/shortrevbinpermute.h
-include/fxt/shortrevbinpermute0.h
-include/fxt/sincos.h
-include/fxt/slowcnvl.h
-include/fxt/slowcorr.h
-include/fxt/slowlazy.h
-include/fxt/slowtwodimcnvl.h
-include/fxt/sort.h
-include/fxt/sortcomplex.h
-include/fxt/sortfunc.h
-include/fxt/sortidx.h
-include/fxt/sortlazy.h
-include/fxt/sortptr.h
-include/fxt/stack.h
-include/fxt/subsetdebruijn.h
-include/fxt/subsetlex.h
-include/fxt/subsetminchange.h
-include/fxt/subsetmonotone.h
-include/fxt/sumdiff.h
-include/fxt/symbolify.h
-include/fxt/symmetricpart.h
-include/fxt/symmetry.h
-include/fxt/testmatrix.h
-include/fxt/testnum.h
-include/fxt/tinyfactors.h
-include/fxt/toeplitz.h
-include/fxt/transpose.h
-include/fxt/transpose2.h
-include/fxt/transpose2_ba.h
-include/fxt/transpose_ba.h
-include/fxt/unique.h
-include/fxt/vector.h
-include/fxt/walshgray.h
-include/fxt/walshhartley.h
-include/fxt/walshlazy.h
-include/fxt/walshpal.h
-include/fxt/walshseq.h
-include/fxt/walshwak.h
-include/fxt/walshwal.h
-include/fxt/waveletfilter.h
-include/fxt/workspace.h
-include/fxt/xorpermute.h
-include/fxt/zerobyte.h
-include/fxt/zip.h
-include/fxt/ziprev.h
+include/fxt/simplfft/fft.h
+include/fxt/sort-all.h
+include/fxt/sort/bsearch.h
+include/fxt/sort/bsearchapprox.h
+include/fxt/sort/bsearchfunc.h
+include/fxt/sort/bsearchidx.h
+include/fxt/sort/bsearchidxfunc.h
+include/fxt/sort/bsearchptr.h
+include/fxt/sort/bsearchptrfunc.h
+include/fxt/sort/bucket/searchunsorted.h
+include/fxt/sort/bucket/sort.h
+include/fxt/sort/convex.h
+include/fxt/sort/grep.h
+include/fxt/sort/heapsort.h
+include/fxt/sort/minmax.h
+include/fxt/sort/minmaxfunc.h
+include/fxt/sort/minmaxidx.h
+include/fxt/sort/minmaxidxfunc.h
+include/fxt/sort/minmaxmed23.h
+include/fxt/sort/minmaxmed23func.h
+include/fxt/sort/minmaxptr.h
+include/fxt/sort/minmaxptrfunc.h
+include/fxt/sort/monotone.h
+include/fxt/sort/quantize.h
+include/fxt/sort/searchdown.h
+include/fxt/sort/sort.h
+include/fxt/sort/sort23.h
+include/fxt/sort/sort23func.h
+include/fxt/sort/sortcomplex.h
+include/fxt/sort/sortfunc.h
+include/fxt/sort/sortidx.h
+include/fxt/sort/sortidxfunc.h
+include/fxt/sort/sortptr.h
+include/fxt/sort/sortptrfunc.h
+include/fxt/sort/symbolify.h
+include/fxt/sort/ucount.h
+include/fxt/sort/unique.h
+include/fxt/sort/uniqueapprox.h
+include/fxt/sort/usearch.h
+include/fxt/sort/usearchfunc.h
+include/fxt/test/test.h
+include/fxt/walsh-all.h
+include/fxt/walsh/arithtransform.h
+include/fxt/walsh/dyadiccnvl.h
+include/fxt/walsh/reedmuller.h
+include/fxt/walsh/slant.h
+include/fxt/walsh/walshbasefunc.h
+include/fxt/walsh/walshgray.h
+include/fxt/walsh/walshpal.h
+include/fxt/walsh/walshq.h
+include/fxt/walsh/walshseq.h
+include/fxt/walsh/walshwak.h
+include/fxt/walsh/walshwal.h
+include/fxt/walsh/walshwalrev.h
+include/fxt/wavelet-all.h
+include/fxt/wavelet/daubechies.h
+include/fxt/wavelet/wavelet.h
+include/fxt/wavelet/waveletfilter.h
lib/libfxt.a
+%%PORTDOCS%%%%DOCSDIR%%/00legal.txt
+%%PORTDOCS%%%%DOCSDIR%%/00readme.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/fxt/wavelet
+@dirrm include/fxt/walsh
+@dirrm include/fxt/test
+@dirrm include/fxt/sort/bucket
+@dirrm include/fxt/sort
+@dirrm include/fxt/simplfft
+@dirrm include/fxt/realfft
+@dirrm include/fxt/perm/bucket
+@dirrm include/fxt/perm
+@dirrm include/fxt/ntt
+@dirrm include/fxt/mult
+@dirrm include/fxt/mod
+@dirrm include/fxt/matrixfft
+@dirrm include/fxt/matrix
+@dirrm include/fxt/haar
+@dirrm include/fxt/graph/bucket
+@dirrm include/fxt/graph
+@dirrm include/fxt/fht
+@dirrm include/fxt/fft
+@dirrm include/fxt/ds
+@dirrm include/fxt/demo
+@dirrm include/fxt/dctdst
+@dirrm include/fxt/correlation
+@dirrm include/fxt/convolution
+@dirrm include/fxt/comb/bucket
+@dirrm include/fxt/comb
+@dirrm include/fxt/chirpzt
+@dirrm include/fxt/bpol
+@dirrm include/fxt/bmat
+@dirrm include/fxt/bits
+@dirrm include/fxt/aux2
+@dirrm include/fxt/aux1
+@dirrm include/fxt/aux0
@dirrm include/fxt