aboutsummaryrefslogtreecommitdiff
path: root/math/fxt
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-28 03:57:15 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-28 03:57:15 +0000
commita4951ca5708346b2d26ae46db77a12a08791efda (patch)
tree53b81ea86007903ca0682f3a33fe7a769411376a /math/fxt
parent81d26a90e918b8806597336ad5564a51a53e756e (diff)
downloadports-a4951ca5708346b2d26ae46db77a12a08791efda.tar.gz
ports-a4951ca5708346b2d26ae46db77a12a08791efda.zip
add fxt
FFT code and related stuff
Notes
Notes: svn path=/head/; revision=50672
Diffstat (limited to 'math/fxt')
-rw-r--r--math/fxt/Makefile27
-rw-r--r--math/fxt/distinfo1
-rw-r--r--math/fxt/files/patch-makefile14
-rw-r--r--math/fxt/pkg-comment1
-rw-r--r--math/fxt/pkg-descr13
-rw-r--r--math/fxt/pkg-plist111
6 files changed, 167 insertions, 0 deletions
diff --git a/math/fxt/Makefile b/math/fxt/Makefile
new file mode 100644
index 000000000000..6587cbdd5856
--- /dev/null
+++ b/math/fxt/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: fxt
+# Date created: Nov 28, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= fxt
+PORTVERSION= 2001.10.15
+CATEGORIES= math
+MASTER_SITES= http://www.jjj.de/fxt/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKEFILE= makefile
+MAKE_ENV= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+ INSTALL_DATA="${INSTALL_DATA}"
+
+post-patch:
+ @${PERL} -pi -e "s,^CXX,#CXX,g ; \
+ s,^PREFIX,#PREFIX,g" ${WRKSRC}/${MAKEFILE}
+
+.include <bsd.port.mk>
diff --git a/math/fxt/distinfo b/math/fxt/distinfo
new file mode 100644
index 000000000000..04e4cea4b00b
--- /dev/null
+++ b/math/fxt/distinfo
@@ -0,0 +1 @@
+MD5 (fxt-2001.10.15.tgz) = a22c3e539c426bb6c09942d2e0726aae
diff --git a/math/fxt/files/patch-makefile b/math/fxt/files/patch-makefile
new file mode 100644
index 000000000000..a68304b99e34
--- /dev/null
+++ b/math/fxt/files/patch-makefile
@@ -0,0 +1,14 @@
+--- makefile.orig Wed Nov 28 11:53:26 2001
++++ makefile Wed Nov 28 11:54:18 2001
+@@ -441,9 +441,9 @@
+ install: lib
+ @echo 'PREFIX=$(PREFIX) LIBDIR=$(LIBDIR) INCDIR=$(INCDIR)'
+ @test -d $(LIBDIR) || mkdir $(LIBDIR)
+- cp -auv $(FXTLIB) $(LIBDIR)/
++ ${INSTALL_PROGRAM} $(FXTLIB) $(LIBDIR)/
+ @test -d $(INCDIR) || mkdir $(INCDIR)
+- @cp -auv $(FXTHDRS) $(INCDIR)/
++ @${INSTALL_DATA} $(FXTHDRS) $(INCDIR)/
+
+ .PHONY: uninstall ## opposite of install ;-)
+ uninstall:
diff --git a/math/fxt/pkg-comment b/math/fxt/pkg-comment
new file mode 100644
index 000000000000..353dce0f6512
--- /dev/null
+++ b/math/fxt/pkg-comment
@@ -0,0 +1 @@
+FFT code and related stuff
diff --git a/math/fxt/pkg-descr b/math/fxt/pkg-descr
new file mode 100644
index 000000000000..85b223d52e6f
--- /dev/null
+++ b/math/fxt/pkg-descr
@@ -0,0 +1,13 @@
+fxt is a library package (coming as C++ source code) containing code various
+algorithms for:
+ - Fast Fourier Transform (FFT) incl. real-vlued,
+ - multidimensional and weighted variants.
+ - Fast Hartley Transform (FHT)
+ - Number Theoretic Transform (NTT), Fast Walsh Transform.
+ - Convolution (cyclic, linear and weighted),
+ - correlation and power spectrum.
+ - Fast Haar Transform, Fast Wavelet Transform
+ - Mass storage convolution and fast multiplication routines.
+ - Sine- and cosine transform (DCT, DST), Fast Z-Transform (FZT)
+
+WWW: http://www.jjj.de/fxt/
diff --git a/math/fxt/pkg-plist b/math/fxt/pkg-plist
new file mode 100644
index 000000000000..5ea517559915
--- /dev/null
+++ b/math/fxt/pkg-plist
@@ -0,0 +1,111 @@
+include/fxt/array.h
+include/fxt/array2d.h
+include/fxt/aux2dlazy.h
+include/fxt/auxdouble.h
+include/fxt/auxlazy.h
+include/fxt/auxprint.h
+include/fxt/bitarray.h
+include/fxt/bitcombination.h
+include/fxt/bitcount.h
+include/fxt/bitcount01.h
+include/fxt/bithigh.h
+include/fxt/bitlow.h
+include/fxt/bitmisc.h
+include/fxt/bitrotate.h
+include/fxt/bits2pow.h
+include/fxt/bitsasm.h
+include/fxt/bitsequency.h
+include/fxt/bitslazy.h
+include/fxt/bitsperlong.h
+include/fxt/bitsubset.h
+include/fxt/bitswap.h
+include/fxt/bitzip.h
+include/fxt/branchless.h
+include/fxt/cmult.h
+include/fxt/comblex.h
+include/fxt/combminchange.h
+include/fxt/combnum.h
+include/fxt/complextype.h
+include/fxt/constants.h
+include/fxt/copy.h
+include/fxt/copy2d.h
+include/fxt/cycles.h
+include/fxt/diskaux.h
+include/fxt/factor.h
+include/fxt/funcemu.h
+include/fxt/fxt.h
+include/fxt/fxtauxlazy.h
+include/fxt/fxtio.h
+include/fxt/fxtiomanip.h
+include/fxt/fxtmult.h
+include/fxt/fxttypes.h
+include/fxt/gcd.h
+include/fxt/graycode.h
+include/fxt/graypermute.h
+include/fxt/inline.h
+include/fxt/jjassert.h
+include/fxt/ldn2rc.h
+include/fxt/minmax.h
+include/fxt/minmax2d.h
+include/fxt/misc.h
+include/fxt/misc2d.h
+include/fxt/mod.h
+include/fxt/modarith.h
+include/fxt/modm.h
+include/fxt/moduli.h
+include/fxt/mtypes.h
+include/fxt/newop.h
+include/fxt/ntt.h
+include/fxt/paren.h
+include/fxt/partition.h
+include/fxt/permderange.h
+include/fxt/permlex.h
+include/fxt/permminchange.h
+include/fxt/permtrotter.h
+include/fxt/permutation.h
+include/fxt/permutelazy.h
+include/fxt/permvisit.h
+include/fxt/primes.h
+include/fxt/printbin.h
+include/fxt/quantise.h
+include/fxt/radixpermute.h
+include/fxt/revbin.h
+include/fxt/revbinpermute.h
+include/fxt/revbinpermute0.h
+include/fxt/reverse.h
+include/fxt/reverse2d.h
+include/fxt/rotate.h
+include/fxt/rotate2d.h
+include/fxt/scale.h
+include/fxt/scale2d.h
+include/fxt/scan.h
+include/fxt/scanbox.h
+include/fxt/search.h
+include/fxt/searchidx.h
+include/fxt/searchptr.h
+include/fxt/shift.h
+include/fxt/shift2d.h
+include/fxt/shortfhtdifcore.h
+include/fxt/shortfhtditcore.h
+include/fxt/shortgraypermute.h
+include/fxt/shortrevbinpermute.h
+include/fxt/shortrevbinpermute0.h
+include/fxt/sincos.h
+include/fxt/sort.h
+include/fxt/sortcomplex.h
+include/fxt/sortfunc.h
+include/fxt/sortidx.h
+include/fxt/sortlazy.h
+include/fxt/sortptr.h
+include/fxt/subsetminchange.h
+include/fxt/sumdiff.h
+include/fxt/transpose.h
+include/fxt/unique.h
+include/fxt/waveletfilter.h
+include/fxt/workspace.h
+include/fxt/zerobyte.h
+include/fxt/zip.h
+include/fxt/ziprev.h
+lib/fxt/libfxt.a
+@dirrm include/fxt
+@dirrm lib/fxt