aboutsummaryrefslogtreecommitdiff
path: root/math/gambit/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-02-09 05:23:06 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-02-09 05:23:06 +0000
commitdf95a34e2a1ee02ee1dd571dcb5618ea1b367df4 (patch)
tree03458ff72cc43554f1f1b4f019b89796b2f0884e /math/gambit/Makefile
parent120650ca4ede2eaaabe954869319842cf9165c3c (diff)
downloadports-df95a34e2a1ee02ee1dd571dcb5618ea1b367df4.tar.gz
ports-df95a34e2a1ee02ee1dd571dcb5618ea1b367df4.zip
re-add gambit 0.97.0.3
A library of tools for doing computation in game theory
Notes
Notes: svn path=/head/; revision=75161
Diffstat (limited to 'math/gambit/Makefile')
-rw-r--r--math/gambit/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/math/gambit/Makefile b/math/gambit/Makefile
new file mode 100644
index 000000000000..b0f939333d55
--- /dev/null
+++ b/math/gambit/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: gambit
+# Date created: Feb 8, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gambit
+PORTVERSION= 0.97.0.3
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk-devel
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+
+post-patch:
+ @${GREP} -lR "values\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
+ -e "s|values\.h|limits.h|"
+ @${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
+ -e "s|malloc\.h|stdlib.h|"
+
+.include <bsd.port.mk>