aboutsummaryrefslogtreecommitdiff
path: root/math/glgraph/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-07 03:14:23 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-07 03:14:23 +0000
commit2841e1e6651c3cf901628c0ee95a4ef8bc3e8c5d (patch)
tree1122b4c5d06503dbe74b055c201e9b2bbd64ef2f /math/glgraph/Makefile
parent13f3771961acb938d5774e4a9a4a6b55845433e5 (diff)
downloadports-2841e1e6651c3cf901628c0ee95a4ef8bc3e8c5d.tar.gz
ports-2841e1e6651c3cf901628c0ee95a4ef8bc3e8c5d.zip
add glgraph 0.2.6
An OpenGL based function grapher
Notes
Notes: svn path=/head/; revision=72664
Diffstat (limited to 'math/glgraph/Makefile')
-rw-r--r--math/glgraph/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/math/glgraph/Makefile b/math/glgraph/Makefile
new file mode 100644
index 000000000000..29de9f5a0843
--- /dev/null
+++ b/math/glgraph/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: glgraph
+# Date created: Jan 7, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= glgraph
+PORTVERSION= 0.2.6
+CATEGORIES= math
+MASTER_SITES= http://glgraph.kaosu.ch/downl/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/OpenGL.pm:${PORTSDIR}/graphics/p5-OpenGL \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+ ${SITE_PERL}/Math/Trig.pm:${PORTSDIR}/math/p5-Math-Trig \
+ import:${PORTSDIR}/graphics/ImageMagick
+
+USE_BZIP2= yes
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/glgraph ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/documentation.html ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>