aboutsummaryrefslogtreecommitdiff
path: root/math/gnuplot
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2002-11-23 18:25:47 +0000
committerGreg Lewis <glewis@FreeBSD.org>2002-11-23 18:25:47 +0000
commit38a4c49b1e460d2797f4ebf7b8ae97a5dcd0ae3d (patch)
tree60a7da161fc32be4e2143c9ff3d413de04f38b5a /math/gnuplot
parentd7b9d91adcdf954b98b85495af4f97c447c8040e (diff)
downloadports-38a4c49b1e460d2797f4ebf7b8ae97a5dcd0ae3d.tar.gz
ports-38a4c49b1e460d2797f4ebf7b8ae97a5dcd0ae3d.zip
. Add a knob to allow compilation without PNG support.
. Add a similar knob which introduces (optional) PDFlib support. Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=70889
Diffstat (limited to 'math/gnuplot')
-rw-r--r--math/gnuplot/Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index cf46c707ac74..393972587fd1 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -13,7 +13,13 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= chuckr@FreeBSD.org
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+LIB_DPEENDS=
+.if !defined(WITHOUT_PNG)
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+.endif
+.if !defined(WITHOUT_PDF)
+LIB_DEPENDS+= pdf.4:${PORTSDIR}/print/pdflib
+.endif
.if !defined(WITHOUT_X11)
USE_XLIB= yes
@@ -25,7 +31,17 @@ CONFIGURE_ARGS= --exec-prefix=${PREFIX} \
--includedir=${LOCALBASE}/include/ \
--libdir=${LOCALBASE}/lib \
--without-linux-vga --without-gd \
- --with-readline=gnu --with-lasergnu --with-png=${LOCALBASE}
+ --with-readline=gnu --with-lasergnu
+.if !defined(WITHOUT_PNG)
+CONFIGURE_ARGS+=--with-png=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--without-png
+.endif
+.if !defined(WITHOUT_PDF)
+CONFIGURE_ARGS+=--with-pdf=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--without-pdf
+.endif
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --without-x