aboutsummaryrefslogtreecommitdiff
path: root/math/gracetmpl
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-08-16 16:36:20 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-08-16 16:36:20 +0000
commit77b7980ad8c0453aeef85b5115de936aa461a889 (patch)
treedf9cdf28ef1b5d8c6d78c4d3b2da784bb0919b45 /math/gracetmpl
parent7ff48abafca32008cdb362e23fcb535eaa740afe (diff)
downloadports-77b7980ad8c0453aeef85b5115de936aa461a889.tar.gz
ports-77b7980ad8c0453aeef85b5115de936aa461a889.zip
Unbreak with gcc 3.4.2
Notes
Notes: svn path=/head/; revision=116415
Diffstat (limited to 'math/gracetmpl')
-rw-r--r--math/gracetmpl/Makefile4
-rw-r--r--math/gracetmpl/files/patch-pygracetmpl.cc11
2 files changed, 11 insertions, 4 deletions
diff --git a/math/gracetmpl/Makefile b/math/gracetmpl/Makefile
index b1fb781d2325..b895beb85a89 100644
--- a/math/gracetmpl/Makefile
+++ b/math/gracetmpl/Makefile
@@ -28,10 +28,6 @@ INSTALL_TARGET= install python_install
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile with gcc 3.4.2"
-.endif
-
.if ${OSVERSION} < 500041
CFLAGS+= "${CPPFLAGS}"
MAKE_ENV= LDFLAGS="${LDFLAGS}"
diff --git a/math/gracetmpl/files/patch-pygracetmpl.cc b/math/gracetmpl/files/patch-pygracetmpl.cc
new file mode 100644
index 000000000000..9ba3f2d0cad8
--- /dev/null
+++ b/math/gracetmpl/files/patch-pygracetmpl.cc
@@ -0,0 +1,11 @@
+--- python/src/pygracetmpl.cc.orig Mon Aug 16 18:25:45 2004
++++ python/src/pygracetmpl.cc Mon Aug 16 18:31:35 2004
+@@ -179,7 +179,7 @@
+ int rows = dataArray->dimensions[1];
+ if(cols > 4)
+ cols = 4;
+- double **data = new (double *)[cols];
++ double **data = new double *[cols];
+ for(int c = 0; c < cols; ++c){
+ data[c] = new double[rows];
+ for(int r = 0; r < rows; ++r)