aboutsummaryrefslogtreecommitdiff
path: root/math/hs-math-functions/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2012-02-02 12:56:00 +0000
committerWen Heping <wen@FreeBSD.org>2012-02-02 12:56:00 +0000
commitcef3e449d23d08e6263ca22d8ab87151d489dd98 (patch)
tree9920395e2030c9edbbe9cc0aa20bf3023b97b4c0 /math/hs-math-functions/Makefile
parente3a1eef7176e4b63bf3e04b8e8bba986f2ec32c4 (diff)
downloadports-cef3e449d23d08e6263ca22d8ab87151d489dd98.tar.gz
ports-cef3e449d23d08e6263ca22d8ab87151d489dd98.zip
This library provides implementations of special mathematical functions
and Chebyshev polynomials. These functions are often useful in statistical and numerical computing. WWW: https://github.com/bos/math-functions
Notes
Notes: svn path=/head/; revision=290293
Diffstat (limited to 'math/hs-math-functions/Makefile')
-rw-r--r--math/hs-math-functions/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/math/hs-math-functions/Makefile b/math/hs-math-functions/Makefile
new file mode 100644
index 000000000000..0e10205c9dd6
--- /dev/null
+++ b/math/hs-math-functions/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: hs-math-functions
+# Date created: Feb 2, 2012
+# Whom: Wen Heping<wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= math-functions
+PORTVERSION= 0.1.1.0
+CATEGORIES= math haskell
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Special mathematical functions and Chebyshev polynomials
+
+LICENSE= BSD
+
+USE_CABAL= erf>=2 vector>=0.7
+
+CABAL_SETUP= Setup.hs
+
+PORTDATA= *
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>