aboutsummaryrefslogtreecommitdiff
path: root/math/jags/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-01-03 18:13:44 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-01-03 18:13:44 +0000
commit2487f5dd9f71952c72763105b575ccefc6d8b627 (patch)
treea9ed4d408787356b1497cb93cfb6721ccc20f69e /math/jags/Makefile
parent6f5df18c0f001332f80a8becee6557d00200e10e (diff)
downloadports-2487f5dd9f71952c72763105b575ccefc6d8b627.tar.gz
ports-2487f5dd9f71952c72763105b575ccefc6d8b627.zip
math/jags: 3.4.0 -> 4.0.0
Notes
Notes: svn path=/head/; revision=405180
Diffstat (limited to 'math/jags/Makefile')
-rw-r--r--math/jags/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/math/jags/Makefile b/math/jags/Makefile
index 1b9d8e51cb8e..e7d74de448b4 100644
--- a/math/jags/Makefile
+++ b/math/jags/Makefile
@@ -2,14 +2,14 @@
# $FreeBSD$
PORTNAME= mcmc-jags
-PORTVERSION= 3.4.0
-PORTREVISION= 4
+PORTVERSION= 4.0.0
CATEGORIES= math
MASTER_SITES= SF/mcmc-jags/JAGS/${S}.x/Source/:1 \
SF/mcmc-jags/Examples/${S}.x/:2 \
SF/mcmc-jags/Manuals/2.x/:3 \
SF/mcmc-jags/Manuals/${S}.x/:4
DISTFILES= JAGS-${PORTVERSION}${EXTRACT_SUFX}:1
+DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTFILES:M*[12]:C|:.*||}
MAINTAINER= bf@FreeBSD.org
@@ -18,14 +18,12 @@ COMMENT= Just Another Gibbs Sampler
LICENSE= GPLv2
GNU_CONFIGURE= yes
-USES= bison fortran gmake libtool
+USES= bison compiler:features fortran gmake libtool localbase
+USE_GCC= yes
USE_LDCONFIG= yes
-DIST_SUBDIR= ${PORTNAME}
WRKSRC= ${WRKDIR}/JAGS-${PORTVERSION}
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= MODULEVERSION=${S}
S= ${PORTVERSION:C|\..*||}
@@ -57,7 +55,7 @@ LIB_DEPENDS+= libblas.so:${PORTSDIR}/math/blas
LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack
CONFIGURE_ARGS= --with-lapack="-llapack" --with-blas="-lblas"
.else
-IGNORE= : invalid value for WITH_BLAS: ${WITH_BLAS}
+IGNORE= invalid value for WITH_BLAS: ${WITH_BLAS}
.endif
post-patch: