aboutsummaryrefslogtreecommitdiff
path: root/math/jags/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-27 15:18:45 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-27 15:18:45 +0000
commitab9154efa788aeee6fca013f4b2e4d3b7dc92569 (patch)
tree265996119ee176ebeb10ddea1cec1b991026c608 /math/jags/Makefile
parentcdc54f9e1966d4dd2aa1f64844de6cd0871835eb (diff)
downloadports-ab9154efa788aeee6fca013f4b2e4d3b7dc92569.tar.gz
ports-ab9154efa788aeee6fca013f4b2e4d3b7dc92569.zip
Add jags, Just Another Gibbs Sampler. A program for Bayesian analysis of
graphical models via Gibbs sampling, not wholy unlike classic BUGS. PR: ports/66648 Submitted by: Eric van Gyzen <vangyzen@stat.duke.edu>
Notes
Notes: svn path=/head/; revision=110135
Diffstat (limited to 'math/jags/Makefile')
-rw-r--r--math/jags/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/math/jags/Makefile b/math/jags/Makefile
new file mode 100644
index 000000000000..7d51506eae31
--- /dev/null
+++ b/math/jags/Makefile
@@ -0,0 +1,48 @@
+# Ports collection Makefile for: jags
+# Date created: 21 April 2004
+# Whom: Eric van Gyzen <vangyzen@stat.duke.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jags
+PORTVERSION= 0.50
+CATEGORIES= math
+MASTER_SITES= http://www-fis.iarc.fr/~martyn/software/jags/
+DISTNAME= ${PORTNAME:U}-${PORTVERSION}
+.if !defined(NOPORTDOCS)
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} bugs-examples.tar.gz manual.pdf
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+.endif
+
+MAINTAINER= vangyzen@stat.duke.edu
+COMMENT= Just Another Gibbs Sampler
+
+LIB_DEPENDS= Rmath.0:${PORTSDIR}/math/libRmath
+
+.if defined(WITH_ATLAS)
+LIB_DEPENDS+= f77blas.1:${PORTSDIR}/math/atlas
+CONFIGURE_ARGS= --with-lapack=-lalapack --with-blas=-lf77blas
+.else
+LIB_DEPENDS+= lapack.3:${PORTSDIR}/math/lapack
+CONFIGURE_ARGS= --with-lapack=-llapack --with-blas=-lblas
+.endif
+
+USE_BISON= yes
+
+DIST_SUBDIR= ${PORTNAME}
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LDFLAGS=-L${PREFIX}/lib
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/manual.pdf ${DOCSDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ ( cd ${EXAMPLESDIR}; \
+ ${PAX} -rzf ${DISTDIR}/${DIST_SUBDIR}/bugs-examples.tar.gz \
+ -s ':^bugs-examples/*::' )
+.endif
+
+.include <bsd.port.mk>