aboutsummaryrefslogtreecommitdiff
path: root/math/kash3
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
commitfb3520254ab73be0aad04c3a63b781750cf26b5b (patch)
tree268d74f9d8738f78b0c895672044611aa6343387 /math/kash3
parent4706739618b79681811e5b336a54032908638160 (diff)
downloadports-fb3520254ab73be0aad04c3a63b781750cf26b5b.tar.gz
ports-fb3520254ab73be0aad04c3a63b781750cf26b5b.zip
- Convert to OptionsNG
- Trim header Reviewed by: beat, bapt, kwm
Notes
Notes: svn path=/head/; revision=313460
Diffstat (limited to 'math/kash3')
-rw-r--r--math/kash3/Makefile24
1 files changed, 11 insertions, 13 deletions
diff --git a/math/kash3/Makefile b/math/kash3/Makefile
index 5b24daa7a3cd..ba539b230633 100644
--- a/math/kash3/Makefile
+++ b/math/kash3/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: kash3
-# Date created: 2006-02-26
-# Whom: Nicola Vitale <nivit@email.it>
-#
+# Created by: Nicola Vitale <nivit@email.it>
# $FreeBSD$
-#
PORTNAME= kash3
PORTVERSION= 2008.07.31
@@ -20,7 +16,9 @@ RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl
NO_CDROM= not for commercial distribution or use
NO_BUILD= yes
-OPTIONS= OPTLIB "Install optional functions library" on
+OPTIONS_DEFINE= OPTLIB DOCS
+OPTIONS_DEFAULT= OPTLIB
+OPTLIB_DESC= Install optional functions library
PLIST_SUB= OPTLIB=${OPTLIB}
@@ -35,16 +33,16 @@ FIND_DATA= -type f -mindepth 1 -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
FIND_DIRS= -type d -exec ${MKDIR} ${DATADIR}/{} \;
FIND_HERE= data gap lib
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
FIND_HERE+= html pdf
.endif
LN_OPTS= -sf
ELFTYPE= Linux
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_OPTLIB)
+.if ${PORT_OPTIONS:MOPTLIB}
DISTFILES+= ${PORTNAME:U}-lib-archindep-${PORTVERSION:S|.|-|g}.tar.bz2
OPTLIB=
.else
@@ -53,7 +51,7 @@ OPTLIB= "@comment "
do-install:
${MKDIR} ${DATADIR};
-.if defined(WITH_OPTLIB)
+.if ${PORT_OPTIONS:MOPTLIB}
cd ${WRKDIR}/${PORTNAME:U}-lib-archindep-${PORTVERSION:S|.|-|g}; \
${COPYTREE_SHARE} . ${DATADIR}
.endif
@@ -63,9 +61,9 @@ do-install:
${BRANDELF} -t ${ELFTYPE} ${PORTNAME}; \
${INSTALL_PROGRAM} ${PORTNAME} ${DATADIR}/${PORTNAME};
${INSTALL_SCRIPT} ${WRKDIR}/${SUB_FILES} ${PREFIX}/bin/${PORTNAME}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}; \
${MV} ${DATADIR}/html ${DATADIR}/pdf ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>