aboutsummaryrefslogtreecommitdiff
path: root/math/kcalc/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-09-02 21:06:27 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-09-02 21:06:27 +0000
commit08351f8e016396e46d654e72eceb6a2ed81aadbb (patch)
treed97f07c03bb7f9977c1021629266214a9d2310e6 /math/kcalc/Makefile
parent0b3b58a79f748bf25f2a89f19316de184c390fa6 (diff)
downloadports-08351f8e016396e46d654e72eceb6a2ed81aadbb.tar.gz
ports-08351f8e016396e46d654e72eceb6a2ed81aadbb.zip
KDE FreeBSD team presents KDE SC 4.5.1.
New ports added: misc/kde4-l10n-ia - Interlingua localization for KDE
Notes
Notes: svn path=/head/; revision=260443
Diffstat (limited to 'math/kcalc/Makefile')
-rw-r--r--math/kcalc/Makefile46
1 files changed, 40 insertions, 6 deletions
diff --git a/math/kcalc/Makefile b/math/kcalc/Makefile
index 54897f73604e..143fdff3786c 100644
--- a/math/kcalc/Makefile
+++ b/math/kcalc/Makefile
@@ -14,6 +14,7 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Utilities for the KDE4 integrated X11 Desktop
+BUILD_DEPENDS= ${LOCALBASE}/share/xml/docbook/4.2/docbookx.dtd:${PORTSDIR}/textproc/docbook-xml
LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
qimageblitz.4:${PORTSDIR}/x11/qimageblitz \
qca.2:${PORTSDIR}/devel/qca
@@ -25,28 +26,61 @@ USE_BZIP2= yes
USE_QT_VER= 4
USE_PYTHON= 2.5+
KDE4_BUILDENV= yes
-USE_KDE4= kdelibs pimlibs kdeprefix kdehier automoc4 kdebase workspace
+USE_KDE4= kdeprefix kdehier automoc4 sharedmime \
+ kdelibs pimlibs workspace kdebase
QT_COMPONENTS= network gui porting xml \
qmake_build moc_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
MAN1= ark.1
-OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
+OPTIONS= 7ZIP "Support for 7-Zip archives in Ark" off \
+ PRINTER_APPLET "Install printer system tray utility" off \
+ RAR "Support for RAR archives in Ark" off \
+ ZIP "Support for ZIP archives in Ark" off
.include <bsd.port.options.mk>
+.ifdef(WITH_7ZIP)
+RUN_DEPENDS+= 7z:${PORTSDIR}/archivers/p7zip
+.endif
+
+.ifdef(WITH_PRINTER_APPLET)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/printer-applet:${PORTSDIR}/print/kdeutils4-printer-applet
+.endif
+
+.ifdef(WITH_ZIP)
+RUN_DEPENDS+= unzip>0:${PORTSDIR}/archivers/unzip \
+ zip:${PORTSDIR}/archivers/zip
+.endif
+
+.include <bsd.port.pre.mk>
+
.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
.endif
-.if defined(WITH_PRINTER_APPLET)
-RUN_DEPENDS+= ${KDE4_PREFIX}/bin/printer-applet:${PORTSDIR}/print/kdeutils4-printer-applet
+.ifdef(WITH_RAR)
+.if ${ARCH} != "amd64" && ${ARCH} != "ia64" && ${ARCH} != "powerpc" && ${ARCH} != "sparc64"
+INSTALL_RAR= YES
+.elif ${ARCH} == "amd64"
+.ifndef(HAVE_COMPAT_IA32_KERN)
+HAVE_COMPAT_IA32_KERN!= if ${SYSCTL} -n compat.ia32.maxvmem >/dev/null 2>&1; then ${ECHO_CMD} YES; fi
+.endif
+.if ${HAVE_COMPAT_IA32_KERN} == "YES"
+INSTALL_RAR= YES
+.endif
+.endif
+.ifdef(INSTALL_RAR)
+RUN_DEPENDS+= rar:${PORTSDIR}/archivers/rar
+.else
+RUN_DEPENDS+= unrar:${PORTSDIR}/archivers/unrar
+.endif
.endif
post-patch:
-#disable printer-applet, it comes with print/kdeutils4-printer-applet
+# Disable printer-applet, it comes with print/kdeutils4-printer-applet.
${REINPLACE_CMD} -e '/add_subdirectory.*printer-applet/d' \
${PATCH_WRKSRC}/CMakeLists.txt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>