aboutsummaryrefslogtreecommitdiff
path: root/math/kcalc
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-05-16 19:26:43 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-05-16 19:26:43 +0000
commita34b8d38b831d19001533639592430f41527a96c (patch)
tree039439a298b8e93967986e11178208cf8e1adbe2 /math/kcalc
parenteb56f7f7066ae94ebacc2284e0b0000539fca8d9 (diff)
downloadports-a34b8d38b831d19001533639592430f41527a96c.tar.gz
ports-a34b8d38b831d19001533639592430f41527a96c.zip
Update KDE Software Compilation ports to 4.6.3
Special thanks to Raphael Kubo da Costa for his work on this update.
Notes
Notes: svn path=/head/; revision=274204
Diffstat (limited to 'math/kcalc')
-rw-r--r--math/kcalc/Makefile8
-rw-r--r--math/kcalc/distinfo4
-rw-r--r--math/kcalc/files/patch-ark-CMakeLists.txt26
-rw-r--r--math/kcalc/files/patch-ark-plugins-CMakeLists.txt32
4 files changed, 63 insertions, 7 deletions
diff --git a/math/kcalc/Makefile b/math/kcalc/Makefile
index 0a7c286315db..9a66faa99cad 100644
--- a/math/kcalc/Makefile
+++ b/math/kcalc/Makefile
@@ -33,6 +33,9 @@ MAKE_JOBS_SAFE= yes
MAN1= ark.1
+# Disable printer-applet, it comes with print/kdeutils4-printer-applet.
+CMAKE_ARGS+= -DBUILD_printer-applet=OFF
+
OPTIONS= 7ZIP "Support for 7-Zip archives in Ark" off \
PRINTER_APPLET "Install printer system tray utility" off \
RAR "Support for RAR archives in Ark" off \
@@ -76,9 +79,4 @@ RUN_DEPENDS+= rar:${PORTSDIR}/archivers/rar
.endif
.endif
-post-patch:
-# Disable printer-applet, it comes with print/kdeutils4-printer-applet.
- ${REINPLACE_CMD} -e '/add_subdirectory.*printer-applet/d' \
- ${PATCH_WRKSRC}/CMakeLists.txt
-
.include <bsd.port.post.mk>
diff --git a/math/kcalc/distinfo b/math/kcalc/distinfo
index 67cad0f38a7b..824077cfc83b 100644
--- a/math/kcalc/distinfo
+++ b/math/kcalc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/kdeutils-4.6.2.tar.bz2) = d1a2d77fe51fe6fb3c9eb79408b7d617927e0e12a0e6d34d2b21cd087d9afbeb
-SIZE (KDE/kdeutils-4.6.2.tar.bz2) = 3703067
+SHA256 (KDE/kdeutils-4.6.3.tar.bz2) = d61e97a5b3464fbfaef624927cfc19da4158dd91f2e020eb245d10da8af33196
+SIZE (KDE/kdeutils-4.6.3.tar.bz2) = 3703326
diff --git a/math/kcalc/files/patch-ark-CMakeLists.txt b/math/kcalc/files/patch-ark-CMakeLists.txt
new file mode 100644
index 000000000000..fae223ae2a40
--- /dev/null
+++ b/math/kcalc/files/patch-ark-CMakeLists.txt
@@ -0,0 +1,26 @@
+KDE SVN revision r1230915.
+
+Author: rkcosta (Raphael Kubo da Costa)
+Date: Sun May 8 17:30:06 2011 +0000
+
+ Put the libarchive detection calls before configure_file().
+
+ The generated config.h was using some variables defined only after
+ plugins/CMakeLists.txt called macro_optional_find_package(LibArchive),
+ however the top-level CMakeLists.txt relied on these variables already
+ being set, which was never the case.
+
+ BUG: 271553
+ FIXED-IN: 4.6.4
+
+--- ark/CMakeLists.txt
++++ ark/CMakeLists.txt
+@@ -1,5 +1,8 @@
+ project(ark)
+
++macro_optional_find_package(LibArchive)
++macro_log_feature(LIBARCHIVE_FOUND "LibArchive" "A library for dealing with a wide variety of archive file formats" "http://code.google.com/p/libarchive/" FALSE "" "Required for among others tar, tar.gz, tar.bz2 formats in Ark.")
++
+ configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)
+
+ add_subdirectory(part)
diff --git a/math/kcalc/files/patch-ark-plugins-CMakeLists.txt b/math/kcalc/files/patch-ark-plugins-CMakeLists.txt
new file mode 100644
index 000000000000..f157bf403124
--- /dev/null
+++ b/math/kcalc/files/patch-ark-plugins-CMakeLists.txt
@@ -0,0 +1,32 @@
+KDE SVN revision r1230915.
+
+Author: rkcosta (Raphael Kubo da Costa)
+Date: Sun May 8 17:30:06 2011 +0000
+
+ Put the libarchive detection calls before configure_file().
+
+ The generated config.h was using some variables defined only after
+ plugins/CMakeLists.txt called macro_optional_find_package(LibArchive),
+ however the top-level CMakeLists.txt relied on these variables already
+ being set, which was never the case.
+
+ BUG: 271553
+ FIXED-IN: 4.6.4
+
+--- ark/plugins/CMakeLists.txt
++++ ark/plugins/CMakeLists.txt
+@@ -1,5 +1,3 @@
+-macro_optional_find_package(LibArchive)
+-
+ if (LIBARCHIVE_FOUND)
+ if( HAVE_LIBARCHIVE_READ_DISK_API )
+ if( NOT HAVE_LIBARCHIVE_LZMA_SUPPORT OR NOT HAVE_LIBARCHIVE_XZ_SUPPORT )
+@@ -15,8 +13,6 @@ if (LIBARCHIVE_FOUND)
+ endif( HAVE_LIBARCHIVE_READ_DISK_API )
+ endif (LIBARCHIVE_FOUND)
+
+-macro_log_feature(LIBARCHIVE_FOUND "LibArchive" "A library for dealing with a wide variety of archive file formats" "http://code.google.com/p/libarchive/" FALSE "" "Required for among others tar, tar.gz, tar.bz2 formats in Ark.")
+-
+ add_subdirectory( clirarplugin )
+ add_subdirectory( cli7zplugin )
+ add_subdirectory( clizipplugin )