aboutsummaryrefslogtreecommitdiff
path: root/math/kcalc
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-07-17 16:07:23 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-07-17 16:07:23 +0000
commitc2f28f7e83083cd9486b9e3df8cff36d87da4507 (patch)
tree07cad62e878509241ca7463f244860d1033a6f9f /math/kcalc
parentd5ce86264de1fd704353c2f9501a242a078bbef3 (diff)
downloadports-c2f28f7e83083cd9486b9e3df8cff36d87da4507.tar.gz
ports-c2f28f7e83083cd9486b9e3df8cff36d87da4507.zip
- Backport patches to fix KCalc issues.
Submitted by: Raphael Kubo da Costa <kubito@gmail.com> via area51
Notes
Notes: svn path=/head/; revision=277858
Diffstat (limited to 'math/kcalc')
-rw-r--r--math/kcalc/Makefile1
-rw-r--r--math/kcalc/files/patch-ark-kerfuffle-cliiterface.cpp35
-rw-r--r--math/kcalc/files/patch-kcalc-kcalc.ui99
3 files changed, 135 insertions, 0 deletions
diff --git a/math/kcalc/Makefile b/math/kcalc/Makefile
index 9a66faa99cad..e4026f85cf9f 100644
--- a/math/kcalc/Makefile
+++ b/math/kcalc/Makefile
@@ -6,6 +6,7 @@
PORTNAME= kdeutils
PORTVERSION= ${KDE4_VERSION}
+PORTREVISION= 1
CATEGORIES= misc kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
diff --git a/math/kcalc/files/patch-ark-kerfuffle-cliiterface.cpp b/math/kcalc/files/patch-ark-kerfuffle-cliiterface.cpp
new file mode 100644
index 000000000000..f2298e0f4493
--- /dev/null
+++ b/math/kcalc/files/patch-ark-kerfuffle-cliiterface.cpp
@@ -0,0 +1,35 @@
+SVN commit 1240907 by rkcosta:
+
+cliinterface: Do not assume a process does not exist in runProcess().
+
+The Q_ASSERT(!m_process) in the beginning of runProcess() was wrong, as when
+one is adding files to an archive (or creating an archive) processFinished()
+calls list(), which in turn calls runProcess() as well, thus making the assert
+fail.
+
+The best thing to do is just wait for the existing process to finish before
+launching the new one.
+
+Backport of r1240907, in case the 4.6 ever gets packaged again.
+
+CCBUG: 277393
+
+http://websvn.kde.org/?view=revision&revision=1240908
+-- ark/kerfuffle/cliinterface.cpp 2011/06/01 20:35:06 1234597
++++ ark/kerfuffle/cliinterface.cpp 2011/07/11 03:23:39 1240908
+@@ -325,10 +325,13 @@
+ return false;
+ }
+
+- Q_ASSERT(!m_process);
+-
+ kDebug() << "Executing" << programPath << arguments;
+
++ if (m_process) {
++ m_process->waitForFinished();
++ delete m_process;
++ }
++
+ #ifdef Q_OS_WIN
+ m_process = new KProcess();
+ #else
diff --git a/math/kcalc/files/patch-kcalc-kcalc.ui b/math/kcalc/files/patch-kcalc-kcalc.ui
new file mode 100644
index 000000000000..b5f94af5bfec
--- /dev/null
+++ b/math/kcalc/files/patch-kcalc-kcalc.ui
@@ -0,0 +1,99 @@
+SVN commit 1240130 by teran:
+
+rolling back change made by r1235446, it broke keybindings entirely.
+
+BUG: 277020
+
+http://websvn.kde.org/?view=revision&revision=1240130
+--- kcalc/kcalc.ui 2011/06/05 18:25:18 1235446
++++ kcalc/kcalc.ui 2011/07/06 18:27:58 1240130
+@@ -616,7 +616,7 @@
+ <string>7</string>
+ </property>
+ <property name="shortcut">
+- <string notr="true">7</string>
++ <string>7</string>
+ </property>
+ </widget>
+ </item>
+@@ -632,7 +632,7 @@
+ <string>8</string>
+ </property>
+ <property name="shortcut">
+- <string notr="true">8</string>
++ <string>8</string>
+ </property>
+ </widget>
+ </item>
+@@ -648,7 +648,7 @@
+ <string>9</string>
+ </property>
+ <property name="shortcut">
+- <string notr="true">9</string>
++ <string>9</string>
+ </property>
+ </widget>
+ </item>
+@@ -680,7 +680,7 @@
+ <string>4</string>
+ </property>
+ <property name="shortcut">
+- <string notr="true">4</string>
++ <string>4</string>
+ </property>
+ </widget>
+ </item>
+@@ -696,7 +696,7 @@
+ <string>5</string>
+ </property>
+ <property name="shortcut">
+- <string notr="true">5</string>
++ <string>5</string>
+ </property>
+ </widget>
+ </item>
+@@ -712,7 +712,7 @@
+ <string>6</string>
+ </property>
+ <property name="shortcut">
+- <string notr="true">6</string>
++ <string>6</string>
+ </property>
+ </widget>
+ </item>
+@@ -728,7 +728,7 @@
+ <string>1</string>
+ </property>
+ <property name="shortcut">
+- <string notr="true">1</string>
++ <string>1</string>
+ </property>
+ </widget>
+ </item>
+@@ -744,7 +744,7 @@
+ <string>2</string>
+ </property>
+ <property name="shortcut">
+- <string notr="true">2</string>
++ <string>2</string>
+ </property>
+ </widget>
+ </item>
+@@ -760,7 +760,7 @@
+ <string>3</string>
+ </property>
+ <property name="shortcut">
+- <string notr="true">3</string>
++ <string>3</string>
+ </property>
+ </widget>
+ </item>
+@@ -786,7 +786,7 @@
+ <string>0</string>
+ </property>
+ <property name="shortcut">
+- <string notr="true">0</string>
++ <string>0</string>
+ </property>
+ </widget>
+ </item>