aboutsummaryrefslogtreecommitdiff
path: root/math/lambda
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-05-14 01:33:15 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-05-14 01:33:15 +0000
commit08ee6ea9df84fc82170e3601e423dfe95799aa13 (patch)
tree5dc00f28b9fbd6db79ff75d819418ac0bcf0becb /math/lambda
parent165b37a218dc6424813cd4c0dd54e0e080327746 (diff)
downloadports-08ee6ea9df84fc82170e3601e423dfe95799aa13.tar.gz
ports-08ee6ea9df84fc82170e3601e423dfe95799aa13.zip
add lambda 0.1.4
A lambda calculus interpreter
Notes
Notes: svn path=/head/; revision=109095
Diffstat (limited to 'math/lambda')
-rw-r--r--math/lambda/Makefile40
-rw-r--r--math/lambda/distinfo2
-rw-r--r--math/lambda/pkg-descr16
3 files changed, 58 insertions, 0 deletions
diff --git a/math/lambda/Makefile b/math/lambda/Makefile
new file mode 100644
index 000000000000..54d9137a6451
--- /dev/null
+++ b/math/lambda/Makefile
@@ -0,0 +1,40 @@
+# ex:ts=8
+# Ports collection makefile for: lambda
+# Date created: Mar 23, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= lambda
+PORTVERSION= 0.1.4
+CATEGORIES= math
+MASTER_SITES= http://66.47.116.75/~demo/lambda/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A lambda calculus interpreter
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/lambda \
+ share/lambda/definitions \
+ share/lambda/definitions_with_numbers
+PLIST_DIRS= share/lambda
+
+.if !defined(NOPORTDOCS)
+DOCS= lambda.html lambdamanual.html user_manual_style.css
+PORTDOCS= *
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/lambda ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/definitions* ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/docs/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/lambda/distinfo b/math/lambda/distinfo
new file mode 100644
index 000000000000..16ab41736223
--- /dev/null
+++ b/math/lambda/distinfo
@@ -0,0 +1,2 @@
+MD5 (lambda-0.1.4.tar.gz) = 7987fed0e62a3b639eb09abb5a136d4c
+SIZE (lambda-0.1.4.tar.gz) = 102295
diff --git a/math/lambda/pkg-descr b/math/lambda/pkg-descr
new file mode 100644
index 000000000000..a3eecc6d2c66
--- /dev/null
+++ b/math/lambda/pkg-descr
@@ -0,0 +1,16 @@
+Lambda is a lambda calculus interpreter. It also will convert lambda expression
+into the combinators S, K, and I.
+
+Current features:
+ * Load predefined lambda expression
+ * Many definitions provided: numbers Y fact map iszero list 1st 2nd 3rd
+ ADD MUL EXP list suc pred . . .
+ * Automatic number definitions.
+ * Interpret lambda expressions.
+ * Single step interpretation.
+ * Normal or application order reductions.
+ * Variable extraction (Conversion to S K I)
+ * List definitions.
+ * Some lambda calculus theory.
+
+WWW: http://66.47.116.75/~demo/lambda/