aboutsummaryrefslogtreecommitdiff
path: root/math/lapack++
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2005-05-11 11:09:46 +0000
committerMaho Nakata <maho@FreeBSD.org>2005-05-11 11:09:46 +0000
commit52d43b3578acfbf0c143837b4cf587cc8f6c0d8b (patch)
treecb5d35070e2de25f1a0b809fcc2b279a048b4c03 /math/lapack++
parent44c80ae215a42698321b02f5b0469cd5ecdef982 (diff)
downloadports-52d43b3578acfbf0c143837b4cf587cc8f6c0d8b.tar.gz
ports-52d43b3578acfbf0c143837b4cf587cc8f6c0d8b.zip
Update to 2.2.0
Notes
Notes: svn path=/head/; revision=135046
Diffstat (limited to 'math/lapack++')
-rw-r--r--math/lapack++/Makefile53
-rw-r--r--math/lapack++/distinfo4
-rw-r--r--math/lapack++/files/patch-blaspp:testing:blas++_test11
-rw-r--r--math/lapack++/files/patch-blaspp:testing:makefile11
-rw-r--r--math/lapack++/files/patch-include:blas++.h15
-rw-r--r--math/lapack++/files/patch-include:laslv.h11
-rw-r--r--math/lapack++/files/patch-makefile29
-rw-r--r--math/lapack++/files/patch-makefile.def45
-rw-r--r--math/lapack++/files/patch-matrix:testing:matrix_test11
-rw-r--r--math/lapack++/files/patch-src:eigslv.cc61
-rw-r--r--math/lapack++/files/patch-testing:lapack++_test11
-rw-r--r--math/lapack++/pkg-descr2
-rw-r--r--math/lapack++/pkg-plist131
13 files changed, 98 insertions, 297 deletions
diff --git a/math/lapack++/Makefile b/math/lapack++/Makefile
index cbbfaa9ab829..efe0e42f543b 100644
--- a/math/lapack++/Makefile
+++ b/math/lapack++/Makefile
@@ -6,50 +6,45 @@
#
PORTNAME= lapack++
-PORTVERSION= 1.1
+PORTVERSION= 2.2.0
CATEGORIES= math
-MASTER_SITES= http://math.nist.gov/lapack++/
-DISTNAME= Lapackpp1_1a
-EXTRACT_SUFX= .tgz
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://math.nist.gov/lapack++/:doc
+MASTER_SITE_SUBDIR= lapackpp
+DISTNAME= lapackpp-${PORTVERSION}
.if !defined(NOPORTDOCS)
-DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} lapack++.ps.gz lapackpp1_1.ps.gz \
- lapackppman1_1.ps.gz lapack++_install.ps.gz
+DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} lapack++.ps.gz:doc lapackpp1_1.ps.gz:doc \
+ lapackppman1_1.ps.gz:doc lapack++_install.ps.gz:doc
.endif
DIST_SUBDIR= lapack++
-EXTRACT_ONLY= Lapackpp1_1a.tgz
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= maho@FreeBSD.org
COMMENT= Linear Algebra PACKage in C++, a wrapper for LAPACK
+.if !defined(WITH_BLAS)
LIB_DEPENDS= atlas:${PORTSDIR}/math/atlas
+.endif
-WRKSRC= ${WRKDIR}/Lapackpp1.1a
-USE_REINPLACE= yes
-
-#ATLAS_BLAS
-BLAS_LIB= -lf77blas -latlas
-LAPACK_LIB= -lalapack -lcblas
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
-#Vanilla BLAS
-#BLAS_LIB= -lblas
-#LAPACK_LIB= -llapack
+.if defined(WITH_BLAS)
+BLAS_LIB= -L${LOCALBASE}/lib -lblas
+LAPACK_LIB= -L${LOCALBASE}/lib -llapack
+.else
+BLAS_LIB= -L${LOCALBASE}/lib -lf77blas -latlas
+LAPACK_LIB= -L${LOCALBASE}/lib -lalapack -lcblas
+.endif
-#SMP version (KSE required)
-#BLAS_LIB= -lptf77blas -latlas_r ${PTHREAD_LIBS}
-#LAPACK_LIB= -lalapack_r -lptcblas ${PTHREAD_LIBS}
+#BLAS_LIB= -L${LOCALBASE}/lib -lptf77blas -latlas_r ${PTHREAD_LIBS}
+#LAPACK_LIB= -L${LOCALBASE}/lib -lalapack_r -lptcblas ${PTHREAD_LIBS}
-post-patch:
- @(cd ${WRKSRC} ; ${MV} makefile Makefile)
- @${REINPLACE_CMD} -e 's+%%BLAS_LIB%%+${BLAS_LIB}+g;' \
- -e 's+%%LAPACK_LIB%%+${LAPACK_LIB}+g;' \
- ${WRKSRC}/makefile.def
+#lapack++ forces to use atlas when detected, so we should disable here.
+CONFIGURE_ARGS+= --with-blas="${BLAS_LIB}" --with-lapack="${LAPACK_LIB}" --disable-atlas
do-install:
-.for i in libblas++ liblamatrix++ liblapack++
- ${INSTALL_DATA} ${WRKSRC}/${i}.a ${PREFIX}/lib
-.endfor
- @${MKDIR} ${PREFIX}/include/lapack++
- ${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include/lapack++
+ @(cd ${WRKSRC} ; ${GMAKE} install)
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/lapack++.ps.gz ${DOCSDIR}
diff --git a/math/lapack++/distinfo b/math/lapack++/distinfo
index 9ef56368dbf7..71f56112e1cc 100644
--- a/math/lapack++/distinfo
+++ b/math/lapack++/distinfo
@@ -1,5 +1,5 @@
-MD5 (lapack++/Lapackpp1_1a.tgz) = 8a55a8d939d460f18f209a6c5c9d2515
-SIZE (lapack++/Lapackpp1_1a.tgz) = 66314
+MD5 (lapack++/lapackpp-2.2.0.tar.gz) = 095313e4839ced4b101d8aac9f117cfd
+SIZE (lapack++/lapackpp-2.2.0.tar.gz) = 481460
MD5 (lapack++/lapack++.ps.gz) = 59ad006ae7b334d44efeecfb127abb9b
SIZE (lapack++/lapack++.ps.gz) = 71184
MD5 (lapack++/lapackpp1_1.ps.gz) = 433f8b9b50d5ce2657a762389eb8c285
diff --git a/math/lapack++/files/patch-blaspp:testing:blas++_test b/math/lapack++/files/patch-blaspp:testing:blas++_test
deleted file mode 100644
index 504663e6e22d..000000000000
--- a/math/lapack++/files/patch-blaspp:testing:blas++_test
+++ /dev/null
@@ -1,11 +0,0 @@
---- blaspp/testing/blas++_test.org Tue Feb 29 05:42:30 2000
-+++ blaspp/testing/blas++_test Mon May 20 10:30:07 2002
-@@ -31,7 +31,7 @@
- foreach t ($testsuite)
- set answer = $t:t.out
- echo "$t $N[1] $M[1] >& $answer"
-- $t $N[1] $M[1] >& $answer
-+ ./$t $N[1] $M[1] >& $answer
-
- end
-
diff --git a/math/lapack++/files/patch-blaspp:testing:makefile b/math/lapack++/files/patch-blaspp:testing:makefile
deleted file mode 100644
index cfa85b5f04ab..000000000000
--- a/math/lapack++/files/patch-blaspp:testing:makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- blaspp/testing/makefile.org Mon May 20 11:04:29 2002
-+++ blaspp/testing/makefile Mon May 20 11:04:44 2002
-@@ -13,7 +13,7 @@
-
-
- tblasd++ : tblasd++.o
-- $(CPP) $(CPPFLAGS) -o tblasd++ tblasd++.o $(LAMATRIXPP_LIB) \
-+ $(CPP) $(CPPFLAGS) -o tblasd++ tblasd++.o -L${PREFIX}/lib $(LAMATRIXPP_LIB) \
- $(COMPLEX_LIB) $(BLASPP_LIB) $(BLAS_LIB) \
- $(FLIBS)
-
diff --git a/math/lapack++/files/patch-include:blas++.h b/math/lapack++/files/patch-include:blas++.h
deleted file mode 100644
index c4fbea53d662..000000000000
--- a/math/lapack++/files/patch-include:blas++.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- include/blas++.h~ Tue Nov 19 13:30:26 2002
-+++ include/blas++.h Tue Nov 19 13:32:03 2002
-@@ -11,7 +11,11 @@
- #include "blas2++.h"
- #include "blas3++.h"
-
--double abs(double);
-+inline double abs(double a)
-+{
-+ if(a>=0) return a;
-+ return -a;
-+}
-
- //-------------------------------------
- // Vector/Vector operators
diff --git a/math/lapack++/files/patch-include:laslv.h b/math/lapack++/files/patch-include:laslv.h
deleted file mode 100644
index 194dc56f220e..000000000000
--- a/math/lapack++/files/patch-include:laslv.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/laslv.h~ Tue Feb 29 05:42:27 2000
-+++ include/laslv.h Wed May 22 21:51:02 2002
-@@ -51,7 +51,7 @@
- void LaEigSolve(const LaSymmMatDouble &S, LaVectorDouble &eigvals,
- LaGenMatDouble &eigvec);
- void LaEigSolveIP(LaSymmMatDouble &S, LaVectorDouble &eigvals);
--void LaEigSolveVecIP(LaSymmMatDouble &S, LaVectorDouble &eigvals);
-+void LaEigSolveVecIP(LaGenMatDouble &A, LaVectorDouble &eigvals);
- #endif
-
-
diff --git a/math/lapack++/files/patch-makefile b/math/lapack++/files/patch-makefile
deleted file mode 100644
index 25dbcad8c8b7..000000000000
--- a/math/lapack++/files/patch-makefile
+++ /dev/null
@@ -1,29 +0,0 @@
---- makefile.org Tue Feb 29 05:42:30 2000
-+++ makefile Mon May 20 10:21:52 2002
-@@ -30,7 +30,7 @@
-
- matrix_testing :
- cd $(LAPACKPP_DIR)/matrix/testing; make;
-- cd $(LAPACKPP_DIR)/matrix/testing; matrix_test
-+ cd $(LAPACKPP_DIR)/matrix/testing; ./matrix_test
-
-
- # C++ interface to the BLAS
-@@ -41,7 +41,7 @@
-
- blas++_testing:
- cd $(LAPACKPP_DIR)/blaspp/testing; make;
-- cd $(LAPACKPP_DIR)/blaspp/testing; blas++_test;
-+ cd $(LAPACKPP_DIR)/blaspp/testing; ./blas++_test;
-
-
-
-@@ -56,7 +56,7 @@
- # (whose path is specified as $(TMGLIB)) be defined.
- lapack++_testing :
- cd $(LAPACKPP_DIR)/testing; make
-- cd $(LAPACKPP_DIR)/testing; lapack++_test
-+ cd $(LAPACKPP_DIR)/testing; ./lapack++_test
-
- nolibs:
- cd $(LAPACKPP_LIB_DIR); rm *.a
diff --git a/math/lapack++/files/patch-makefile.def b/math/lapack++/files/patch-makefile.def
deleted file mode 100644
index 7ac546974384..000000000000
--- a/math/lapack++/files/patch-makefile.def
+++ /dev/null
@@ -1,45 +0,0 @@
---- makefile.def.orig Wed Mar 1 02:42:58 2000
-+++ makefile.def Tue Nov 19 13:16:28 2002
-@@ -12,11 +12,11 @@
- # g++ 2.7.0) Some other choices for ARCH are "SGI" and "RIOS" (RS-6000)
- #
-
--ARCH = Linux
--CPP = g++
--CPPFLAGS = -I$(LAPACKPP_INC) -D$(ARCH) -Wall
--CPPLIBS = -lm
--CFLAGS = -I$(LAPACKPP_INC)
-+ARCH = FreeBSD
-+CPP = $(CXX)
-+CPPFLAGS+= $(CXXFLAGS) -I$(LAPACKPP_INC) -D$(ARCH)
-+CPPLIBS+= -lm
-+CFLAGS+= -I$(LAPACKPP_INC)
- #
- #
-
-@@ -35,8 +35,14 @@
- #
- # Linux
- #
--BLAS_LIB = $(HOME)/lib/Linux/libblas.a
--LAPACK_LIB = $(HOME)/lib/Linux/liblapack.a
-+#BLAS_LIB = $(HOME)/lib/Linux/libblas.a
-+#LAPACK_LIB = $(HOME)/lib/Linux/liblapack.a
-+#FLIBS = -lm -lg2c
-+#
-+# FreeBSD
-+#
-+BLAS_LIB = %%BLAS_LIB%%
-+LAPACK_LIB = %%LAPACK_LIB%%
- FLIBS = -lm -lg2c
- #
- # Sun
-@@ -60,7 +66,7 @@
- LAPACKPP_LIB = $(LAPACKPP_LIB_DIR)/liblapack++.a
- BLASPP_LIB = $(LAPACKPP_LIB_DIR)/libblas++.a
-
--ALL_LAPACKPP_LIB = \
-+ALL_LAPACKPP_LIB = -L${PREFIX}/lib \
- $(LAMATRIXPP_LIB) \
- $(LAPACKPP_LIB) \
- $(TMGLIB) \
diff --git a/math/lapack++/files/patch-matrix:testing:matrix_test b/math/lapack++/files/patch-matrix:testing:matrix_test
deleted file mode 100644
index 6043c5398b86..000000000000
--- a/math/lapack++/files/patch-matrix:testing:matrix_test
+++ /dev/null
@@ -1,11 +0,0 @@
---- matrix/testing/matrix_test.org Tue Feb 29 05:42:29 2000
-+++ matrix/testing/matrix_test Mon May 20 10:19:03 2002
-@@ -32,7 +32,7 @@
- foreach t ($testsuite)
- set answer = $t:t.out
- echo "$t $N[1] $N[1] >& $answer"
-- $t $N[1] $N[1] >& $answer
-+ ./$t $N[1] $N[1] >& $answer
-
- end
-
diff --git a/math/lapack++/files/patch-src:eigslv.cc b/math/lapack++/files/patch-src:eigslv.cc
deleted file mode 100644
index c087bceb8f4f..000000000000
--- a/math/lapack++/files/patch-src:eigslv.cc
+++ /dev/null
@@ -1,61 +0,0 @@
---- src/eigslv.cc~ Wed Mar 1 02:52:47 2000
-+++ src/eigslv.cc Wed May 22 21:49:45 2002
-@@ -58,14 +58,14 @@
- // char *fname = NULL; // HP C++ does not support string initalization!
- //#endif
-
-- // view symmetric matrix S as a LaGenMatDouble
-- // assumes S is contiguous...
-- LaSymmMatDouble tmp(S);
-- LaEigSolveVecIP(tmp, eigvals);
--
-- LaGenMatDouble tmp2(&tmp(0,0), S.size(0), S.size(1));
-- eigvec.ref(tmp2);
--
-+ long int N = S.size(0);
-+ long int i,j;
-+
-+ for(j=0;j<N;j++){
-+ for(i=j;i<N;i++){
-+ eigvec(i,j)=S(i,j);
-+ }}
-+ LaEigSolveVecIP(eigvec, eigvals);
-
- }
-
-@@ -100,18 +100,18 @@
-
- }
-
--void LaEigSolveVecIP(LaSymmMatDouble &S, LaVectorDouble &eigvals)
-+void LaEigSolveVecIP(LaGenMatDouble &A, LaVectorDouble &eigvals)
- {
- #ifndef HPPA
- const char fname[] = "LaEigSolveVecIP(LaGenMatDouble &A, &eigvals)";
- #else
- char *fname = NULL; // HP C++ does not support string initalization!
- #endif
-- long int N = S.size(0);
-+ long int N = A.size(0);
- char jobz = 'V';
- char uplo = 'L';
- long int info;
-- long int lda = S.gdim(0);
-+ long int lda = A.gdim(0);
-
- if (eigvals.size() < N)
- {
-@@ -119,11 +119,11 @@
- }
-
-
-- long int w = (LaEnvBlockSize("SSYTRD", S) +2) * N;
-+ long int w = (LaEnvBlockSize("SSYTRD", A) +2) * N;
- LaVectorDouble Work(w);
-
-
-- F77NAME(dsyev)(&jobz, &uplo, &N, S.addr(), &lda, &eigvals(0), &Work(0),
-+ F77NAME(dsyev)(&jobz, &uplo, &N, A.addr(), &lda, &eigvals(0), &Work(0),
- &w, &info);
-
- if (info != 0)
diff --git a/math/lapack++/files/patch-testing:lapack++_test b/math/lapack++/files/patch-testing:lapack++_test
deleted file mode 100644
index 9f0d5b4d5438..000000000000
--- a/math/lapack++/files/patch-testing:lapack++_test
+++ /dev/null
@@ -1,11 +0,0 @@
---- testing/lapack++_test.org Tue Feb 29 05:42:30 2000
-+++ testing/lapack++_test Mon May 20 10:26:07 2002
-@@ -31,7 +31,7 @@
- foreach n ($N)
- set answer = $t:t$n.out
- echo "$t $n $n >& $answer"
-- $t $n $n >>& $answer
-+ ./$t $n $n >>& $answer
- end
- end
-
diff --git a/math/lapack++/pkg-descr b/math/lapack++/pkg-descr
index 795529c9c15c..72b4268f61ac 100644
--- a/math/lapack++/pkg-descr
+++ b/math/lapack++/pkg-descr
@@ -9,4 +9,4 @@ of the capabilities of original f77 LAPACK. Emphasis is given to routines
for solving linear systems consisting of non-symmetric matrices,
symmetric positive definite systems, and solving linear least-square systems.
-WWW: http://math.nist.gov/lapack++/
+WWW: http://sourceforge.net/projects/lapackpp
diff --git a/math/lapack++/pkg-plist b/math/lapack++/pkg-plist
index 1cc34a732460..4a0e90062025 100644
--- a/math/lapack++/pkg-plist
+++ b/math/lapack++/pkg-plist
@@ -1,63 +1,74 @@
-include/lapack++/arch.h
-include/lapack++/bfd.h
-include/lapack++/blas++.h
-include/lapack++/blas1++.h
-include/lapack++/blas1.h
-include/lapack++/blas2++.h
-include/lapack++/blas2.h
-include/lapack++/blas3++.h
-include/lapack++/blas3.h
-include/lapack++/bmd.h
-include/lapack++/f2c.h
-include/lapack++/fmd.h
-include/lapack++/genmd.h
-include/lapack++/gfd.h
-include/lapack++/gmc.h
-include/lapack++/gmd.h
-include/lapack++/gmf.h
-include/lapack++/gmi.h
-include/lapack++/gmli.h
-include/lapack++/lacvd.h
-include/lapack++/laexcp.h
-include/lapack++/lafnames.h
-include/lapack++/laindex.h
-include/lapack++/lapack++.h
-include/lapack++/lapack.h
-include/lapack++/lapackc.h
-include/lapack++/lapackd.h
-include/lapack++/larvd.h
-include/lapack++/laslv.h
-include/lapack++/lautil.h
-include/lapack++/lavc.h
-include/lapack++/lavd.h
-include/lapack++/lavf.h
-include/lapack++/lavi.h
-include/lapack++/lavli.h
-include/lapack++/ltgmd.h
-include/lapack++/spdbmd.h
-include/lapack++/spdfd.h
-include/lapack++/spdmd.h
-include/lapack++/spdtrmd.h
-include/lapack++/sybfd.h
-include/lapack++/sybmd.h
-include/lapack++/syfd.h
-include/lapack++/symd.h
-include/lapack++/sytrmd.h
-include/lapack++/template_v.h
-include/lapack++/trfd.h
-include/lapack++/trmd.h
-include/lapack++/ultgmd.h
-include/lapack++/utgmd.h
-include/lapack++/uutgmd.h
-include/lapack++/vc.h
-include/lapack++/vd.h
-include/lapack++/vf.h
-include/lapack++/vi.h
-include/lapack++/vli.h
-@dirrm include/lapack++
-lib/libblas++.a
-lib/liblamatrix++.a
-lib/liblapack++.a
+include/lapackpp/arch.h
+include/lapackpp/bfd.h
+include/lapackpp/blas++.h
+include/lapackpp/blas1++.h
+include/lapackpp/blas1.h
+include/lapackpp/blas1pp.h
+include/lapackpp/blas2++.h
+include/lapackpp/blas2.h
+include/lapackpp/blas2pp.h
+include/lapackpp/blas3++.h
+include/lapackpp/blas3.h
+include/lapackpp/blas3pp.h
+include/lapackpp/blaspp.h
+include/lapackpp/bmd.h
+include/lapackpp/f2c.h
+include/lapackpp/fmd.h
+include/lapackpp/genmd.h
+include/lapackpp/gfd.h
+include/lapackpp/gfqrc.h
+include/lapackpp/gmc.h
+include/lapackpp/gmd.h
+include/lapackpp/gmf.h
+include/lapackpp/gmi.h
+include/lapackpp/gmli.h
+include/lapackpp/lacomplex
+include/lapackpp/lacomplex.h
+include/lapackpp/lacvd.h
+include/lapackpp/laexcp.h
+include/lapackpp/lafnames.h
+include/lapackpp/laindex.h
+include/lapackpp/lapack++.h
+include/lapackpp/lapack.h
+include/lapackpp/lapackc.h
+include/lapackpp/lapackd.h
+include/lapackpp/lapackpp.h
+include/lapackpp/laprefs.h
+include/lapackpp/larvd.h
+include/lapackpp/laslv.h
+include/lapackpp/lasvd.h
+include/lapackpp/lautil.h
+include/lapackpp/lavc.h
+include/lapackpp/lavd.h
+include/lapackpp/lavi.h
+include/lapackpp/lavli.h
+include/lapackpp/ltgmd.h
+include/lapackpp/spdbmd.h
+include/lapackpp/spdfd.h
+include/lapackpp/spdmd.h
+include/lapackpp/spdtrmd.h
+include/lapackpp/sybfd.h
+include/lapackpp/sybmd.h
+include/lapackpp/syfd.h
+include/lapackpp/symd.h
+include/lapackpp/sytrmd.h
+include/lapackpp/trfd.h
+include/lapackpp/trmd.h
+include/lapackpp/ultgmd.h
+include/lapackpp/utgmd.h
+include/lapackpp/uutgmd.h
+include/lapackpp/vc.h
+include/lapackpp/vd.h
+include/lapackpp/vf.h
+include/lapackpp/vi.h
+include/lapackpp/vli.h
+lib/liblapackpp.a
+lib/liblapackpp.la
+lib/liblapackpp.so
+lib/liblapackpp.so.7
+share/aclocal/acx_lapackpp.m4
+@dirrm include/lapackpp
+@dirrm share/aclocal
%%PORTDOCS%%share/doc/lapack++/lapack++.ps.gz
%%PORTDOCS%%share/doc/lapack++/lapack++_install.ps.gz
%%PORTDOCS%%share/doc/lapack++/lapackpp1_1.ps.gz