aboutsummaryrefslogtreecommitdiff
path: root/math/matharray
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-10-31 06:20:44 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-10-31 06:20:44 +0000
commit06f7bd813b41518e3972ec9cb9af9f1d01e4358f (patch)
tree801e2dba7b02b4844ca4d431abfe56320c19f23d /math/matharray
parentc14bfbbb5823117e427f0158d0f5665c21555bc1 (diff)
downloadports-06f7bd813b41518e3972ec9cb9af9f1d01e4358f.tar.gz
ports-06f7bd813b41518e3972ec9cb9af9f1d01e4358f.zip
MathArray is a general library of classes for performing mathematical
operations on arrays (vectors, matrices, etc) of values. It can operate on any standard 'C' number type plus numbers of complex type. MathArray is implemented using a "class cluster" concept, allowing one to perform mathematical calculations on a number without necessarily being aware of what type (class) of number is being operated on. MathArray knows implicitly what types of operations can be performed on what types of numbers and will automatically cast itself to the correct number type representation to handle the specific operation. Standard operations include addition, scalar and matrix multiplication and logical operations. Mathematical operations in the standard C math library are also supported, as well as user-defined functions. MathArray also does much more. Arrays can be manipulated, transposed and concatenated. One can extract subarrays or include subarrays within larger arrays.
Notes
Notes: svn path=/head/; revision=175706
Diffstat (limited to 'math/matharray')
-rw-r--r--math/matharray/Makefile27
-rw-r--r--math/matharray/distinfo3
-rw-r--r--math/matharray/pkg-descr16
-rw-r--r--math/matharray/pkg-plist12
4 files changed, 58 insertions, 0 deletions
diff --git a/math/matharray/Makefile b/math/matharray/Makefile
new file mode 100644
index 000000000000..a2a375b9fa6f
--- /dev/null
+++ b/math/matharray/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: matharray
+# Date created: 30 Oct 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= matharray
+PORTVERSION= 1.0
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_GNUSTEP}
+MASTER_SITE_SUBDIR= contrib
+DISTNAME= MathArray-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Class library for mathematical manipulation of matrices
+
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BASE= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE= GNUmakefile
+NO_FILTER_SHLIBS= yes
+
+.include <bsd.port.mk>
diff --git a/math/matharray/distinfo b/math/matharray/distinfo
new file mode 100644
index 000000000000..4076fe5af506
--- /dev/null
+++ b/math/matharray/distinfo
@@ -0,0 +1,3 @@
+MD5 (MathArray-1.0.tar.gz) = 534085eeb9e219e9fb3257e38323681a
+SHA256 (MathArray-1.0.tar.gz) = 2bfd06ee3b560b4442ed4e6afcac9d9961a037bb44d350030942587ae081a04e
+SIZE (MathArray-1.0.tar.gz) = 104963
diff --git a/math/matharray/pkg-descr b/math/matharray/pkg-descr
new file mode 100644
index 000000000000..bdacf46c1dc1
--- /dev/null
+++ b/math/matharray/pkg-descr
@@ -0,0 +1,16 @@
+MathArray is a general library of classes for performing mathematical
+operations on arrays (vectors, matrices, etc) of values. It can
+operate on any standard 'C' number type plus numbers of complex
+type. MathArray is implemented using a "class cluster" concept,
+allowing one to perform mathematical calculations on a number without
+necessarily being aware of what type (class) of number is being
+operated on. MathArray knows implicitly what types of operations can
+be performed on what types of numbers and will automatically cast
+itself to the correct number type representation to handle the
+specific operation. Standard operations include addition, scalar and
+matrix multiplication and logical operations. Mathematical operations
+in the standard C math library are also supported, as well as
+user-defined functions.
+MathArray also does much more. Arrays can be manipulated, transposed
+and concatenated. One can extract subarrays or include subarrays within
+larger arrays.
diff --git a/math/matharray/pkg-plist b/math/matharray/pkg-plist
new file mode 100644
index 000000000000..9dd6017ea992
--- /dev/null
+++ b/math/matharray/pkg-plist
@@ -0,0 +1,12 @@
+Local/Library/Headers/MathArray/MAValue.h
+Local/Library/Headers/MathArray/MAValueData.h
+Local/Library/Headers/MathArray/MaskedException.h
+Local/Library/Headers/MathArray/MathArray.h
+Local/Library/Headers/MathArray/MathArrayExtensions.h
+Local/Library/Headers/MathArray/NSObjectExtra.h
+Local/Library/Headers/MathArray/array_encoding.h
+Local/Library/Headers/MathArray/complex.h
+Local/Library/Libraries/libMathArray.so
+Local/Library/Libraries/libMathArray.so.%%MAJORVERSION%%
+Local/Library/Libraries/libMathArray.so.%%VERSION%%
+@dirrm Local/Library/Headers/MathArray