aboutsummaryrefslogtreecommitdiff
path: root/math/msieve/Makefile
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-02-07 07:41:28 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-02-07 07:41:28 +0000
commit067f883824555a8dd8f73dc55a8571638a891e6d (patch)
tree2a4f6ee82c0b745762e3559d241a83c26a980d80 /math/msieve/Makefile
parent768e7ec67462e425c0425f077c40d746c4ec998b (diff)
downloadports-067f883824555a8dd8f73dc55a8571638a891e6d.tar.gz
ports-067f883824555a8dd8f73dc55a8571638a891e6d.zip
Update to 1.48
Approved by: makc, miwi (mentors, implicit) Feature safe: yes
Notes
Notes: svn path=/head/; revision=268737
Diffstat (limited to 'math/msieve/Makefile')
-rw-r--r--math/msieve/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/math/msieve/Makefile b/math/msieve/Makefile
index 1102041b7a8f..8f6afb77b1a7 100644
--- a/math/msieve/Makefile
+++ b/math/msieve/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= msieve
-PORTVERSION= 1.46
+PORTVERSION= 1.48
CATEGORIES= math
MASTER_SITES= SF
MASTER_SITE_SUBDIR= \
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libecm.a:${PORTSDIR}/math/gmp-ecm
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
-CFLAGS+= -D_FILE_OFFSET_BITS=64 -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV= LDFLAGS="${LDFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}" ECM=1
@@ -61,4 +61,7 @@ do-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
+regression-test test check: build
+ @( cd ${WRKSRC} ; ./msieve -q -d 1 2385734365243128176756453434347656453122245767798 )
+
.include <bsd.port.post.mk>