aboutsummaryrefslogtreecommitdiff
path: root/math/msieve/Makefile
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2010-08-28 12:55:19 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2010-08-28 12:55:19 +0000
commitbc36efa3a240e9ef8d329456e7d513d88992eaf9 (patch)
tree57bb6a46b2b30ca2e11da6fa567e31a776a48700 /math/msieve/Makefile
parent1dda96a4802058e6f99528fede8644ffdfa4f970 (diff)
downloadports-bc36efa3a240e9ef8d329456e7d513d88992eaf9.tar.gz
ports-bc36efa3a240e9ef8d329456e7d513d88992eaf9.zip
Fix build by updating to 1.46
Approved by: makc (co-mentor)
Notes
Notes: svn path=/head/; revision=260134
Diffstat (limited to 'math/msieve/Makefile')
-rw-r--r--math/msieve/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/math/msieve/Makefile b/math/msieve/Makefile
index b166e331f10a..4a90e2fcafa6 100644
--- a/math/msieve/Makefile
+++ b/math/msieve/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= msieve
-PORTVERSION= 1.38
-PORTREVISION= 2
+PORTVERSION= 1.46
CATEGORIES= math
-MASTER_SITES= http://www.boo.net/~jasonp/ \
- http://mirror.roe.ch/dist/msieve/
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= \
+ ${PORTNAME}/${PORTNAME}/${PORTNAME:C/^m/M/}%20v${PORTVERSION}/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
MAINTAINER= bf@FreeBSD.org
@@ -18,8 +18,6 @@ COMMENT= Fast factorization of big integers using MPQS and GNFS
BUILD_DEPENDS= ${LOCALBASE}/lib/libecm.a:${PORTSDIR}/math/gmp-ecm
-BROKEN= does not build
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GMAKE= yes
MAKE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
@@ -37,7 +35,7 @@ OPTIONS= OCFLAGS "Enable optimized CFLAGS" On
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_OCFLAGS)
-CFLAGS+= -O3 -ffast-math -fomit-frame-pointer -D_FILE_OFFSET_BITS=64
+CFLAGS+= -O3 -ffast-math -fomit-frame-pointer -DNDEBUG -D_FILE_OFFSET_BITS=64
.else
CFLAGS+= -D_FILE_OFFSET_BITS=64
.endif