aboutsummaryrefslogtreecommitdiff
path: root/math/newmat
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-06 15:48:26 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-06 15:48:26 +0000
commita9920b0635ad4fe8f8e08b1de74d7b1dbb4d328e (patch)
treeb0f64e9c05dfea32194acf5bf2cfbdb9ef43d7e7 /math/newmat
parent6336e8725479eb4bd88bea8589ad8c3deb86c7f0 (diff)
downloadports-a9920b0635ad4fe8f8e08b1de74d7b1dbb4d328e.tar.gz
ports-a9920b0635ad4fe8f8e08b1de74d7b1dbb4d328e.zip
add newmat
A C++ matrix library
Notes
Notes: svn path=/head/; revision=51145
Diffstat (limited to 'math/newmat')
-rw-r--r--math/newmat/Makefile31
-rw-r--r--math/newmat/distinfo1
-rw-r--r--math/newmat/pkg-comment1
-rw-r--r--math/newmat/pkg-descr6
-rw-r--r--math/newmat/pkg-plist15
5 files changed, 54 insertions, 0 deletions
diff --git a/math/newmat/Makefile b/math/newmat/Makefile
new file mode 100644
index 000000000000..a3afacb333ae
--- /dev/null
+++ b/math/newmat/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# New ports collection makefile for: newmat
+# Date created: Dec 6, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= newmat
+PORTVERSION= 1.0
+CATEGORIES= math
+MASTER_SITES= ftp://webnz.com/robert/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
+
+MAINTAINER= ports@FreeBSD.org
+
+NO_WRKSUBDIR= yes
+USE_GMAKE= yes
+MAKEFILE= nm_gnu.mak
+ALL_TARGET= everything
+
+post-patch:
+ @${PERL} -pi -e "s,^CXX,#CXX,g ; \
+ s,^CXXFLAGS,#CXXFLAGS,g" ${WRKSRC}/${MAKEFILE}
+
+do-install:
+ @${MKDIR} ${PREFIX}/include/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/libnewmat.a ${PREFIX}/lib
+
+.include <bsd.port.mk>
diff --git a/math/newmat/distinfo b/math/newmat/distinfo
new file mode 100644
index 000000000000..5fa119c0d127
--- /dev/null
+++ b/math/newmat/distinfo
@@ -0,0 +1 @@
+MD5 (newmat10.tar.gz) = 6aad1fd21c28f5a92c51992b8012255b
diff --git a/math/newmat/pkg-comment b/math/newmat/pkg-comment
new file mode 100644
index 000000000000..143b896e42fc
--- /dev/null
+++ b/math/newmat/pkg-comment
@@ -0,0 +1 @@
+A C++ matrix library
diff --git a/math/newmat/pkg-descr b/math/newmat/pkg-descr
new file mode 100644
index 000000000000..0223135180bd
--- /dev/null
+++ b/math/newmat/pkg-descr
@@ -0,0 +1,6 @@
+The package is intended for scientists and engineers who need to manipulate
+a variety of types of matrices using standard matrix operations. Emphasis is
+on the kind of operations needed in statistical calculations such as least
+squares, linear equation solve and eigenvalues.
+
+WWW: http://webnz.com/robert/cpp_lib.htm#newmat10
diff --git a/math/newmat/pkg-plist b/math/newmat/pkg-plist
new file mode 100644
index 000000000000..355cb75be6d0
--- /dev/null
+++ b/math/newmat/pkg-plist
@@ -0,0 +1,15 @@
+include/newmat/boolean.h
+include/newmat/controlw.h
+include/newmat/include.h
+include/newmat/myexcept.h
+include/newmat/newmat.h
+include/newmat/newmatap.h
+include/newmat/newmatio.h
+include/newmat/newmatnl.h
+include/newmat/newmatrc.h
+include/newmat/newmatrm.h
+include/newmat/precisio.h
+include/newmat/solution.h
+include/newmat/tmt.h
+@dirrm include/newmat
+lib/libnewmat.a