aboutsummaryrefslogtreecommitdiff
path: root/math/nsc2ke
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-03 00:57:09 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-03 00:57:09 +0000
commit6de26dfcb042d1997604af16b876aea82d331435 (patch)
tree174def8243c6299d1872c8eb1414917b7039b177 /math/nsc2ke
parentdd79e1a7f5df0de0491f45fa80eac5462930452d (diff)
downloadports-6de26dfcb042d1997604af16b876aea82d331435.tar.gz
ports-6de26dfcb042d1997604af16b876aea82d331435.zip
Add nsc2ke, a Finite-Volume Galerkin program computing 2D and axisymmetric
flows on unstructured meshes. PR: ports/60836 Submitted by: Thierry Thomas <thierry@pompo.net>
Notes
Notes: svn path=/head/; revision=97150
Diffstat (limited to 'math/nsc2ke')
-rw-r--r--math/nsc2ke/Makefile65
-rw-r--r--math/nsc2ke/distinfo2
-rw-r--r--math/nsc2ke/files/patch-makefile20
-rw-r--r--math/nsc2ke/pkg-descr6
-rw-r--r--math/nsc2ke/pkg-message9
-rw-r--r--math/nsc2ke/pkg-plist8
6 files changed, 110 insertions, 0 deletions
diff --git a/math/nsc2ke/Makefile b/math/nsc2ke/Makefile
new file mode 100644
index 000000000000..1ef2735f504a
--- /dev/null
+++ b/math/nsc2ke/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: nsc2ke
+# Date created: 16 December 2003
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= nsc2ke
+PORTVERSION= 1.0
+CATEGORIES= math science
+MASTER_SITES= http://www-rocq1.inria.fr/gamma/cdrom/ftp/nsc2ke/
+DISTNAME= ${PORTNAME}
+.if !defined(NOPORTDOCS)
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} nsc2ke.ps.gz
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+.endif
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A Navier-Stokes solver
+
+RESTRICTED= No resale, contact author for commercial usage
+
+F77?= f77
+FFLAGS?= -O2 # Note: FFLAGS is set to -O in /usr/share/mk/sys.mk
+
+WRKSRC= ${WRKDIR}
+
+MAKEFILE= makefile
+ALL_TARGET= NSC2KE
+MAKE_ENV= F77="${F77}" FFLAGS="${FFLAGS}"
+
+EXEMPLES= DATA MESH gnu.data
+TESTDIR?= /tmp/testnsc2ke
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/NSC2KE ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/READ_ME ${DOCSDIR}
+ @${INSTALL_DATA} ${DISTDIR}/nsc2ke.ps.gz ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ @${MKDIR} ${EXAMPLESDIR}
+.for fich in ${EXEMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/${fich} ${EXAMPLESDIR}
+.endfor
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
+
+post-install:
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO}
+
+.if defined(MAINTAINER_MODE)
+test: install
+ ${MKDIR} ${TESTDIR}
+.for fich in ${EXEMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/${fich} ${TESTDIR}
+.endfor
+ (cd ${TESTDIR}; \
+ NSC2KE; \
+ gnuplot < gnu.data)
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/nsc2ke/distinfo b/math/nsc2ke/distinfo
new file mode 100644
index 000000000000..6442d78c9300
--- /dev/null
+++ b/math/nsc2ke/distinfo
@@ -0,0 +1,2 @@
+MD5 (nsc2ke.tar.gz) = 4a7e7739fd50fe7493a6ef909c621503
+MD5 (nsc2ke.ps.gz) = 4302ec130267d2391f27be3855a015c9
diff --git a/math/nsc2ke/files/patch-makefile b/math/nsc2ke/files/patch-makefile
new file mode 100644
index 000000000000..377c93d4e582
--- /dev/null
+++ b/math/nsc2ke/files/patch-makefile
@@ -0,0 +1,20 @@
+--- makefile.orig Tue Feb 7 14:00:19 1995
++++ makefile Thu Jan 1 21:40:26 2004
+@@ -1,6 +1,4 @@
+-F77=f77
+-LINK=f77 -O
+-FLAGS=-c -O
++# $FreeBSD$
+
+ OBJS=nsc2ke.o config.o mailla.o aires.o seg2d.o\
+ clhaut.o init.o calprc.o result.o fluosh.o flucin.o\
+@@ -9,7 +7,7 @@
+ loglaw.o isovat.o gravity.o
+
+ .f.o:
+- $(F77) $(FLAGS) $*.f
++ $(F77) -c $(FFLAGS) $*.f
+
+ NSC2KE:$(OBJS)
+- $(LINK) $(OBJS) -o NSC2KE
++ $(F77) $(FFLAGS) $(OBJS) -o NSC2KE
diff --git a/math/nsc2ke/pkg-descr b/math/nsc2ke/pkg-descr
new file mode 100644
index 000000000000..aa6303cafd8a
--- /dev/null
+++ b/math/nsc2ke/pkg-descr
@@ -0,0 +1,6 @@
+NSC2KE is a Finite-Volume Galerkin program computing 2D and axisymmetric
+flows on unstructured meshes.
+
+Suggested add-on: the ports math/bamg or math/emc2.
+
+WWW: http://www-rocq1.inria.fr/gamma/cdrom/www/nsc2ke/eng.htm
diff --git a/math/nsc2ke/pkg-message b/math/nsc2ke/pkg-message
new file mode 100644
index 000000000000..f1915d3114d9
--- /dev/null
+++ b/math/nsc2ke/pkg-message
@@ -0,0 +1,9 @@
+The names of the input and output files are hard-coded. You must have:
+
+- the computation configuration (Mach, Reynolds,...) in file a 'DATA';
+
+- the mesh in a file 'MESH'.
+
+Put these files in a working directory (see the examples), cd to this
+directory, and run NSC2KE. The example gnu.data shows you how to visualize
+the results by typing 'gnuplot < gnu.data'.
diff --git a/math/nsc2ke/pkg-plist b/math/nsc2ke/pkg-plist
new file mode 100644
index 000000000000..9a547774ea09
--- /dev/null
+++ b/math/nsc2ke/pkg-plist
@@ -0,0 +1,8 @@
+bin/NSC2KE
+%%PORTDOCS%%%%DOCSDIR%%/READ_ME
+%%PORTDOCS%%%%DOCSDIR%%/nsc2ke.ps.gz
+%%PORTDOCS%%%%EXAMPLESDIR%%/DATA
+%%PORTDOCS%%%%EXAMPLESDIR%%/MESH
+%%PORTDOCS%%%%EXAMPLESDIR%%/gnu.data
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%