aboutsummaryrefslogtreecommitdiff
path: root/math/octave-devel
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-11-22 11:14:10 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-11-22 11:14:10 +0000
commit004a7c5ac21475f760354371ae4f8fca5e556acb (patch)
tree47b9539be8bb171263921a641d850025fee218cc /math/octave-devel
parentbcfacab8772c0f3bf72412386eb13f58def6bef2 (diff)
downloadports-004a7c5ac21475f760354371ae4f8fca5e556acb.tar.gz
ports-004a7c5ac21475f760354371ae4f8fca5e556acb.zip
adjust linking and comments in dependent ports after the math/atlas update;
math/atlas-devel will be updated to use the same constructs at a later date PR: 162706 Approved by: miwi (portmgr) Feature safe: yes
Notes
Notes: svn path=/head/; revision=286242
Diffstat (limited to 'math/octave-devel')
-rw-r--r--math/octave-devel/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/math/octave-devel/Makefile b/math/octave-devel/Makefile
index e25a7cfe5e67..3402f0992218 100644
--- a/math/octave-devel/Makefile
+++ b/math/octave-devel/Makefile
@@ -44,27 +44,27 @@ MAN1= octave.1 octave-bug.1 mkoctfile.1 octave-config.1
.include <bsd.port.pre.mk>
-USE_BLAS?= reference
-
.if exists(${LOCALBASE}/lib/libgoto2.so)
-USE_BLAS= gotoblas
-.elif exists(${LOCALBASE}/lib/libatlas_r.so)
-USE_BLAS= atlas
+WITH_BLAS?= gotoblas
+.elif exists(${LOCALBASE}/lib/libatlas.so)
+WITH_BLAS?= atlas
+.else
+WITH_BLAS?= reference
.endif
-. if ${USE_BLAS} == reference
+. if ${WITH_BLAS} == reference
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
-.elif ${USE_BLAS} == gotoblas
+.elif ${WITH_BLAS} == gotoblas
LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
BLAS= -lgoto2p
LAPACK= -lgoto2p
-.elif ${USE_BLAS} == atlas
+.elif ${WITH_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
-BLAS= -lptf77blas -lptcblas -latlas_r
-LAPACK= -lalapack_r
+BLAS= -lptf77blas
+LAPACK= -lalapack -lptcblas
.endif
USE_FORTRAN= yes