aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-queueing
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2012-02-06 19:42:56 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2012-02-06 19:42:56 +0000
commit0c3d03543d4aaf6ec3944fcd75ee8e2664485c39 (patch)
tree78013a93970165a76b027e27480b238faa094d79 /math/octave-forge-queueing
parent43651e5d8b6c733a70db2e621bc608fc71c5dba5 (diff)
downloadports-0c3d03543d4aaf6ec3944fcd75ee8e2664485c39.tar.gz
ports-0c3d03543d4aaf6ec3944fcd75ee8e2664485c39.zip
-New port octave-forge-queueing.
The octave-forge package is the result of The GNU Octave Repositry project, which is intended to be a central location for custom scripts, functions and extensions for GNU Octave. contains the source for all the functions plus build and install scripts. The queueing toolbox provides functions for queueing networks and Markov chains analysis. This package can be used to compute steady-state performance measures for open, closed and mixed networks with single or multiple job classes. Mean Valud Analysis (MVA), convolution and various bounding techniques are implemented. Various transient and steady-state performance measures for Markov chains can als be computed (including state occupancy probabilities, mean time to absorption, time-averaged sojourn times), both for continuous-time and discrete-time chains.
Notes
Notes: svn path=/head/; revision=290509
Diffstat (limited to 'math/octave-forge-queueing')
-rw-r--r--math/octave-forge-queueing/Makefile28
-rw-r--r--math/octave-forge-queueing/distinfo2
-rw-r--r--math/octave-forge-queueing/pkg-descr17
-rw-r--r--math/octave-forge-queueing/pkg-plist1
4 files changed, 48 insertions, 0 deletions
diff --git a/math/octave-forge-queueing/Makefile b/math/octave-forge-queueing/Makefile
new file mode 100644
index 000000000000..6b9b4ffe9d8f
--- /dev/null
+++ b/math/octave-forge-queueing/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: octave-forge-queueing
+# Date created: 6 February 2012
+# Whom: Stephen Montgomery-Smith <stephen@FreeBSD.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= octave-forge-queueing
+PORTVERSION= 1.0.0
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+do-build:
+ ${DO_NADA}
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.post.mk>
diff --git a/math/octave-forge-queueing/distinfo b/math/octave-forge-queueing/distinfo
new file mode 100644
index 000000000000..9ea55828df8f
--- /dev/null
+++ b/math/octave-forge-queueing/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/queueing-1.0.0.tar.gz) = 33dc31a3b85b8cc8156d2a4e646749ddc7bfb547ee07d5cbbbbf99de8bc4a9cc
+SIZE (octave-forge/queueing-1.0.0.tar.gz) = 600705
diff --git a/math/octave-forge-queueing/pkg-descr b/math/octave-forge-queueing/pkg-descr
new file mode 100644
index 000000000000..4f3ed5ab8056
--- /dev/null
+++ b/math/octave-forge-queueing/pkg-descr
@@ -0,0 +1,17 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is queueing.
+
+ The queueing toolbox provides functions for queueing networks and Markov
+ chains analysis. This package can be used to compute steady-state performance
+ measures for open, closed and mixed networks with single or multiple job
+ classes. Mean Valud Analysis (MVA), convolution and various bounding
+ techniques are implemented. Various transient and steady-state performance
+ measures for Markov chains can als be computed (including state occupancy
+ probabilities, mean time to absorption, time-averaged sojourn times), both
+ for continuous-time and discrete-time chains.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-queueing/pkg-plist b/math/octave-forge-queueing/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-queueing/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty