aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2004-05-10 18:25:13 +0000
committerMaho Nakata <maho@FreeBSD.org>2004-05-10 18:25:13 +0000
commit7938534b67aacd89f1cb398730ece06263a0502c (patch)
treeb3811b1938b56cbc2bec8f4a2aaafed789696453 /math/octave-forge
parent334de2f1ea99e6904d10651d39a495893c24ebdd (diff)
downloadports-7938534b67aacd89f1cb398730ece06263a0502c.tar.gz
ports-7938534b67aacd89f1cb398730ece06263a0502c.zip
This version of octave-forge doens't compile any more with the
good old gcc-2.95. The newly introduced xmlread-stuff requires >gcc-3.x. Maintainer doens't mark this port as broken, but set USE_GCC instead. Suggested by: Kay Lehmann <kay_lehmann@web.de>
Notes
Notes: svn path=/head/; revision=108861
Diffstat (limited to 'math/octave-forge')
-rw-r--r--math/octave-forge/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/math/octave-forge/Makefile b/math/octave-forge/Makefile
index ff464a52017c..5cd94aaa5dca 100644
--- a/math/octave-forge/Makefile
+++ b/math/octave-forge/Makefile
@@ -22,6 +22,14 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
ALL_TARGET= # empty
USE_REINPLACE= yes
+CONFIGURE_ARGS= --with-cc=${CC} \
+ --with-cxx=${CXX}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 501000
+USE_GCC=3.3
+.endif
GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}
PLIST_SUB= OCTAVE_VERSION="`${LOCALBASE}/bin/octave-config -v`" GNU_HOST=${GNU_HOST}
@@ -32,4 +40,4 @@ post-configure:
@${REINPLACE_CMD} -e 's+%%LOCALBASE%%+${LOCALBASE}+g;' ${WRKSRC}/main/sparse/buildtests.sh
@${REINPLACE_CMD} -e 's+#! /bin/sh+#! ${LOCALBASE}/bin/bash+g;' ${WRKSRC}/octinst.sh
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>