aboutsummaryrefslogtreecommitdiff
path: root/math/octave/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-09-09 05:46:18 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-09-09 05:46:18 +0000
commit7c14c37f5a302512988c640b457ddf2f1a534609 (patch)
tree1dd4ce488337e1f2f0bdba25f0fb52593060ef83 /math/octave/Makefile
parent7457015fa2b244f6c1c8cf383cb3d12aa51a90de (diff)
downloadports-7c14c37f5a302512988c640b457ddf2f1a534609.tar.gz
ports-7c14c37f5a302512988c640b457ddf2f1a534609.zip
Use PLIST_SUB to avoid changing a few hundred lines in PLIST every time
there's an upgrade. Approved by: maintainer
Notes
Notes: svn path=/head/; revision=13064
Diffstat (limited to 'math/octave/Makefile')
-rw-r--r--math/octave/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index ce48c80d4d85..7a7d70eee46c 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -3,7 +3,7 @@
# Date created: 8 September 1998
# Whom: chuckr@freebsd.org
#
-# $Id: Makefile,v 1.15 1998/05/20 02:17:06 chuckr Exp $
+# $Id: Makefile,v 1.16 1998/09/08 14:32:30 chuckr Exp $
#
DISTNAME= octave-2.0.13
@@ -14,6 +14,8 @@ MAINTAINER= chuckr@FreeBSD.ORG
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot
+OCTAVE_VERSION= 2.0.13
+PLIST_SUB= OCTAVE_VERSION=${OCTAVE_VERSION}
HAS_CONFIGURE= yes
CONFIGURE_ENV= ${SETENV} "INSTALL_DATA=$(INSTALL_DATA)" "INSTALL_PROGRAM=$(INSTALL_SCRIPT)"
CONFIGURE_ARGS= --prefix=${PREFIX} --exec-prefix=${PREFIX} --with-f2c --disable-shared --host=i386-unknown-freebsd