aboutsummaryrefslogtreecommitdiff
path: root/math/octave
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-02-10 07:43:49 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-02-10 07:43:49 +0000
commitd2a4c132d86e6134773f873365c2718c85c59d79 (patch)
tree8806ce9c2f7c0317000e56dbc9b3399077b9ed16 /math/octave
parent273d2508f9048e24605d2f9924e1282e25034cfe (diff)
downloadports-d2a4c132d86e6134773f873365c2718c85c59d79.tar.gz
ports-d2a4c132d86e6134773f873365c2718c85c59d79.zip
- Use more graceful way to unbreak on amd64
PR: ports/74669 Submitted by: Roland Smith <rsmith(at)xs4all.nl>
Notes
Notes: svn path=/head/; revision=128451
Diffstat (limited to 'math/octave')
-rw-r--r--math/octave/Makefile9
-rw-r--r--math/octave/files/patch-glob::Makefile.in11
2 files changed, 13 insertions, 7 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index d76776c4f612..55f677c8d5af 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -40,13 +40,8 @@ BLAS_LIBS= "-L${LOCALBASE}/lib -lf77blas -lcblas -latlas"
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONIGURE_ARGS= --host=${GNU_HOST} \
- --with-fftw --with-blas=${BLAS_LIBS} --with-lapack=-lalapack
-.if ${ARCH} == "amd64"
-CONFIGURE_ARGS+= --disable-shared
-.else
-CONFIGURE_ARGS+= --enable-shared
-.endif
+CONIGURE_ARGS= --host=${GNU_HOST} --with-fftw --with-blas=${BLAS_LIBS} \
+ --with-lapack=-lalapack --enable-shared
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
diff --git a/math/octave/files/patch-glob::Makefile.in b/math/octave/files/patch-glob::Makefile.in
new file mode 100644
index 000000000000..8a80c4b52029
--- /dev/null
+++ b/math/octave/files/patch-glob::Makefile.in
@@ -0,0 +1,11 @@
+--- glob/Makefile.in.orig Wed Feb 9 14:43:01 2005
++++ glob/Makefile.in Wed Feb 9 14:43:13 2005
+@@ -25,7 +25,7 @@
+
+ CC = @CC@
+ CPPFLAGS = @CPPFLAGS@
+-CFLAGS = @CFLAGS@
++CFLAGS = @CFLAGS@ -fPIC
+
+ # Information determined by configure.
+ DEFS = @DEFS@