aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-GMPf
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-22 21:28:16 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-22 21:28:16 +0000
commita8e379637c0e6565885974c16cbbc8bed99632de (patch)
treedb57934f56999e109c903d78d2e25a8c2c1285dd /math/p5-Math-GMPf
parent82560e153730eeed6900e355abc7efadb76573f2 (diff)
downloadports-a8e379637c0e6565885974c16cbbc8bed99632de.tar.gz
ports-a8e379637c0e6565885974c16cbbc8bed99632de.zip
- Add p5-Math-GMPf 0.35
Math::GMPf is a bigfloat module utilising the GNU MP (GMP) library. Basically this module simply wraps all of the mpf floating point functions provided by that library. See the Math::GMPf test suite for some examples of usage. WWW: http://search.cpan.org/dist/Math-GMPf/
Notes
Notes: svn path=/head/; revision=299792
Diffstat (limited to 'math/p5-Math-GMPf')
-rw-r--r--math/p5-Math-GMPf/Makefile27
-rw-r--r--math/p5-Math-GMPf/distinfo2
-rw-r--r--math/p5-Math-GMPf/pkg-descr5
-rw-r--r--math/p5-Math-GMPf/pkg-plist16
4 files changed, 50 insertions, 0 deletions
diff --git a/math/p5-Math-GMPf/Makefile b/math/p5-Math-GMPf/Makefile
new file mode 100644
index 000000000000..092e381f2b09
--- /dev/null
+++ b/math/p5-Math-GMPf/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Math-GMPf
+# Date created: 2011-11-30
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-GMPf
+PORTVERSION= 0.35
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:SISYPHUS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Perl interface to the GMP library floating point (mpf) functions
+
+LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp
+TEST_DEPENDS= p5-Math-GMP>=0:${PORTSDIR}/math/p5-Math-GMP \
+ p5-Test-Pod>=1:${PORTSDIR}/devel/p5-Test-Pod
+
+CONFIGURE_ARGS= INC=-I${LOCALBASE}/include LIBS="-L${LOCALBASE}/lib -lgmp"
+PERL_CONFIGURE= yes
+
+MAN3= Math::GMPf.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-GMPf/distinfo b/math/p5-Math-GMPf/distinfo
new file mode 100644
index 000000000000..c93577767707
--- /dev/null
+++ b/math/p5-Math-GMPf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Math-GMPf-0.35.tar.gz) = ea4765bb6bc5aab22bf02b81b2d5d6c753c10be4acc52564fce07988bbed1bd6
+SIZE (Math-GMPf-0.35.tar.gz) = 37573
diff --git a/math/p5-Math-GMPf/pkg-descr b/math/p5-Math-GMPf/pkg-descr
new file mode 100644
index 000000000000..81f93bdef1c4
--- /dev/null
+++ b/math/p5-Math-GMPf/pkg-descr
@@ -0,0 +1,5 @@
+Math::GMPf is a bigfloat module utilising the GNU MP (GMP) library. Basically
+this module simply wraps all of the mpf floating point functions provided by
+that library. See the Math::GMPf test suite for some examples of usage.
+
+WWW: http://search.cpan.org/dist/Math-GMPf/
diff --git a/math/p5-Math-GMPf/pkg-plist b/math/p5-Math-GMPf/pkg-plist
new file mode 100644
index 000000000000..c866fb9fa4bb
--- /dev/null
+++ b/math/p5-Math-GMPf/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/GMPf.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/GMPf/Random.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/GMPf/V.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/GMPf.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/GMPf.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/Random/Random.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/Random/Random.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/V/V.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/V/V.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/V
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf/Random
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/GMPf
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Math/GMPf
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math