aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-GSL/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-11 17:34:25 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-02-11 17:34:25 +0000
commit729ef65a1506a432784bbfe23f22bf2927d0ea3e (patch)
tree6d4191e0c67b52c5788952a8e5ebd173ff392c74 /math/p5-Math-GSL/Makefile
parent9e33339b6cdd2b3055906d70ad67f7bb16b22b11 (diff)
downloadports-729ef65a1506a432784bbfe23f22bf2927d0ea3e.tar.gz
ports-729ef65a1506a432784bbfe23f22bf2927d0ea3e.zip
- Update to 0.28
- Convert to new LIB_DEPENDS format - Use BROKEN_sparc64 - Remove outdated post-patch: - Support STAGEDIR - Take maintainership Changes: http://search.cpan.org/dist/Math-GSL/Changes
Notes
Notes: svn path=/head/; revision=343788
Diffstat (limited to 'math/p5-Math-GSL/Makefile')
-rw-r--r--math/p5-Math-GSL/Makefile82
1 files changed, 8 insertions, 74 deletions
diff --git a/math/p5-Math-GSL/Makefile b/math/p5-Math-GSL/Makefile
index 4096108db2a6..3c3139456a5c 100644
--- a/math/p5-Math-GSL/Makefile
+++ b/math/p5-Math-GSL/Makefile
@@ -2,92 +2,26 @@
# $FreeBSD$
PORTNAME= Math-GSL
-PORTVERSION= 0.27
-PORTREVISION= 1
+PORTVERSION= 0.28
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Perl interface to GNU Scientific Library
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
BUILD_DEPENDS= p5-ExtUtils-PkgConfig>=1.03:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig
-LIB_DEPENDS= gsl:${PORTSDIR}/math/gsl
+LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
TEST_DEPENDS= p5-Test-Class>=0.12:${PORTSDIR}/devel/p5-Test-Class \
- p5-Test-Exception>=0.21:${PORTSDIR}/devel/p5-Test-Exception \
- p5-Test-Most>=0:${PORTSDIR}/devel/p5-Test-Most
+ p5-Test-Most>=0.31:${PORTSDIR}/devel/p5-Test-Most \
+ p5-Test-Exception>=0.21:${PORTSDIR}/devel/p5-Test-Exception
-CFLAGS+= -I${LOCALBASE}/include
-USES= perl5
USE_PERL5= modbuild
+USES= perl5
-MAN1= smolder_smoke_signal.1
-MAN3= Math::GSL.3 \
- Math::GSL::BLAS.3 \
- Math::GSL::BSpline.3 \
- Math::GSL::CBLAS.3 \
- Math::GSL::CDF.3 \
- Math::GSL::Chebyshev.3 \
- Math::GSL::Combination.3 \
- Math::GSL::Complex.3 \
- Math::GSL::Const.3 \
- Math::GSL::DHT.3 \
- Math::GSL::Deriv.3 \
- Math::GSL::Diff.3 \
- Math::GSL::Eigen.3 \
- Math::GSL::Errno.3 \
- Math::GSL::FFT.3 \
- Math::GSL::Fit.3 \
- Math::GSL::Heapsort.3 \
- Math::GSL::Histogram.3 \
- Math::GSL::Histogram2D.3 \
- Math::GSL::Integration.3 \
- Math::GSL::Interp.3 \
- Math::GSL::Linalg.3 \
- Math::GSL::Machine.3 \
- Math::GSL::Matrix.3 \
- Math::GSL::MatrixComplex.3 \
- Math::GSL::Min.3 \
- Math::GSL::Monte.3 \
- Math::GSL::Multifit.3 \
- Math::GSL::Multimin.3 \
- Math::GSL::Multiroots.3 \
- Math::GSL::NTuple.3 \
- Math::GSL::ODEIV.3 \
- Math::GSL::Permutation.3 \
- Math::GSL::Poly.3 \
- Math::GSL::PowInt.3 \
- Math::GSL::QRNG.3 \
- Math::GSL::RNG.3 \
- Math::GSL::Randist.3 \
- Math::GSL::Roots.3 \
- Math::GSL::SF.3 \
- Math::GSL::Siman.3 \
- Math::GSL::Sort.3 \
- Math::GSL::Spline.3 \
- Math::GSL::Statistics.3 \
- Math::GSL::Sum.3 \
- Math::GSL::Sys.3 \
- Math::GSL::Test.3 \
- Math::GSL::Vector.3 \
- Math::GSL::VectorComplex.3 \
- Math::GSL::Wavelet.3 \
- Math::GSL::Wavelet2D.3
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -Ee 's/(\()(back|for)(ward\))/\1gsl_fft_\2\3/' \
- ${WRKSRC}/xs/FFT_wrap.1.15.c
- @${REINPLACE_CMD} -Ee 's/(\()(back|for)(ward\))/\1gsl_wavelet_\2\3/' \
- ${WRKSRC}/xs/Wavelet_wrap.1.15.c
+BROKEN_sparc64= Does not compile on sparc64
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>