aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-RandomOrg
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-29 20:53:35 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-29 20:53:35 +0000
commitea2c977e7fa0f3ac24f96e8056720b511c59a091 (patch)
tree8ad76ee4719a0eb6cc42f8275be882b4213b3a09 /math/p5-Math-RandomOrg
parent78e7a60e213462de54bb4cb9f907eb7c4dc3900b (diff)
downloadports-ea2c977e7fa0f3ac24f96e8056720b511c59a091.tar.gz
ports-ea2c977e7fa0f3ac24f96e8056720b511c59a091.zip
Adding port math/p5-Math-RandomOrg, Retrieve random numbers and data from random.org.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163887
Diffstat (limited to 'math/p5-Math-RandomOrg')
-rw-r--r--math/p5-Math-RandomOrg/Makefile31
-rw-r--r--math/p5-Math-RandomOrg/distinfo2
-rw-r--r--math/p5-Math-RandomOrg/pkg-descr7
-rw-r--r--math/p5-Math-RandomOrg/pkg-plist5
4 files changed, 45 insertions, 0 deletions
diff --git a/math/p5-Math-RandomOrg/Makefile b/math/p5-Math-RandomOrg/Makefile
new file mode 100644
index 000000000000..6c39a981c1a5
--- /dev/null
+++ b/math/p5-Math-RandomOrg/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Math-RandomOrg
+# Date created: 29 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-RandomOrg
+PORTVERSION= 0.02
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Retrieve random numbers and data from random.org
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::RandomOrg.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-RandomOrg/distinfo b/math/p5-Math-RandomOrg/distinfo
new file mode 100644
index 000000000000..1d6e9e0d0823
--- /dev/null
+++ b/math/p5-Math-RandomOrg/distinfo
@@ -0,0 +1,2 @@
+MD5 (Math-RandomOrg-0.02.tar.gz) = 1afcfeee3f1770fb31199887a6c77eeb
+SIZE (Math-RandomOrg-0.02.tar.gz) = 2851
diff --git a/math/p5-Math-RandomOrg/pkg-descr b/math/p5-Math-RandomOrg/pkg-descr
new file mode 100644
index 000000000000..38f7f93ee807
--- /dev/null
+++ b/math/p5-Math-RandomOrg/pkg-descr
@@ -0,0 +1,7 @@
+Math::RandomOrg provides functions for retrieving random data from the
+random.org server. Data may be retrieved in an integer or byte-stream
+format using the randnum and randbyte functions respectively.
+
+WWW: http://search.cpan.org/dist/Math-RandomOrg
+ http://random.org
+Author: Gregory Williams <greg@evilfunhouse.com>
diff --git a/math/p5-Math-RandomOrg/pkg-plist b/math/p5-Math-RandomOrg/pkg-plist
new file mode 100644
index 000000000000..ae791fd2799d
--- /dev/null
+++ b/math/p5-Math-RandomOrg/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Math/RandomOrg.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/RandomOrg/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/RandomOrg
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math