aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-SymbolicX-Complex
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-15 15:02:14 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-15 15:02:14 +0000
commitc1eafb7989782f2ea81dc80e78e558c56aa2f226 (patch)
tree0865a357d2efc766ef9830e4d8eca0b96e7afa84 /math/p5-Math-SymbolicX-Complex
parent8c0396f6bf6d7be65631e467265aed9157882d13 (diff)
downloadports-c1eafb7989782f2ea81dc80e78e558c56aa2f226.tar.gz
ports-c1eafb7989782f2ea81dc80e78e558c56aa2f226.zip
Adding port math/p5-Math-SymbolicX-Complex, Complex number support for the Math::Symbolic parser
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=162441
Diffstat (limited to 'math/p5-Math-SymbolicX-Complex')
-rw-r--r--math/p5-Math-SymbolicX-Complex/Makefile32
-rw-r--r--math/p5-Math-SymbolicX-Complex/distinfo3
-rw-r--r--math/p5-Math-SymbolicX-Complex/pkg-descr8
-rw-r--r--math/p5-Math-SymbolicX-Complex/pkg-plist7
4 files changed, 50 insertions, 0 deletions
diff --git a/math/p5-Math-SymbolicX-Complex/Makefile b/math/p5-Math-SymbolicX-Complex/Makefile
new file mode 100644
index 000000000000..3fbe5c371b66
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Complex/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Math-SymbolicX-Complex
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-SymbolicX-Complex
+PORTVERSION= 0.01
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Complex number support for the Math::Symbolic parser
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
+ ${SITE_PERL}/Math/SymbolicX/ParserExtensionFactory.pm:${PORTSDIR}/math/p5-Math-SymbolicX-ParserExtensionFactory
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::SymbolicX::Complex.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-SymbolicX-Complex/distinfo b/math/p5-Math-SymbolicX-Complex/distinfo
new file mode 100644
index 000000000000..c66001eddccf
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Complex/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-SymbolicX-Complex-0.01.tar.gz) = 509cc4092ade46de3762bf3d5f63a914
+SHA256 (Math-SymbolicX-Complex-0.01.tar.gz) = 559947d3d40937108c5b9814dc8b6b6c4ae69c684f84e07f9d7008b6d1ae93b6
+SIZE (Math-SymbolicX-Complex-0.01.tar.gz) = 4057
diff --git a/math/p5-Math-SymbolicX-Complex/pkg-descr b/math/p5-Math-SymbolicX-Complex/pkg-descr
new file mode 100644
index 000000000000..00626db86978
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Complex/pkg-descr
@@ -0,0 +1,8 @@
+This module adds complex number support to Math::Symbolic. It does so by
+extending the parser of the Math::Symbolic module (that is, the one stored
+in $Math::Symbolic::Parser) with certain special functions that create
+complex constants. (Math::Symbolic::Variable objects have been able to
+contain complex number objects since the very beginning.)
+
+WWW: http://search.cpan.org/dist/Math-SymbolicX-Complex
+Author: Steffen Mueller <symbolic-module@steffen-mueller.net>
diff --git a/math/p5-Math-SymbolicX-Complex/pkg-plist b/math/p5-Math-SymbolicX-Complex/pkg-plist
new file mode 100644
index 000000000000..43b5ee8c7596
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Complex/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Math/SymbolicX/Complex.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX/Complex/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX/Complex
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math/SymbolicX
+@dirrmtry %%SITE_PERL%%/Math