aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-SymbolicX-NoSimplification
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-15 15:26:46 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-15 15:26:46 +0000
commit422fb53a7301b31627daa7692717af673720fc79 (patch)
treeee4cce2bbc10adde9583373d7ddc630f08696f94 /math/p5-Math-SymbolicX-NoSimplification
parentcc977fa0810cf11473f1160f13a7dd9caf3a379e (diff)
downloadports-422fb53a7301b31627daa7692717af673720fc79.tar.gz
ports-422fb53a7301b31627daa7692717af673720fc79.zip
Adding port math/p5-Math-SymbolicX-NoSimplification, Turn off Math::Symbolic simplification
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=162447
Diffstat (limited to 'math/p5-Math-SymbolicX-NoSimplification')
-rw-r--r--math/p5-Math-SymbolicX-NoSimplification/Makefile31
-rw-r--r--math/p5-Math-SymbolicX-NoSimplification/distinfo3
-rw-r--r--math/p5-Math-SymbolicX-NoSimplification/pkg-descr17
-rw-r--r--math/p5-Math-SymbolicX-NoSimplification/pkg-plist7
4 files changed, 58 insertions, 0 deletions
diff --git a/math/p5-Math-SymbolicX-NoSimplification/Makefile b/math/p5-Math-SymbolicX-NoSimplification/Makefile
new file mode 100644
index 000000000000..5f0fe6a32df1
--- /dev/null
+++ b/math/p5-Math-SymbolicX-NoSimplification/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Math-SymbolicX-NoSimplification
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-SymbolicX-NoSimplification
+PORTVERSION= 0.01
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Turn off Math::Symbolic simplification
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::SymbolicX::NoSimplification.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-SymbolicX-NoSimplification/distinfo b/math/p5-Math-SymbolicX-NoSimplification/distinfo
new file mode 100644
index 000000000000..d336982e6220
--- /dev/null
+++ b/math/p5-Math-SymbolicX-NoSimplification/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-SymbolicX-NoSimplification-0.01.tar.gz) = 63a8a430b82bcf4425345d4977f1b582
+SHA256 (Math-SymbolicX-NoSimplification-0.01.tar.gz) = 66d3b3d38b765fee1118fc92933e2a94ead3d3b93fed071fda3fab25f3cf3c1b
+SIZE (Math-SymbolicX-NoSimplification-0.01.tar.gz) = 3263
diff --git a/math/p5-Math-SymbolicX-NoSimplification/pkg-descr b/math/p5-Math-SymbolicX-NoSimplification/pkg-descr
new file mode 100644
index 000000000000..cda5979c7dc0
--- /dev/null
+++ b/math/p5-Math-SymbolicX-NoSimplification/pkg-descr
@@ -0,0 +1,17 @@
+This module offers facilities to turn off the builtin Math::Symbolic
+simplification routines and replace them with routines that just clone the
+objects. You may want to do this in cases where the simplification
+routines fail to simplify the Math::Symbolic trees and waste a lot of CPU
+time. (For example, calculating the first order Taylor polynomial of a
+moderately complex test function was sped up by 100% on my machine.)
+
+A word of caution, however: If you turn off the simplification routines,
+some procedures may produce very, very large trees. One such procedure
+would be the consecutive application of many derivatives to a product
+without intermediate simplification. This would yield exponential growth
+of nodes. (And may, in fact, still do if you keep the simplification
+heuristics turned on because most expressions cannot be simplified
+significantly.)
+
+WWW: http://search.cpan.org/dist/Math-SymbolicX-NoSimplification
+Author: Steffen Mueller <symbolic-module@steffen-mueller.net>
diff --git a/math/p5-Math-SymbolicX-NoSimplification/pkg-plist b/math/p5-Math-SymbolicX-NoSimplification/pkg-plist
new file mode 100644
index 000000000000..89219414d2fa
--- /dev/null
+++ b/math/p5-Math-SymbolicX-NoSimplification/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Math/SymbolicX/NoSimplification.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX/NoSimplification/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX/NoSimplification
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math/SymbolicX
+@dirrmtry %%SITE_PERL%%/Math