aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Math-TrulyRandom
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-03-17 21:41:24 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-03-17 21:41:24 +0000
commit40902e2b31cd6154e1312d9693b25fd0a52135d0 (patch)
tree10709ae2eda543f3d45242f8d00287747c284040 /math/p5-Math-TrulyRandom
parentef29dbc153c24bf373d54f59e176d57a872b506c (diff)
downloadports-40902e2b31cd6154e1312d9693b25fd0a52135d0.tar.gz
ports-40902e2b31cd6154e1312d9693b25fd0a52135d0.zip
Add Math::TrulyRandom, a Perl interface to a truly random number
generator function.
Notes
Notes: svn path=/head/; revision=56269
Diffstat (limited to 'math/p5-Math-TrulyRandom')
-rw-r--r--math/p5-Math-TrulyRandom/Makefile30
-rw-r--r--math/p5-Math-TrulyRandom/distinfo1
-rw-r--r--math/p5-Math-TrulyRandom/pkg-comment1
-rw-r--r--math/p5-Math-TrulyRandom/pkg-descr5
-rw-r--r--math/p5-Math-TrulyRandom/pkg-plist12
5 files changed, 49 insertions, 0 deletions
diff --git a/math/p5-Math-TrulyRandom/Makefile b/math/p5-Math-TrulyRandom/Makefile
new file mode 100644
index 000000000000..18349f4c1210
--- /dev/null
+++ b/math/p5-Math-TrulyRandom/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Math::TrulyRandom
+# Date created: 17 March 2002
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-TrulyRandom
+PORTVERSION= 1.0
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= anders@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::TrulyRandom.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d -m 0755 ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYRIGHT ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/truerand.c ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/truerand.h ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-TrulyRandom/distinfo b/math/p5-Math-TrulyRandom/distinfo
new file mode 100644
index 000000000000..64d75fff92d2
--- /dev/null
+++ b/math/p5-Math-TrulyRandom/distinfo
@@ -0,0 +1 @@
+MD5 (Math-TrulyRandom-1.0.tar.gz) = 32e2273ee192203837cb1a21756a27a0
diff --git a/math/p5-Math-TrulyRandom/pkg-comment b/math/p5-Math-TrulyRandom/pkg-comment
new file mode 100644
index 000000000000..7deb38d95527
--- /dev/null
+++ b/math/p5-Math-TrulyRandom/pkg-comment
@@ -0,0 +1 @@
+Perl interface to a truly random number generator function
diff --git a/math/p5-Math-TrulyRandom/pkg-descr b/math/p5-Math-TrulyRandom/pkg-descr
new file mode 100644
index 000000000000..34d01c7da26c
--- /dev/null
+++ b/math/p5-Math-TrulyRandom/pkg-descr
@@ -0,0 +1,5 @@
+The Math::TrulyRandom module provides an ability to generate truly random
+numbers from within Perl programs. The source of the randomness is from
+interrupt timing discrepancies.
+
+- Anders Nordby <anders@FreeBSD.org>
diff --git a/math/p5-Math-TrulyRandom/pkg-plist b/math/p5-Math-TrulyRandom/pkg-plist
new file mode 100644
index 000000000000..97d979d1a2d7
--- /dev/null
+++ b/math/p5-Math-TrulyRandom/pkg-plist
@@ -0,0 +1,12 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/TrulyRandom/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Math/TrulyRandom.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Math/TrulyRandom.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/TrulyRandom/TrulyRandom.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/TrulyRandom/TrulyRandom.so
+%%PORTDOCS%%share/doc/Math-TrulyRandom/COPYRIGHT
+%%PORTDOCS%%share/doc/Math-TrulyRandom/truerand.c
+%%PORTDOCS%%share/doc/Math-TrulyRandom/truerand.h
+%%PORTDOCS%%@dirrm share/doc/Math-TrulyRandom
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/TrulyRandom 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Math 2>/dev/null || true