aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Statistics-Contingency/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-01-03 09:20:28 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-01-03 09:20:28 +0000
commit57fecf181c346ce9248732016430d952b9188498 (patch)
treecb939350ac1a5c1362b25a70b87088e99cef5da7 /math/p5-Statistics-Contingency/Makefile
parenta50225470362fed8b02a7c7d31a5489983e1cb6d (diff)
downloadports-57fecf181c346ce9248732016430d952b9188498.tar.gz
ports-57fecf181c346ce9248732016430d952b9188498.zip
Add p5-Statistics-Contingency 0.06,
calculate precision, recall, F1, accuracy, etc. PR: 60726 Submitted by: Cheng-Lung Sung <clsung@dragon2.net>
Notes
Notes: svn path=/head/; revision=97202
Diffstat (limited to 'math/p5-Statistics-Contingency/Makefile')
-rw-r--r--math/p5-Statistics-Contingency/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/math/p5-Statistics-Contingency/Makefile b/math/p5-Statistics-Contingency/Makefile
new file mode 100644
index 000000000000..00acbb9cc30b
--- /dev/null
+++ b/math/p5-Statistics-Contingency/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: math/p5-Statistics-Contingency
+# Date created: Tue Dec 30 19:57:00 CST 2003
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Statistics-Contingency
+PORTVERSION= 0.06
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Statistics
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= Calculate precision, recall, F1, accuracy, etc
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Statistics::Contingency.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port will require perl 5.6.x or later in the future. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>