aboutsummaryrefslogtreecommitdiff
path: root/math/p5-Statistics-Regression
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-04-07 03:02:00 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-04-07 03:02:00 +0000
commit1cfd4012b358242cc44320b4a4539cbf0b5265cf (patch)
tree0e6911663dad75670ffde91598bcdc9ea863a5db /math/p5-Statistics-Regression
parent1683f995b98538709c3ec0e2ad8cbe01eb6b201d (diff)
downloadports-1cfd4012b358242cc44320b4a4539cbf0b5265cf.tar.gz
ports-1cfd4012b358242cc44320b4a4539cbf0b5265cf.zip
Regression.pm is a multivariate linear regression package.
That is, it estimates the c coefficients for a line-fit of the type y= c(0)*x(0) + c(1)*x1 + c(2)*x2 + ... + c(k)*xk given a data set of N observations, each with k independent x variables and one y variable. Naturally, N must be greater than k---and preferably considerably greater. Any reasonable undergraduate statistics book will explain what a regression is. Most of the time, the user will provide a constant ('1') as x(0) for each observation in order to allow the regression package to fit an intercept. WWW: http://search.cpan.org/dist/Statistics-Regression/
Notes
Notes: svn path=/head/; revision=189404
Diffstat (limited to 'math/p5-Statistics-Regression')
-rw-r--r--math/p5-Statistics-Regression/Makefile22
-rw-r--r--math/p5-Statistics-Regression/distinfo3
-rw-r--r--math/p5-Statistics-Regression/pkg-descr13
-rw-r--r--math/p5-Statistics-Regression/pkg-plist5
4 files changed, 43 insertions, 0 deletions
diff --git a/math/p5-Statistics-Regression/Makefile b/math/p5-Statistics-Regression/Makefile
new file mode 100644
index 000000000000..22cbcc77b4b9
--- /dev/null
+++ b/math/p5-Statistics-Regression/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: math/p5-Statistics-Regression
+# Date created: Apr 7, 2007
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Statistics-Regression
+PORTVERSION= 0.50
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Statistics
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Perl module to perform weighted linear regression
+
+PERL_CONFIGURE= yes
+
+MAN3= Statistics::Regression.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Statistics-Regression/distinfo b/math/p5-Statistics-Regression/distinfo
new file mode 100644
index 000000000000..cd64e17d9b34
--- /dev/null
+++ b/math/p5-Statistics-Regression/distinfo
@@ -0,0 +1,3 @@
+MD5 (Statistics-Regression-0.50.tar.gz) = 4930f08a214ec91243b6846d9ddbe5fe
+SHA256 (Statistics-Regression-0.50.tar.gz) = 2bbf3310ad95ac942a7b7f666c1e1dbc8a8286b542ce727ba35d69daad56a7e3
+SIZE (Statistics-Regression-0.50.tar.gz) = 22268
diff --git a/math/p5-Statistics-Regression/pkg-descr b/math/p5-Statistics-Regression/pkg-descr
new file mode 100644
index 000000000000..e7b40725d355
--- /dev/null
+++ b/math/p5-Statistics-Regression/pkg-descr
@@ -0,0 +1,13 @@
+Regression.pm is a multivariate linear regression package.
+That is, it estimates the c coefficients for a line-fit of the type
+
+ y= c(0)*x(0) + c(1)*x1 + c(2)*x2 + ... + c(k)*xk
+
+given a data set of N observations, each with k independent x variables
+and one y variable. Naturally, N must be greater than k---and preferably
+considerably greater. Any reasonable undergraduate statistics book will
+explain what a regression is. Most of the time, the user will provide a
+constant ('1') as x(0) for each observation in order to allow the
+regression package to fit an intercept.
+
+WWW: http://search.cpan.org/dist/Statistics-Regression/
diff --git a/math/p5-Statistics-Regression/pkg-plist b/math/p5-Statistics-Regression/pkg-plist
new file mode 100644
index 000000000000..3998a1c4fc0e
--- /dev/null
+++ b/math/p5-Statistics-Regression/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/Regression/.packlist
+%%SITE_PERL%%/Statistics/Regression.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/Regression
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics
+@dirrmtry %%SITE_PERL%%/Statistics