aboutsummaryrefslogtreecommitdiff
path: root/math/ploticus
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-01 07:25:59 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-01 07:25:59 +0000
commit05284ee12724b8a28a93a21534cdb8191a12e1ae (patch)
tree9be5662a2bd22766e70c6b5bc57d0e309c0c3df8 /math/ploticus
parentb3622a850cd57e16cf9bf0cfa308d241ab98aff5 (diff)
downloadports-05284ee12724b8a28a93a21534cdb8191a12e1ae.tar.gz
ports-05284ee12724b8a28a93a21534cdb8191a12e1ae.zip
update math/ploticus:
- Add graphics/ming to LIB_DEPENDS PR: 52932 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=83959
Diffstat (limited to 'math/ploticus')
-rw-r--r--math/ploticus/Makefile20
-rw-r--r--math/ploticus/files/patch-src::Makefile88
-rw-r--r--math/ploticus/files/patch-src::swf.c11
3 files changed, 28 insertions, 91 deletions
diff --git a/math/ploticus/Makefile b/math/ploticus/Makefile
index ae6b87f74793..9ec313128004 100644
--- a/math/ploticus/Makefile
+++ b/math/ploticus/Makefile
@@ -8,6 +8,7 @@
PORTNAME= ploticus
PORTVERSION= 2.11
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://ploticus.sourceforge.net/download/
DISTNAME= plsrc${PORTVERSION:S/.//}
@@ -15,15 +16,28 @@ DISTNAME= plsrc${PORTVERSION:S/.//}
MAINTAINER= ports@FreeBSD.org
COMMENT= Generates plots and graphs from data
-LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd \
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd2 \
jpeg.9:${PORTSDIR}/graphics/jpeg \
+ ming.3:${PORTSDIR}/graphics/ming \
png.5:${PORTSDIR}/graphics/png \
freetype.9:${PORTSDIR}/print/freetype2
WRKSRC= ${WRKDIR}/${DISTNAME}/src
CONFLICTS= slffea-* swi-pl-*
-USE_XLIB= yes
-ALL_TARGET= ${PORTNAME}
+
+FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
+
+USE_XPM= yes
+MAKE_ARGS= CC="${CC}" FLAGS="${CFLAGS}" \
+ LOCALEOBJ="localef.o" LOCALE_FLAG="-DLOCALE" \
+ MING="-L${LOCALBASE}/lib -lming" \
+ MINGH="-I${LOCALBASE}/include/ming" NOSWFFLAG="" \
+ GD18LIBS="`${FREETYPE_CONFIG} --libs` \
+ -L${LOCALBASE}/lib -lgd -lpng -lz -ljpeg" \
+ GD18H="`${FREETYPE_CONFIG} --cflags` \
+ -L${LOCALBASE}/include" \
+ GDFREETYPE="-DGDFREETYPE" PREFABS_DIR="${DATADIR}"
+ALL_TARGET= plgd18
MAN1= pl.1
diff --git a/math/ploticus/files/patch-src::Makefile b/math/ploticus/files/patch-src::Makefile
deleted file mode 100644
index 47715281a655..000000000000
--- a/math/ploticus/files/patch-src::Makefile
+++ /dev/null
@@ -1,88 +0,0 @@
---- Makefile.orig Sat May 24 15:00:02 2003
-+++ Makefile Sat May 24 15:06:19 2003
-@@ -23,7 +23,7 @@
- ######## Covered by GPL; see the file ./Copyright for details.
-
- # defaults..
--CC = gcc
-+CC ?= gcc
- PLATFORM = UNIX
- RMCOM = rm -f
- XOBJ = x11.o interact.o
-@@ -41,7 +41,8 @@
- XLIBS = -L/usr/X11R6/lib -lX11
- XINCLUDEDIR = -I/usr/X11R6/include
- #### For FreeBSD uncomment the following and find GD16H or GD18H below and set to -I/usr/local/include
--# ADDLIBS = -L/usr/local/lib
-+ADDLIBS = -L${LOCALBASE}/lib
-+FLAGS = -I${LOCALBASE}/include
-
- #### For Solaris 2.x uncomment the following..
- # XLIBS = -L/usr/openwin/lib -lX11
-@@ -105,11 +106,11 @@
- # ploticus: pl
-
- #### For PNG (only) uncomment the following.. (you must have libpng and zlib)
--ploticus: plpng
--PLPNG = pl
--GD16LIBS = -lpng -lz
--GD16H =
--ZFLAG = -DWZ
-+#ploticus: plpng
-+#PLPNG = pl
-+#GD16LIBS = -lpng -lz
-+#GD16H =
-+#ZFLAG = -DWZ
-
- #### For both pseudo-GIF & PNG uncomment the following.. (you must have libpng and zlib)
- # ploticus: pl plpng
-@@ -121,18 +122,18 @@
- #### (you must have gd 1.84+, libpng, zlib, libjpeg)
- # ploticus: plgd18
- # GD18LIBS = -lgd -lpng -lz -ljpeg
--# GD18H =
--# GDFREETYPE =
-+# GD18H = -I${LOCALBASE}/include/gd
-+# GDFREETYPE = -DGDFREETYPE
- # ZFLAG = -DWZ
-
- #### For JPEG, WBMP, PNG, and FreeType2, using your copy of GD 1.84+, uncomment the following..
- #### (you must have gd 1.84+, libpng, zlib, libjpeg, libfreetype)
- #### Before using set environment var GDFONTPATH to directory containing .ttf files
--# ploticus: plgd18
--# GD18LIBS = -lgd -lpng -lz -ljpeg -lfreetype
--# GD18H =
--# GDFREETYPE = -DGDFREETYPE
--# ZFLAG = -DWZ
-+ploticus: plgd18
-+GD18LIBS = -lgd -lpng -lz -ljpeg -lfreetype
-+GD18H = -I${LOCALBASE}/include/gd
-+GDFREETYPE = -DGDFREETYPE
-+ZFLAG = -DWZ
-
- #### To disable all GD image support (no PNG, JPEG, GIF, etc) uncomment the following..
- # ploticus: plnogd
-@@ -149,11 +150,11 @@
- #### To set a hard-coded directory for prefabs files, uncomment & edit the following..
- #### If done, users won't be required to have PLOTICUS_PREFABS environment variable defined.
- #### This option not available for win32
--# PREFABS_DIR = "/usr/lib/ploticus"
-+PREFABS_DIR = "${PREFIX}/share/ploticus"
-
- #### For LOCALE support (non-roman alphabets & collation), uncomment the following..
--# LOCALEOBJ = localef.o
--# LOCALE_FLAG = -DLOCALE
-+LOCALEOBJ = localef.o
-+LOCALE_FLAG = -DLOCALE
-
- #### SVG output is always available by default.
- #### If you want compressed SVG (.svgz), and you selected "GIF only", "GIF & PNG", or "disable GD" above,
-@@ -197,7 +198,7 @@
-
- LIBS = $(XLIBS) -lm $(ADDLIBS)
-
--CFLAGS = -DPLOTICUS -D$(PLATFORM) -DTDH_NOREC $(ZFLAG) $(FLAGS) $(LOCALE_FLAG) \
-+CFLAGS += -DPLOTICUS -D$(PLATFORM) -DTDH_NOREC $(ZFLAG) $(FLAGS) $(LOCALE_FLAG) \
- $(NOGDFLAG) $(NOXFLAG) $(NOPSFLAG) $(NOSVGFLAG) $(NOSWFFLAG) $(XINCLUDEDIR) \
- $(MINGH) $(NORLIMFLAG) -DPREFABS_DIR=\"$(PREFABS_DIR)\"
-
diff --git a/math/ploticus/files/patch-src::swf.c b/math/ploticus/files/patch-src::swf.c
new file mode 100644
index 000000000000..63e500760310
--- /dev/null
+++ b/math/ploticus/files/patch-src::swf.c
@@ -0,0 +1,11 @@
+--- swf.c.orig Tue May 20 02:55:58 2003
++++ swf.c Wed Jun 4 09:41:53 2003
+@@ -80,7 +80,7 @@
+ static void swf_TX(char *s);
+ static void swf_LS(char *s);
+ static void swf_PO(char *s);
+-static void swf_FT(char *s);
++/* static void swf_FT(char *s); */
+ static void swf_TR(char *s);
+
+ /* ============================= */