aboutsummaryrefslogtreecommitdiff
path: root/math/ploticus
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-23 19:32:29 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-01-23 19:32:29 +0000
commit269271c78daafdfc461c6e43b3af75f619e73cb1 (patch)
treecc1690f5ed7dc293c5c985652ff1988bfe7efe54 /math/ploticus
parent79b8f028047f81174a2db4f72957c434db5b681b (diff)
downloadports-269271c78daafdfc461c6e43b3af75f619e73cb1.tar.gz
ports-269271c78daafdfc461c6e43b3af75f619e73cb1.zip
add ploticus 2.02
Generates plots and graphs from data
Notes
Notes: svn path=/head/; revision=53652
Diffstat (limited to 'math/ploticus')
-rw-r--r--math/ploticus/Makefile47
-rw-r--r--math/ploticus/distinfo1
-rw-r--r--math/ploticus/files/patch-Makefile81
-rw-r--r--math/ploticus/files/patch-reslimits.c13
-rw-r--r--math/ploticus/pkg-comment1
-rw-r--r--math/ploticus/pkg-descr20
-rw-r--r--math/ploticus/pkg-plist117
7 files changed, 280 insertions, 0 deletions
diff --git a/math/ploticus/Makefile b/math/ploticus/Makefile
new file mode 100644
index 000000000000..e26f7fa77d1b
--- /dev/null
+++ b/math/ploticus/Makefile
@@ -0,0 +1,47 @@
+# ex:ts=8
+# Ports collection makefile for: ploticus
+# Date created: Jan 23, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ploticus
+PORTVERSION= 2.02
+CATEGORIES= math
+MASTER_SITES= http://ploticus.sourceforge.net/download/
+DISTNAME= plsrc${PORTVERSION:S/.//}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd \
+ png:${PORTSDIR}/graphics/png \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ freetype:${PORTSDIR}/print/freetype2
+
+USE_XLIB= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+ALL_TARGET= # empty
+MAKE_ENV= LIBS="-L${LOCALBASE}/lib"
+
+MAN1= pl.1 ploticus.1 plpng.1 pltab.1
+
+post-patch:
+ @${PERL} -pi -e "s,%%X11BASE%%,${X11BASE},g ; \
+ s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile
+
+do-install:
+.for file in pl pltab
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
+.endfor
+ @${MKDIR} ${DATADIR}
+ ${CP} ${WRKSRC}/../prefabs/* ${DATADIR}
+.for file in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/../man/man1/${file} ${MAN1PREFIX}/man/man1
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/../doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/ploticus/distinfo b/math/ploticus/distinfo
new file mode 100644
index 000000000000..32b73770a560
--- /dev/null
+++ b/math/ploticus/distinfo
@@ -0,0 +1 @@
+MD5 (plsrc202.tar.gz) = bb77876000f4ce4ca2e6892620b7f777
diff --git a/math/ploticus/files/patch-Makefile b/math/ploticus/files/patch-Makefile
new file mode 100644
index 000000000000..8ee40905fe00
--- /dev/null
+++ b/math/ploticus/files/patch-Makefile
@@ -0,0 +1,81 @@
+--- Makefile.orig Wed Jan 23 22:23:20 2002
++++ Makefile Wed Jan 23 22:36:17 2002
+@@ -13,7 +13,7 @@
+ ######## Covered by GPL; see the file ./Copyright for details.
+
+ # defaults..
+-CC = gcc
++#CC = gcc
+ PLATFORM = UNIX
+ RMCOM = rm -f
+ XOBJ = x11.o sleep.o interact.o
+@@ -26,12 +26,12 @@
+ ######## Choose one of the following. All others should be commented out.
+
+ #### For Solaris 2.x uncomment the following..
+-XLIBS = -L/usr/openwin/lib -lX11
+-XINCLUDEDIR = -I/usr/openwin/include
++#XLIBS = -L/usr/openwin/lib -lX11
++#XINCLUDEDIR = -I/usr/openwin/include
+
+ #### For Linux and FreeBSD uncomment the following..
+-# XLIBS = -L/usr/X11R6/lib -lX11
+-# XINCLUDEDIR = -I/usr/X11R6/include
++XLIBS = -L%%X11BASE%%/lib -lX11
++XINCLUDEDIR = -I/usr/X11R6/include
+
+ #### For Cygwin uncomment the following..
+ # PLATFORM = WIN32
+@@ -79,7 +79,7 @@
+ ######## Choose ONE of the following. All others should be commented out.
+
+ #### For pseudo-GIF uncomment the following.. (no libs required)
+-ploticus: pl pltab
++#ploticus: pl pltab
+
+ #### For PNG uncomment the following.. (you must have libpng and zlib)
+ # ploticus: plpng pltabpng
+@@ -105,11 +105,11 @@
+ #### For JPEG, WBMP, and PNG & FreeType2 using your copy of GD 1.84+ uncomment the following..
+ #### (you must have gd 1.84+, libpng, zlib, libjpeg, libfreetype)
+ #### Before using set environment var GDFONTPATH to directory containing .ttf files
+-# ploticus: plgd18 pltabgd18
+-# GD18LIBS = -lgd -lpng -lz -ljpeg -lfreetype
+-# GD18H =
+-# GDFREETYPE = -DGDFREETYPE
+-# ZFLAG = -DWZ
++ploticus: plgd18 pltabgd18
++GD18LIBS = -lgd -lpng -lz -ljpeg -lfreetype
++GD18H = -I%%LOCALBASE%%/include -I%%LOCALBASE%%/include/gd -I%%LOCALBASE%%/include/freetype2
++GDFREETYPE = -DGDFREETYPE
++ZFLAG = -DWZ
+
+ #### To disable GD image support (no GIF, PNG, JPEG, etc) uncomment the following..
+ # ploticus: plnogd pltabnogd
+@@ -123,11 +123,11 @@
+ #### To set a hard-coded directory for prefabs files, uncomment & edit the following..
+ #### If done, users won't be required to have PLOTICUS_PREFABS environment variable defined.
+ #### This option not available for win32
+-# PREFABS_DIR = "/usr/lib/ploticus"
++PREFABS_DIR = "%%LOCALBASE%%/share/ploticus"
+
+ #### For LOCALE support (non-roman alphabets & collation), uncomment the following..
+-# LOCALEOBJ = localef.o
+-# LOCALE_FLAG = -DLOCALE
++LOCALEOBJ = localef.o
++LOCALE_FLAG = -DLOCALE
+
+ #### If you want compressed svg (.svgz), and you selected "GIF only", "GIF & PNG", or "disable GD" above,
+ #### uncomment the following. You need to have zlib. If necessary change -lz to location of zlib.
+@@ -154,9 +154,9 @@
+ GD = gdfontg.o gdfontl.o gdfontmb.o gdfonts.o gdfontt.o
+
+
+-LIBS = $(XLIBS) -lm $(ADDLIBS)
++LIBS += $(XLIBS) -lm $(ADDLIBS)
+
+-CFLAGS = -DPLOTICUS -D$(PLATFORM) -DTDH_NOREC $(ZFLAG) $(FLAGS) $(LOCALE_FLAG) \
++CFLAGS += -DPLOTICUS -D$(PLATFORM) -DTDH_NOREC $(ZFLAG) $(FLAGS) $(LOCALE_FLAG) \
+ $(NOGDFLAG) $(NOXFLAG) $(XINCLUDEDIR) $(NORLIMFLAG) -DPREFABS_DIR=\"$(PREFABS_DIR)\"
+
+ OBJ = proc_annotate.o proc_areadef.o proc_axis.o proc_bars.o proc_bevelrect.o proc_breakaxis.o \
diff --git a/math/ploticus/files/patch-reslimits.c b/math/ploticus/files/patch-reslimits.c
new file mode 100644
index 000000000000..3623e527397c
--- /dev/null
+++ b/math/ploticus/files/patch-reslimits.c
@@ -0,0 +1,13 @@
+--- reslimits.c.orig Wed Jan 23 22:39:27 2002
++++ reslimits.c Wed Jan 23 22:41:29 2002
+@@ -9,8 +9,9 @@
+ #ifndef NORLIMIT
+
+ #include <stdio.h>
+-#include <sys/resource.h>
++#include <sys/types.h>
+ #include <sys/time.h>
++#include <sys/resource.h>
+
+ reslimits( type, value )
+ char *type;
diff --git a/math/ploticus/pkg-comment b/math/ploticus/pkg-comment
new file mode 100644
index 000000000000..f3e1fc41cc32
--- /dev/null
+++ b/math/ploticus/pkg-comment
@@ -0,0 +1 @@
+Generates plots and graphs from data
diff --git a/math/ploticus/pkg-descr b/math/ploticus/pkg-descr
new file mode 100644
index 000000000000..393b93c4a52c
--- /dev/null
+++ b/math/ploticus/pkg-descr
@@ -0,0 +1,20 @@
+Ploticus is script-driven, which makes it suitable for automated, unattended
+uses, or for applications that will be run again and again. Ploticus might be
+your choice for stylistic reasons or just because it suits the problem or
+application. In general, ploticus is good at making graphs like you would see
+in newspapers and news magazines, business publications, journals for medical
+and social sciences, and so on.
+
+You can also use Ploticus in combination with standard desktop tools, e.g.
+generate data displays using ploticus then import SVG or PNG into PowerPoint,
+Word, etc.)
+
+Ploticus is not a function or mathematical plotting package like gnuplot, nor
+would it be a good choice for applications where mathematical formulas or
+scientific notations are to be rendered as an integral part of the data
+display. Ploticus is also not intended as a "marketing" graphics package. Its
+goal is to display data crisply without extra decoration and distracting
+"dingbats" that cloud the picture. Thus there is little support for 3-D
+effects, gradient backgrounds, and so on.
+
+WWW: http://ploticus.sourceforge.net/
diff --git a/math/ploticus/pkg-plist b/math/ploticus/pkg-plist
new file mode 100644
index 000000000000..22121f2a6132
--- /dev/null
+++ b/math/ploticus/pkg-plist
@@ -0,0 +1,117 @@
+bin/pl
+bin/pltab
+share/ploticus/README
+share/ploticus/chron.pl
+share/ploticus/chunk_area
+share/ploticus/chunk_read
+share/ploticus/chunk_setstd
+share/ploticus/chunk_title
+share/ploticus/chunk_xaxis
+share/ploticus/chunk_yaxis
+share/ploticus/dist.pl
+share/ploticus/draw.pl
+share/ploticus/lines.pl
+share/ploticus/pie.pl
+share/ploticus/scat.pl
+share/ploticus/stack.pl
+share/ploticus/vbars.pl
+@dirrm share/ploticus
+%%PORTDOCS%%share/doc/ploticus/Changelog.html
+%%PORTDOCS%%share/doc/ploticus/Contents.html
+%%PORTDOCS%%share/doc/ploticus/Copyright.html
+%%PORTDOCS%%share/doc/ploticus/Download.html
+%%PORTDOCS%%share/doc/ploticus/Faq.html
+%%PORTDOCS%%share/doc/ploticus/Faq.other.html
+%%PORTDOCS%%share/doc/ploticus/Feedback.html
+%%PORTDOCS%%share/doc/ploticus/Feedback00.html
+%%PORTDOCS%%share/doc/ploticus/Problems.html
+%%PORTDOCS%%share/doc/ploticus/Versions.html
+%%PORTDOCS%%share/doc/ploticus/Welcome.html
+%%PORTDOCS%%share/doc/ploticus/annotate.html
+%%PORTDOCS%%share/doc/ploticus/areadef.html
+%%PORTDOCS%%share/doc/ploticus/attributetypes.html
+%%PORTDOCS%%share/doc/ploticus/autorange.html
+%%PORTDOCS%%share/doc/ploticus/axis.html
+%%PORTDOCS%%share/doc/ploticus/bars.html
+%%PORTDOCS%%share/doc/ploticus/bevelrect.html
+%%PORTDOCS%%share/doc/ploticus/breakaxis.html
+%%PORTDOCS%%share/doc/ploticus/catslide.html
+%%PORTDOCS%%share/doc/ploticus/cgi.html
+%%PORTDOCS%%share/doc/ploticus/changes20.html
+%%PORTDOCS%%share/doc/ploticus/clickmap.html
+%%PORTDOCS%%share/doc/ploticus/color.html
+%%PORTDOCS%%share/doc/ploticus/commalist.html
+%%PORTDOCS%%share/doc/ploticus/condex.html
+%%PORTDOCS%%share/doc/ploticus/config.html
+%%PORTDOCS%%share/doc/ploticus/control.html
+%%PORTDOCS%%share/doc/ploticus/controlling.html
+%%PORTDOCS%%share/doc/ploticus/curvefit.html
+%%PORTDOCS%%share/doc/ploticus/dataformat.html
+%%PORTDOCS%%share/doc/ploticus/dates.html
+%%PORTDOCS%%share/doc/ploticus/datesettings.html
+%%PORTDOCS%%share/doc/ploticus/defineunits.html
+%%PORTDOCS%%share/doc/ploticus/drawcommands.html
+%%PORTDOCS%%share/doc/ploticus/endproc.html
+%%PORTDOCS%%share/doc/ploticus/fonts.html
+%%PORTDOCS%%share/doc/ploticus/functions.html
+%%PORTDOCS%%share/doc/ploticus/gall.lineplot.html
+%%PORTDOCS%%share/doc/ploticus/gall.scat.html
+%%PORTDOCS%%share/doc/ploticus/getdata.html
+%%PORTDOCS%%share/doc/ploticus/gifpatent.html
+%%PORTDOCS%%share/doc/ploticus/gpl.gif
+%%PORTDOCS%%share/doc/ploticus/import.html
+%%PORTDOCS%%share/doc/ploticus/index.html
+%%PORTDOCS%%share/doc/ploticus/interactive.html
+%%PORTDOCS%%share/doc/ploticus/legend.html
+%%PORTDOCS%%share/doc/ploticus/legenddriven.html
+%%PORTDOCS%%share/doc/ploticus/legendentry.html
+%%PORTDOCS%%share/doc/ploticus/license.jpg
+%%PORTDOCS%%share/doc/ploticus/limits.html
+%%PORTDOCS%%share/doc/ploticus/line.html
+%%PORTDOCS%%share/doc/ploticus/linedetails.html
+%%PORTDOCS%%share/doc/ploticus/lineplot.html
+%%PORTDOCS%%share/doc/ploticus/missingdata.html
+%%PORTDOCS%%share/doc/ploticus/new.gif
+%%PORTDOCS%%share/doc/ploticus/nonunix.html
+%%PORTDOCS%%share/doc/ploticus/originaldata.html
+%%PORTDOCS%%share/doc/ploticus/page.html
+%%PORTDOCS%%share/doc/ploticus/paper.html
+%%PORTDOCS%%share/doc/ploticus/pie.html
+%%PORTDOCS%%share/doc/ploticus/pl.1.html
+%%PORTDOCS%%share/doc/ploticus/ploticus.1.html
+%%PORTDOCS%%share/doc/ploticus/ploticus.gif
+%%PORTDOCS%%share/doc/ploticus/plpng.1.html
+%%PORTDOCS%%share/doc/ploticus/plshellsql.html
+%%PORTDOCS%%share/doc/ploticus/pltab.1.html
+%%PORTDOCS%%share/doc/ploticus/posters.html
+%%PORTDOCS%%share/doc/ploticus/prefab_chron.html
+%%PORTDOCS%%share/doc/ploticus/prefab_dist.html
+%%PORTDOCS%%share/doc/ploticus/prefab_draw.html
+%%PORTDOCS%%share/doc/ploticus/prefab_lines.html
+%%PORTDOCS%%share/doc/ploticus/prefab_pie.html
+%%PORTDOCS%%share/doc/ploticus/prefab_scat.html
+%%PORTDOCS%%share/doc/ploticus/prefab_stack.html
+%%PORTDOCS%%share/doc/ploticus/prefab_stdparms.html
+%%PORTDOCS%%share/doc/ploticus/prefab_vbars.html
+%%PORTDOCS%%share/doc/ploticus/prefabs.html
+%%PORTDOCS%%share/doc/ploticus/print.html
+%%PORTDOCS%%share/doc/ploticus/processdata.html
+%%PORTDOCS%%share/doc/ploticus/rangebar.html
+%%PORTDOCS%%share/doc/ploticus/rangesweep.html
+%%PORTDOCS%%share/doc/ploticus/scaleunits.html
+%%PORTDOCS%%share/doc/ploticus/scatterplot.html
+%%PORTDOCS%%share/doc/ploticus/scripts.html
+%%PORTDOCS%%share/doc/ploticus/shell.html
+%%PORTDOCS%%share/doc/ploticus/slides.html
+%%PORTDOCS%%share/doc/ploticus/specialchars.html
+%%PORTDOCS%%share/doc/ploticus/sql.html
+%%PORTDOCS%%share/doc/ploticus/svg.html
+%%PORTDOCS%%share/doc/ploticus/symboldetails.html
+%%PORTDOCS%%share/doc/ploticus/tabulate.html
+%%PORTDOCS%%share/doc/ploticus/textdetails.html
+%%PORTDOCS%%share/doc/ploticus/times.html
+%%PORTDOCS%%share/doc/ploticus/trailer.html
+%%PORTDOCS%%share/doc/ploticus/transform.html
+%%PORTDOCS%%share/doc/ploticus/variables.html
+%%PORTDOCS%%share/doc/ploticus/web.html
+%%PORTDOCS%%@dirrm share/doc/ploticus