aboutsummaryrefslogtreecommitdiff
path: root/math/plplot
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-03-06 15:04:23 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-03-06 15:04:23 +0000
commit2f498ee636118028e9ab633fabeea250353b5552 (patch)
treeca6578f6db8e1e219257eaff6636dcd38f2ccedd /math/plplot
parente0a959491b0bd6a0a561ce88143456f28d156bde (diff)
downloadports-2f498ee636118028e9ab633fabeea250353b5552.tar.gz
ports-2f498ee636118028e9ab633fabeea250353b5552.zip
If another port defines HAVE_CONFIG_H and includes plConfig.h, this
tries to bring plplot_config.h, which is not installed, but plplot_config.h is required when we build plplot. E.g. science/gnudatalanguage does that.
Notes
Notes: svn path=/head/; revision=347247
Diffstat (limited to 'math/plplot')
-rw-r--r--math/plplot/Makefile2
-rw-r--r--math/plplot/files/patch-include_plConfig.h12
2 files changed, 14 insertions, 0 deletions
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index d36ad5dbaf94..8c029e70beef 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -3,6 +3,7 @@
PORTNAME= plplot
PORTVERSION= 5.10.0
+PORTREVISION= 1
CATEGORIES= math science
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}%20Source
@@ -32,6 +33,7 @@ CMAKE_ARGS= -DENABLE_java:BOOL=OFF -DENABLE_octave:BOOL=OFF \
-DENABLE_pyqt4:BOOL=OFF \
-DPL_FREETYPE_FONT_PATH:PATH="${FREEFONT_DIR}" \
-DPLD_plmeta:BOOL=OFF
+CFLAGS+= -D_IS_BUILDING_PLPLOT_PORT_
USE_AUTOTOOLS= libltdl
USE_LDCONFIG= yes
diff --git a/math/plplot/files/patch-include_plConfig.h b/math/plplot/files/patch-include_plConfig.h
new file mode 100644
index 000000000000..8b6a45fd788b
--- /dev/null
+++ b/math/plplot/files/patch-include_plConfig.h
@@ -0,0 +1,12 @@
+--- include/plConfig.h.in.orig 2013-12-29 21:11:07.000000000 +0100
++++ include/plConfig.h.in 2014-03-06 15:35:44.000000000 +0100
+@@ -44,7 +44,8 @@
+ #ifndef __PLCONFIG_H__
+ #define __PLCONFIG_H__
+
+-#ifdef HAVE_CONFIG_H
++// plplot_config.h won't be installed: don't let it be used by consumers
++#if defined(HAVE_CONFIG_H) && defined(_IS_BUILDING_PLPLOT_PORT_)
+ # include <plplot_config.h>
+ #endif
+