aboutsummaryrefslogtreecommitdiff
path: root/math/py-numpy/files
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-11-15 05:50:40 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-11-15 05:50:40 +0000
commit9c54ff04c118e799b11d9593734a2f07cf8dafd2 (patch)
treef646e66d8241031bdb2f34281af4ad9d90e84e87 /math/py-numpy/files
parentce6c07ab82ae7f5d1b5b7516ab75f025c3ae5b4f (diff)
downloadports-9c54ff04c118e799b11d9593734a2f07cf8dafd2.tar.gz
ports-9c54ff04c118e799b11d9593734a2f07cf8dafd2.zip
- Update to 1.0rc1
- Add options for ATLAS - Fix ATLAS detection - Use feclearexcept(3) rather than fpsetsticky(3) on 5.3+ - Add CONFLICTS for f2py. Both ports install bin/f2py PR: ports/103827 Submitted by: Li-Lun Wang Approved by: maintainer timeout (6 weeks)
Notes
Notes: svn path=/head/; revision=177291
Diffstat (limited to 'math/py-numpy/files')
-rw-r--r--math/py-numpy/files/patch-numpy-core-include-numpy-ufuncobject.h26
-rw-r--r--math/py-numpy/files/patch-numpy-distutils-fcompiler-__init__.py15
-rw-r--r--math/py-numpy/files/patch-numpy-distutils-system_info.py11
-rw-r--r--math/py-numpy/files/patch-numpy_f2py_setup.py12
-rw-r--r--math/py-numpy/files/patch-system_info.py11
-rw-r--r--math/py-numpy/files/site.cfg3
6 files changed, 67 insertions, 11 deletions
diff --git a/math/py-numpy/files/patch-numpy-core-include-numpy-ufuncobject.h b/math/py-numpy/files/patch-numpy-core-include-numpy-ufuncobject.h
new file mode 100644
index 000000000000..3382e09819b9
--- /dev/null
+++ b/math/py-numpy/files/patch-numpy-core-include-numpy-ufuncobject.h
@@ -0,0 +1,26 @@
+--- numpy/core/include/numpy/ufuncobject.h.orig Wed Sep 13 22:22:47 2006
++++ numpy/core/include/numpy/ufuncobject.h Fri Sep 29 16:35:25 2006
+@@ -251,7 +251,10 @@
+ /* Solaris --------------------------------------------------------*/
+ /* --------ignoring SunOS ieee_flags approach, someone else can
+ ** deal with that! */
+-#elif defined(sun) || defined(__BSD__) || defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__NetBSD__)
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
++#elif defined(sun) || defined(__BSD__) || defined(__OpenBSD__) || (defined(__FreeBSD__) && (__FreeBSD_version < 502114)) || defined(__NetBSD__)
+ #include <ieeefp.h>
+
+ #define UFUNC_CHECK_STATUS(ret) { \
+@@ -265,9 +268,9 @@
+ (void) fpsetsticky(0); \
+ }
+
+-#elif defined(linux) || defined(__APPLE__) || defined(__CYGWIN__) || defined(__MINGW32__)
++#elif defined(linux) || defined(__APPLE__) || defined(__CYGWIN__) || defined(__MINGW32__) || (defined(__FreeBSD__) && (__FreeBSD_version >= 502114))
+
+-#if defined(__GLIBC__) || defined(__APPLE__) || defined(__MINGW32__)
++#if defined(__GLIBC__) || defined(__APPLE__) || defined(__MINGW32__) || (defined(__FreeBSD__) && (__FreeBSD_version >= 502114))
+ #include <fenv.h>
+ #elif defined(__CYGWIN__)
+ #include "fenv/fenv.c"
diff --git a/math/py-numpy/files/patch-numpy-distutils-fcompiler-__init__.py b/math/py-numpy/files/patch-numpy-distutils-fcompiler-__init__.py
new file mode 100644
index 000000000000..63df1556e8d5
--- /dev/null
+++ b/math/py-numpy/files/patch-numpy-distutils-fcompiler-__init__.py
@@ -0,0 +1,15 @@
+--- numpy/distutils/fcompiler/__init__.py.orig Tue Oct 3 20:39:58 2006
++++ numpy/distutils/fcompiler/__init__.py Tue Oct 3 22:43:18 2006
+@@ -268,11 +268,7 @@
+ f90 = self.__get_cmd('compiler_f90','F90',(conf,'f90exec'))
+ # Temporarily setting f77,f90 compilers so that
+ # version_cmd can use their executables.
+- if f77:
+- self.set_executables(compiler_f77=[f77])
+- if f90:
+- self.set_executables(compiler_f90=[f90])
+-
++ # If you do that, --f77exec and --f90exec break -db
+ # Must set version_cmd before others as self.get_flags*
+ # methods may call self.get_version.
+ vers_cmd = self.__get_cmd(self.get_version_cmd)
diff --git a/math/py-numpy/files/patch-numpy-distutils-system_info.py b/math/py-numpy/files/patch-numpy-distutils-system_info.py
new file mode 100644
index 000000000000..60983bbdefaf
--- /dev/null
+++ b/math/py-numpy/files/patch-numpy-distutils-system_info.py
@@ -0,0 +1,11 @@
+--- numpy/distutils/system_info.py.orig Sun Jul 30 11:08:48 2006
++++ numpy/distutils/system_info.py Fri Sep 29 12:22:29 2006
+@@ -855,6 +855,8 @@
+ atlas_1 = None
+ for d in lib_dirs:
+ atlas = self.check_libs2(d,atlas_libs,[])
++ if atlas is not None:
++ atlas['libraries'].extend(['g2c', 'm', 'pthread'])
+ lapack_atlas = self.check_libs2(d,['lapack_atlas'],[])
+ if atlas is not None:
+ lib_dirs2 = [d] + self.combine_paths(d,['atlas*','ATLAS*'])
diff --git a/math/py-numpy/files/patch-numpy_f2py_setup.py b/math/py-numpy/files/patch-numpy_f2py_setup.py
new file mode 100644
index 000000000000..a1ca10e8ab0b
--- /dev/null
+++ b/math/py-numpy/files/patch-numpy_f2py_setup.py
@@ -0,0 +1,12 @@
+--- numpy/f2py/setup.py.orig Sat Sep 23 05:25:27 2006
++++ numpy/f2py/setup.py Sat Sep 23 05:25:41 2006
+@@ -32,8 +32,7 @@
+ config.add_data_dir('docs')
+
+ config.add_data_files('src/fortranobject.c',
+- 'src/fortranobject.h',
+- 'f2py.1'
++ 'src/fortranobject.h'
+ )
+
+ config.make_svn_version_py()
diff --git a/math/py-numpy/files/patch-system_info.py b/math/py-numpy/files/patch-system_info.py
deleted file mode 100644
index 8e0eb1361b68..000000000000
--- a/math/py-numpy/files/patch-system_info.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- numpy/distutils/system_info.py.orig Thu Jul 27 19:44:41 2006
-+++ numpy/distutils/system_info.py Thu Jul 27 19:39:18 2006
-@@ -811,7 +811,7 @@
- dir_env_var = 'ATLAS'
- _lib_names = ['f77blas','cblas']
- if sys.platform[:7]=='freebsd':
-- _lib_atlas = ['atlas_r']
-+ _lib_atlas = ['atlas_r', 'g2c']
- _lib_lapack = ['alapack_r']
- else:
- _lib_atlas = ['atlas']
diff --git a/math/py-numpy/files/site.cfg b/math/py-numpy/files/site.cfg
new file mode 100644
index 000000000000..badb3f67e602
--- /dev/null
+++ b/math/py-numpy/files/site.cfg
@@ -0,0 +1,3 @@
+[atlas]
+library_dirs = /usr/local/lib
+atlas_libs = alapack_r, f77blas_r, cblas_r, atlas_r