aboutsummaryrefslogtreecommitdiff
path: root/math/py-numpy
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-01-18 07:07:57 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-01-18 07:07:57 +0000
commitcbebfac84968d9314b94b9dcbd1bb28a5dc4a0fc (patch)
tree5bd79ac2fecc7c935ef8f766c3bfb64be951bc2b /math/py-numpy
parent14fb3bb808a37bff1b902989f5d6f0a4e68d08c6 (diff)
downloadports-cbebfac84968d9314b94b9dcbd1bb28a5dc4a0fc.tar.gz
ports-cbebfac84968d9314b94b9dcbd1bb28a5dc4a0fc.zip
* Migrate to gfortran.
* Bump port revision. Approved by: portmgr(kris)
Notes
Notes: svn path=/head/; revision=182696
Diffstat (limited to 'math/py-numpy')
-rw-r--r--math/py-numpy/Makefile7
-rw-r--r--math/py-numpy/files/patch-numpy-distutils-system_info.py2
2 files changed, 5 insertions, 4 deletions
diff --git a/math/py-numpy/Makefile b/math/py-numpy/Makefile
index da77b3ef09df..c5818c72bdd0 100644
--- a/math/py-numpy/Makefile
+++ b/math/py-numpy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= numpy
PORTVERSION= 1.0.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= math python
MASTER_SITES= http://numpy.scipy.org/:doc \
@@ -34,13 +35,13 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/r/rc/}
.include <bsd.port.pre.mk>
.if defined(WITH_ATLAS)
-LIB_DEPENDS+= atlas.1:${PORTSDIR}/math/atlas
+LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
.if !exists(${LOCALBASE}/lib/libalapack.a)
IGNORE= atlas needs to be built with WITH_STATICLIB for numpy to function properly
.endif
.else
-LIB_DEPENDS+= lapack.3:${PORTSDIR}/math/lapack \
- blas.1:${PORTSDIR}/math/blas
+LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack \
+ blas.2:${PORTSDIR}/math/blas
.endif
.if ${OSVERSION} < 500000
diff --git a/math/py-numpy/files/patch-numpy-distutils-system_info.py b/math/py-numpy/files/patch-numpy-distutils-system_info.py
index b5c52e190285..c0615d0d0386 100644
--- a/math/py-numpy/files/patch-numpy-distutils-system_info.py
+++ b/math/py-numpy/files/patch-numpy-distutils-system_info.py
@@ -5,7 +5,7 @@
for d in lib_dirs:
atlas = self.check_libs2(d,atlas_libs,[])
+ if atlas is not None:
-+ atlas['libraries'].extend(['g2c', 'm', 'pthread'])
++ atlas['libraries'].extend(['gfortran', 'm', 'pthread'])
lapack_atlas = self.check_libs2(d,['lapack_atlas'],[])
if atlas is not None:
lib_dirs2 = [d] + self.combine_paths(d,['atlas*','ATLAS*'])