aboutsummaryrefslogtreecommitdiff
path: root/math/py-patsy
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-11-11 20:32:09 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-11-11 20:32:09 +0000
commit1d6d865274b61986b5bb027cbad2078aeabf87f2 (patch)
treef980e6119cacea482b744e10c9f5c78acc8ff705 /math/py-patsy
parentbf15b4d5857dbc1a7ffe536202930ce4ff8bc925 (diff)
downloadports-1d6d865274b61986b5bb027cbad2078aeabf87f2.tar.gz
ports-1d6d865274b61986b5bb027cbad2078aeabf87f2.zip
math/py-patsy: Python package for statistical models and design matrices
Patsy is a Python library for describing statistical models (especially linear models, or models that have a linear component) and building design matrices. Patsy brings the convenience of R "formulas" to Python. WWW: https://www.github.com/pydata/patsy PR: ports/183870 Submitted by: Johannes Jost Meixner <xmj chaot.net>
Notes
Notes: svn path=/head/; revision=333533
Diffstat (limited to 'math/py-patsy')
-rw-r--r--math/py-patsy/Makefile48
-rw-r--r--math/py-patsy/distinfo2
-rw-r--r--math/py-patsy/files/patch-setup.py10
-rw-r--r--math/py-patsy/pkg-descr5
4 files changed, 65 insertions, 0 deletions
diff --git a/math/py-patsy/Makefile b/math/py-patsy/Makefile
new file mode 100644
index 000000000000..e30e5c7855ec
--- /dev/null
+++ b/math/py-patsy/Makefile
@@ -0,0 +1,48 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= patsy
+PORTVERSION= 0.2.1
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= xmj@chaot.net
+COMMENT= Python package for statistical models and design matrices
+
+LICENSE= BSD
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_AUTOPLIST= yes
+
+PORTDOCS= API-reference.rst \
+ R-comparison.rst \
+ builtins-reference.rst \
+ categorical-coding.rst \
+ changes.rst \
+ expert-model-specification.rst \
+ formulas.rst \
+ index.rst \
+ library-developers.rst \
+ overview.rst \
+ py2-versus-py3.rst \
+ quickstart.rst \
+ stateful-transforms.rst \
+
+PORTEXAMPLES= add_predictors.py \
+ example_lm.py \
+ example_treatment.py
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/doc/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/doc/_examples/|} ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/math/py-patsy/distinfo b/math/py-patsy/distinfo
new file mode 100644
index 000000000000..63801d1dade5
--- /dev/null
+++ b/math/py-patsy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (patsy-0.2.1.tar.gz) = 31374ce25275813d8f1c48bdda40bba06f7a16cce7dcdfad73f43a555393d065
+SIZE (patsy-0.2.1.tar.gz) = 316115
diff --git a/math/py-patsy/files/patch-setup.py b/math/py-patsy/files/patch-setup.py
new file mode 100644
index 000000000000..d98732e4ae18
--- /dev/null
+++ b/math/py-patsy/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- ./setup.py.orig 2013-08-20 18:59:30.000000000 +0300
++++ ./setup.py 2013-11-11 16:18:52.782247350 +0200
+@@ -27,7 +27,6 @@
+ license="2-clause BSD",
+ packages=["patsy"],
+ url="https://github.com/pydata/patsy",
+- install_requires=["numpy"],
+ classifiers =
+ [ "Development Status :: 4 - Beta",
+ "Intended Audience :: Developers",
diff --git a/math/py-patsy/pkg-descr b/math/py-patsy/pkg-descr
new file mode 100644
index 000000000000..019bd1ecb5fd
--- /dev/null
+++ b/math/py-patsy/pkg-descr
@@ -0,0 +1,5 @@
+Patsy is a Python library for describing statistical models (especially linear
+models, or models that have a linear component) and building design matrices.
+Patsy brings the convenience of R "formulas" to Python.
+
+WWW: https://www.github.com/pydata/patsy