aboutsummaryrefslogtreecommitdiff
path: root/math/randlib/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-11-14 09:43:39 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-11-14 09:43:39 +0000
commit96bc8048c3217bb231f2f30eadeb628134b557f5 (patch)
treec75d5bd5a6faba5d6ec73da367e4bfe5b0d4285d /math/randlib/Makefile
parent637c4e8f19438274164c0673ec85af739aba205b (diff)
downloadports-96bc8048c3217bb231f2f30eadeb628134b557f5.tar.gz
ports-96bc8048c3217bb231f2f30eadeb628134b557f5.zip
Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
shell loops to make loops. Use EXTRA_PKG_FLAGS to add install scripts instead of adding it to PKG_FLAGS after bsd.port.mk.
Notes
Notes: svn path=/head/; revision=14512
Diffstat (limited to 'math/randlib/Makefile')
-rw-r--r--math/randlib/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/math/randlib/Makefile b/math/randlib/Makefile
index 7f899107d9ed..427dbe91cabf 100644
--- a/math/randlib/Makefile
+++ b/math/randlib/Makefile
@@ -3,7 +3,7 @@
# Date created: 06 April 1997
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.2 1997/04/23 06:57:54 tg Exp $
+# $Id: Makefile,v 1.3 1998/10/26 07:45:01 asami Exp $
#
DISTNAME= ranlib.c
@@ -15,6 +15,8 @@ MAINTAINER= tg@FreeBSD.ORG
WRKSRC= ${WRKDIR}/${DISTNAME}/src
+.include <bsd.port.pre.mk>
+
post-extract:
@${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}/Makefile
@@ -23,9 +25,9 @@ post-install:
@${MKDIR} ${PREFIX}/share/doc/ranlib
@${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/doc/* ${PREFIX}/share/doc/ranlib
.endif
- if [ "${PORTOBJFORMAT}" = "aout" ]; then \
- ${LN} -sf libranlib.so.1.0 ${PREFIX}/lib/libranlib.so; \
- fi
+.if ${PORTOBJFORMAT} == "aout"
+ ${LN} -sf libranlib.so.1.0 ${PREFIX}/lib/libranlib.so
+.endif
@${LDCONFIG} -m ${PREFIX}/lib
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>