aboutsummaryrefslogtreecommitdiff
path: root/math/rpy2/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-10-31 01:47:04 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-10-31 01:47:04 +0000
commit11f91702a0fd3bf54e6250f221aba58f9770375b (patch)
treec8161de820bc2fc0a305942f3b0d905b1d1e6c0b /math/rpy2/Makefile
parentb90670448cfd2b2212a078d762a02dfbe0d3316b (diff)
downloadports-11f91702a0fd3bf54e6250f221aba58f9770375b.tar.gz
ports-11f91702a0fd3bf54e6250f221aba58f9770375b.zip
add rpy 0.3.1
Python interface to the R Programming Language
Notes
Notes: svn path=/head/; revision=92667
Diffstat (limited to 'math/rpy2/Makefile')
-rw-r--r--math/rpy2/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/math/rpy2/Makefile b/math/rpy2/Makefile
new file mode 100644
index 000000000000..269723e0d864
--- /dev/null
+++ b/math/rpy2/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: rpy
+# Date created: Jan 14, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= rpy
+PORTVERSION= 0.3.1
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Python interface to the R Programming Language
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/Numeric.pth:${PORTSDIR}/math/py-numeric \
+ R:${PORTSDIR}/math/R-letter
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib/R/modules"
+
+.include <bsd.port.mk>