aboutsummaryrefslogtreecommitdiff
path: root/math/scilab-toolbox-swt/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-06-20 13:38:07 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-06-20 13:38:07 +0000
commita69d39e7bd40b55cb5b373a63f26936cbee97693 (patch)
treec681d2cf139044411495151c55e952e1443cd6c6 /math/scilab-toolbox-swt/Makefile
parent3f17f105e20bd10c9e77bcc1509c61024f60a15f (diff)
downloadports-a69d39e7bd40b55cb5b373a63f26936cbee97693.tar.gz
ports-a69d39e7bd40b55cb5b373a63f26936cbee97693.zip
- Update to 0.1.0 RC4
- Remove unnecessary gfortran settings PR: ports/113836 Submitted by: Max Brazhnikov <makc at issp.ac.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=193944
Diffstat (limited to 'math/scilab-toolbox-swt/Makefile')
-rw-r--r--math/scilab-toolbox-swt/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/math/scilab-toolbox-swt/Makefile b/math/scilab-toolbox-swt/Makefile
index 1c3fdb6f559a..a18eb367ab1f 100644
--- a/math/scilab-toolbox-swt/Makefile
+++ b/math/scilab-toolbox-swt/Makefile
@@ -6,36 +6,32 @@
#
PORTNAME= swt
-PORTVERSION= 0.1.0.r3
-PORTREVISION= 2
+DISTVERSION= 0.1.0rc4
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= scwt
PKGNAMEPREFIX= scilab-toolbox-
-DISTNAME= ${PORTNAME}-0.1.0rc3
+DISTNAME= ${PORTNAME}${DISTVERSION}
MAINTAINER= makc@issp.ac.ru
COMMENT= Scilab 1-D and 2-D Wavelet Toolbox
-BUILD_DEPENDS+= scilab:${PORTSDIR}/math/scilab
+BUILD_DEPENDS= ${LOCALBASE}/bin/scilab:${PORTSDIR}/math/scilab
+RUN_DEPENDS= ${BUILD_DEPENDS}
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
-CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
-USE_LDCONFIG= yes
-LDCONFIG_DIRS+= %%PREFIX%%/lib/scilab/contrib/swt/lib
+SCI= ${LOCALBASE}/lib/scilab
+TOOLBOXDIR?= lib/scilab/contrib/swt
HAS_CONFIGURE= yes
-CONFIGURE_ARGS+=--prefix=${PREFIX}/lib/scilab/contrib/swt
-TOOLBOXDIR= lib/scilab/contrib/swt
+CONFIGURE_ARGS+=--prefix=${PREFIX}/${TOOLBOXDIR}
+CONFIGURE_ENV+= SCI="${SCI}"
+USE_LDCONFIG= ${PREFIX}/${TOOLBOXDIR}
+
PLIST_SUB= TOOLBOXDIR=${TOOLBOXDIR}
-post-install@:
- @${ECHO_MSG} "==========================================================="
- @${ECHO_MSG} "NOTE: SWT should be recompiled whenever Scilab is upgraded."
- @${ECHO_MSG} "==========================================================="
+post-install:
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>