aboutsummaryrefslogtreecommitdiff
path: root/math/scilab
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-11-14 20:21:13 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-11-14 20:21:13 +0000
commit9af90b00563cd93a22274ba9c3491a2f66e2c238 (patch)
tree95d3fd102a7844494e4d701b169db2d52f1a7548 /math/scilab
parent30f0edef4145f0607c5af9e069d9cc1efa6d86b4 (diff)
downloadports-9af90b00563cd93a22274ba9c3491a2f66e2c238.tar.gz
ports-9af90b00563cd93a22274ba9c3491a2f66e2c238.zip
Made math/scilab building on -current again
Noticed on: bento Approved by: Jean-Sebastien Roy <js@jeannot.org> (approved)
Notes
Notes: svn path=/head/; revision=70127
Diffstat (limited to 'math/scilab')
-rw-r--r--math/scilab/Makefile53
1 files changed, 50 insertions, 3 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index 5ca2454c6072..bbcafedfe3c1 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -26,6 +26,7 @@ PVM_ROOT= ${PREFIX}/lib/pvm
NO_CDROM= "Don't sell for profit."
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
CONFIGURE_ARGS= --without-xless --with-tk \
--with-tk-library=${PREFIX}/lib --with-tk-include=${PREFIX}/include/tk8.3 \
@@ -42,13 +43,59 @@ post-extract:
${RM} ${WRKSRC}/examples/callsci/callsciC++/config/config
pre-patch:
- @${PERL} -pi -e 's|\r\n|\n|' ${WRKSRC}/macros/util/formatman.sci
+ ${TR} -d '\015' < ${WRKSRC}/macros/util/formatman.sci \
+ > ${WRKSRC}/macros/util/formatman.sci.new
+ ${MV} ${WRKSRC}/macros/util/formatman.sci.new \
+ ${WRKSRC}/macros/util/formatman.sci
post-patch:
- @${PERL} -pi -e 's,%%PVM_ROOT%%,${PVM_ROOT},' \
+ @${REINPLACE_CMD} -e 's,%%PVM_ROOT%%,${PVM_ROOT},' \
${WRKSRC}/scripts/scilab.g
+ # malloc.h -> stdlib.h conversions
+ for file in \
+ examples/intersci-examples/ex6c.c \
+ examples/intersci-examples/ex8c.c \
+ examples/intersci-examples/ex9c.c \
+ examples/interface-tour/pgmsc.c \
+ examples/intersci-examples-so/ex06c.c \
+ examples/intersci-examples-so/ex09c.c \
+ examples/intersci-examples-so/ex08c.c imp/Slatexpr2.c \
+ imp/Slatexprs.c imp/Slpr.c imp/SEpsf.c imp/Slatexpr.c \
+ intersci/intersci.h intersci/intersci-n.h \
+ pvm3/src/imalloc.c routines/calelm/sci_tools.c \
+ routines/comm/messages.c routines/metanet/connex.c \
+ routines/metanet/metanet.c routines/metanet/dmtree.c \
+ routines/metanet/files.c routines/metanet/loadg.c \
+ routines/metanet/paths.c routines/metanet/saveg.c \
+ routines/metanet/show.c routines/metanet/transc.c \
+ routines/metanet/myhsearch.c routines/default/scimem.c \
+ routines/default/Funtab.c routines/sparse/spDefs.h \
+ routines/sun/link.c routines/sun/addinter.c \
+ routines/sun/men_Sutils.c routines/sun/h_help_data.c \
+ routines/xsci/jpc_command.c routines/xsci/jpc_utils.c \
+ routines/xsci/wf_e_edit.c routines/xsci/wf_w_dir.c \
+ routines/xsci/wf_w_file.c routines/xsci/x_button.c \
+ routines/xsci/x_charproc.c routines/xsci/x_screen.c \
+ routines/xsci/x_scrollbar.c routines/xsci/x_test_loop.c \
+ routines/xsci/x_screen.nok.c routines/xsci/jpc_SGraph.c \
+ routines/xsci/jpc_Xloop.c routines/xsci/jpc_coloredit.c \
+ routines/xsci/jpc_SGraph.c.in \
+ routines/libcomm/gest_memoire.c routines/sound/fileio.c \
+ routines/sound/sprintf_ptr.c routines/wsci/winmain.c \
+ routines/wsci/wmprint.c routines/wsci/runscilab.c \
+ routines/wsci/wmtex.c routines/pvm/sci_tools.c \
+ routines/graphics/RecLoad.c routines/graphics/periFig.c \
+ routines/graphics/periPos.c routines/graphics/Math.h \
+ routines/graphics/periGif.c xless/xless.h xmetanet/comm.c \
+ xmetanet/dialog.c xmetanet/file.c xmetanet/graph.c \
+ xmetanet/graphics.c xmetanet/list.c xmetanet/load.c \
+ xmetanet/myhsearch.c xmetanet/name.c xmetanet/save.c; do \
+ ${REINPLACE_CMD} -e \
+ 's/[<"]malloc.h[>"]/<stdlib.h>/' ${WRKSRC}/$${file}; \
+ done
pre-install:
- find ${WRKSRC} -name \*.orig -delete
+ ${FIND} ${WRKSRC} -name \*.orig -delete
+ ${FIND} ${WRKSRC} -name \*.bak -delete
.include <bsd.port.mk>