aboutsummaryrefslogtreecommitdiff
path: root/math/sdpa
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-11-22 11:14:10 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-11-22 11:14:10 +0000
commit004a7c5ac21475f760354371ae4f8fca5e556acb (patch)
tree47b9539be8bb171263921a641d850025fee218cc /math/sdpa
parentbcfacab8772c0f3bf72412386eb13f58def6bef2 (diff)
downloadports-004a7c5ac21475f760354371ae4f8fca5e556acb.tar.gz
ports-004a7c5ac21475f760354371ae4f8fca5e556acb.zip
adjust linking and comments in dependent ports after the math/atlas update;
math/atlas-devel will be updated to use the same constructs at a later date PR: 162706 Approved by: miwi (portmgr) Feature safe: yes
Notes
Notes: svn path=/head/; revision=286242
Diffstat (limited to 'math/sdpa')
-rw-r--r--math/sdpa/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/math/sdpa/Makefile b/math/sdpa/Makefile
index 8b5da3c04dfb..46d7aec41a9c 100644
--- a/math/sdpa/Makefile
+++ b/math/sdpa/Makefile
@@ -24,28 +24,29 @@ USE_FORTRAN= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}.${PORTVERSION}.src
-USE_BLAS?= reference
.if exists(${LOCALBASE}/lib/libgoto2.so)
-USE_BLAS= gotoblas
-.elif exists(${LOCALBASE}/lib/libatlas_r.so)
-USE_BLAS= atlas
+WITH_BLAS?= gotoblas
+.elif exists(${LOCALBASE}/lib/libatlas.so)
+WITH_BLAS?= atlas
+.else
+WITH_BLAS?= reference
.endif
-. if ${USE_BLAS} == reference
+. if ${WITH_BLAS} == reference
LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lblas
LAPACK= -llapack
-.elif ${USE_BLAS} == gotoblas
+.elif ${WITH_BLAS} == gotoblas
LIB_DEPENDS+= goto2:${PORTSDIR}/math/gotoblas
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
BLAS= -lgoto2p
LAPACK=
-.elif ${USE_BLAS} == atlas
+.elif ${WITH_BLAS} == atlas
LIB_DEPENDS+= atlas:${PORTSDIR}/math/atlas
-BLAS= -lptf77blas -lptcblas -latlas_r
-LAPACK= -lalapack_r
+BLAS= -lptf77blas
+LAPACK= -lalapack -lptcblas
.endif
CONFIGURE_ARGS+=--with-blas="-L${LOCALBASE}/lib ${BLAS}" --with-lapack="-L${LOCALBASE}/lib ${LAPACK}"